Bug 488450 - The keyboard stops working in a terminal window when a mouse pointer is over it.
The keyboard stops working in a terminal window when a mouse pointer is over it.
Status: CLOSED DUPLICATE of bug 488445
Product: Fedora
Classification: Fedora
Component: xorg-x11-apps (Show other bugs)
10
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 07:57 EST by vaxon
Modified: 2009-05-18 07:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 03:57:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vaxon 2009-03-04 07:57:37 EST
Description of problem:
After the last update of my Fedora 10 the keyboard stops working in a terminal window if a mouse pointer is moved over it. If I move the pointer outside the window's area, it works fine. The problem can be reproduced in any DE. I've tried xterm and konsole in Gnome and fluxbox in particular.

Here's the list of updated packages:
Mar 04 02:46:06 Updated: gvfs-1.0.3-6.fc10.x86_64
Mar 04 02:46:07 Updated: audit-libs-1.7.12-1.fc10.x86_64
Mar 04 02:46:14 Updated: evolution-data-server-2.24.5-1.fc10.x86_64
Mar 04 02:46:15 Updated: 1:cups-libs-1.3.9-8.fc10.x86_64
Mar 04 02:46:15 Updated: SDL-1.2.13-7.fc10.x86_64
Mar 04 02:46:18 Updated: libgxim-0.3.2-3.fc10.x86_64
Mar 04 02:46:18 Updated: linuxwacom-0.8.0.3-8.fc10.x86_64
Mar 04 02:46:20 Updated: soprano-2.2.3-1.fc10.x86_64
Mar 04 02:46:24 Updated: gtkhtml3-3.24.5-1.fc10.x86_64
Mar 04 02:46:38 Updated: selinux-policy-3.5.13-46.fc10.noarch
Mar 04 02:46:42 Updated: evolution-data-server-doc-2.24.5-1.fc10.x86_64
Mar 04 02:46:43 Updated: kernel-firmware-2.6.27.19-170.2.35.fc10.noarch
Mar 04 02:47:01 Installed: system-config-date-1.9.36-1.fc10.noarch
Mar 04 02:47:02 Updated: audit-1.7.12-1.fc10.x86_64
Mar 04 02:47:28 Installed: kernel-2.6.27.19-170.2.35.fc10.x86_64
Mar 04 02:47:29 Updated: SDL-devel-1.2.13-7.fc10.x86_64
Mar 04 02:47:32 Updated: 1:cups-1.3.9-8.fc10.x86_64
Mar 04 02:47:34 Updated: kernel-headers-2.6.27.19-170.2.35.fc10.x86_64
Mar 04 02:47:35 Installed: system-config-date-docs-1.0.5-1.fc10.noarch
Mar 04 02:47:40 Installed: kernel-devel-2.6.27.19-170.2.35.fc10.x86_64
Mar 04 02:47:40 Updated: gvfs-obexftp-1.0.3-6.fc10.x86_64
Mar 04 02:47:40 Updated: audit-libs-python-1.7.12-1.fc10.x86_64
Mar 04 02:47:41 Updated: alsa-utils-1.0.19-2.fc10.x86_64
Mar 04 02:47:55 Updated: selinux-policy-targeted-3.5.13-46.fc10.noarch
Mar 04 02:47:55 Updated: gvfs-gphoto2-1.0.3-6.fc10.x86_64
Mar 04 02:47:55 Updated: gvfs-fuse-1.0.3-6.fc10.x86_64
Mar 04 02:47:56 Updated: gvfs-archive-1.0.3-6.fc10.x86_64
Mar 04 02:47:56 Updated: xmlto-0.0.21-4.fc10.x86_64
Mar 04 02:47:57 Updated: evolution-data-server-devel-2.24.5-1.fc10.x86_64
Mar 04 02:47:57 Updated: gvfs-smb-1.0.3-6.fc10.x86_64
Mar 04 02:47:57 Updated: xorg-x11-drv-vmmouse-12.6.3-3.fc10.x86_64
Mar 04 02:48:15 Installed: kernel-2.6.27.19-170.2.35.fc10.x86_64

The problem appeared after the above update.

I tried to roll back to the previous kernel and xorg-x11-drv-vmmouse versions, but it didn't help. I have a x86_64 Core i7 system, a USB BTC keyboard and mouse. The videocard is a NVidia gtx260 and the nvidia driver version is 180.22.
Version-Release number of selected component (if applicable):


How reproducible:
Start Gnome or fluxbox. Start xterm or konsole. Try to type anything in the console window when the mouse pointer is inside the window's area.

Steps to Reproduce:
1. Start Gnome or fluxbox.
2. Start xterm or konsole.
3. Try to type anything in the console window when the mouse pointer is inside the window's area.
  
Actual results:
The typed text doesn't appear in the console window.

Expected results:
The typed text should appear in the console window.

Additional info:
Comment 1 vaxon 2009-03-04 08:19:41 EST
The bug is always reproducible.
Comment 2 vaxon 2009-03-04 08:22:11 EST
SElinux is off.
Comment 3 Alex Chiang 2009-03-04 14:21:37 EST
I tripped over this too using default gnome window manager.

alt-f6 to switch to the text console still works, even when the xterm no longer receives input.

I can login to the text console and everything seems to work just fine.

I thought it might have been an interrupt storm, but /proc/interrupts doesn't show anything unusual.
Comment 4 Alex Chiang 2009-03-04 14:25:05 EST
These bugzillas seem like they might be related:

https://bugzilla.redhat.com/show_bug.cgi?id=488445
https://bugzilla.redhat.com/show_bug.cgi?id=487908

The first one in particular claims that if you update libgxim, it solves the issue.

I haven't had a chance to try this yet. Vaxon, wanna give it a shot?
Comment 5 vaxon 2009-03-04 16:58:00 EST
Thanks Alex,
I've updated libgxim to version 0.3.2-4.fc10.x86_64 and it seems to have solved the problem. The keyboard input seems to work fine now.

Thanks,
Vax.
Comment 6 Martin A. Boegelund 2009-03-04 17:30:57 EST
Hi,

I experienced a similar problem:
After updating my Fedora 10 installation, keyboard input to games didn't work. I confirmed this for "Frozen Bubble 2", "Powermanga" and "Warzone 2100".

I located this bug report, updated libgxim to libgxim-0.3.2-4.fc10 (from the download location given in bug #488445), and it fixed the problem.
Comment 7 Matěj Cepl 2009-03-05 03:57:18 EST

*** This bug has been marked as a duplicate of bug 488445 ***

Note You need to log in before you can comment on or make changes to this bug.