Bug 488534 - RfE New upstream release is available
RfE New upstream release is available
Status: CLOSED DUPLICATE of bug 523018
Product: Fedora
Classification: Fedora
Component: gnustep-make (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 475852
  Show dependency treegraph
 
Reported: 2009-03-04 13:14 EST by Jochen Schmitt
Modified: 2009-09-13 13:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-13 13:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed SPEC file for gnustep-make-2.0.8 (3.78 KB, text/plain)
2009-03-04 13:14 EST, Jochen Schmitt
no flags Details
Diff to existing 2.0.6 specfile (2.10 KB, patch)
2009-03-12 18:54 EDT, Michel Alexandre Salim
no flags Details | Diff
Updated patch with separate -doc subpackage (3.56 KB, patch)
2009-03-12 19:15 EDT, Michel Alexandre Salim
no flags Details | Diff

  None (edit)
Description Jochen Schmitt 2009-03-04 13:14:13 EST
Created attachment 334023 [details]
Proposed SPEC file for gnustep-make-2.0.8

I will notify you, that the release 2.0.8 of gnustep-make is available.

I have create a SPEC file to build this release. This SPEC file create a version which is usable for x86_64 systems. Additionally, the ddebuginfo issue (BZ #483358) will be solved.

It may be nice, if you can publish this release asap, because the other gnustep releated reviews submitted by me are blocked.
Comment 1 Michel Alexandre Salim 2009-03-12 18:54:54 EDT
Created attachment 335029 [details]
Diff to existing 2.0.6 specfile

Turned new spec file into a diff so the changes are easy to see.

I've changed two things:
- reverted make -i -C Documentation to make -C Documentation
- remove empty %else from the documentation installation

We should probably split off the larger spec files into a -doc subpackage rather than putting all in the main package's documentation directory, otherwise it's a large overhead every time someone needs gnustep-make just to build other GNUstep components.
Comment 2 Michel Alexandre Salim 2009-03-12 19:15:10 EDT
Created attachment 335030 [details]
Updated patch with separate -doc subpackage

Looks like gnustep-make does not have an open ACL, so even though I'm in provenpackager, I cannot commit this.

Applying for co-maintainership
Comment 3 Jochen Schmitt 2009-03-15 15:06:23 EDT
Are you sure, that you are in the provenpackager group anymore. I was kick out of this group and FESCO was not very helpful to get this status again. As second, I have request comaintainership too, but waiting several weeks for approvement.
Comment 4 Jochen Schmitt 2009-03-15 15:09:20 EDT
(In reply to comment #3)
> Are you sure, that you are in the provenpackager group anymore. I was kick out
> of this group and FESCO was not very helpful to get this status again. As
> second, I have request comaintainership too, but waiting several weeks for
> approvement.  


Sorry, I have forgotten to tell you, that pkgdb shows, that it should be possible to commit as provenpackages, so I'm wondering why you can't do it?
Comment 5 Michel Alexandre Salim 2009-03-24 15:27:27 EDT
(just got back from spring break)

The steering committee changed the way provenpackager membership is handed out -- I initially gained the membership due to the number of packages I maintain, but now they've reinitialized it to sponsors + people who manually apply.

I'm now a sponsor so I can commit, but it'd still be nice to get co-maintainership -- in fact, get all the active GNUstep maintainers co-maintain the core packages; that way, we all get notified when a breakage occurs and can fix things.

Axel, could you process the pkgdb requests? Thanks.
Comment 7 John Poelstra 2009-06-08 15:29:06 EDT
Adding 'FutureFeature' keyword to avoid rawhide rebase.
Comment 8 Charles Lopes 2009-06-15 04:49:45 EDT
The changes introduced in this spec remove the distinction between the Local and System domains anymore.

This was mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=475852

Commenting out the following line in the spec file reverts the behaviour back to the upstream one:
sed -i -e 's,/local,,' FilesystemLayouts/fhs-system

Can that change be reverted please?
Comment 9 Charles Lopes 2009-08-14 09:41:09 EDT
Any news on this getting committed.

Anyhow I have noticed further issues with this spec. GNUstep software build with this gnustep-make will try to install their documentation under /usr/share/doc/gnustep-make-doc-2.0.8. This is because /etc/GNUstep.conf sets GNUSTEP_SYSTEM_DOC to that path. This is the spec file line that creates the problem:
perl -pi -e"s,/share/GNUstep/Documentation,`echo %{_defaultdocdir}/%{name}-doc-%{version} | sed -e's,^/usr,,'`," \
   FilesystemLayouts/fhs-system

Unfortunately, the rest of the spec file depends on it so we cannot just comment it out.
Comment 10 Charles Lopes 2009-08-14 10:25:12 EDT
Sorry about the noise. I somehow missed that fact that version 2.0.8-2 was already in f11. Shouldn't this ticket be closed? I will open a new ticket about the issues I encountered.
Comment 11 Michel Alexandre Salim 2009-09-13 13:15:32 EDT
I'm closing this; there's already a bug ticket open for 2.2.0. We could continue the discussion there.

*** This bug has been marked as a duplicate of bug 523018 ***

Note You need to log in before you can comment on or make changes to this bug.