Bug 523018 - gnustep-make-2.2.0 is available
Summary: gnustep-make-2.2.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnustep-make
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 488534 517550 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-13 10:50 UTC by Upstream Release Monitoring
Modified: 2009-09-24 05:23 UTC (History)
3 users (show)

Fixed In Version: 2.2.0-3.fc10
Doc Type: Enhancement
Doc Text:
Clone Of:
: 517550 (view as bug list)
Environment:
Last Closed: 2009-09-24 05:21:57 UTC


Attachments (Terms of Use)
Updated spec file (5.23 KB, application/octet-stream)
2009-09-13 17:24 UTC, Michel Alexandre Salim
no flags Details
Latest updated spec file (6.69 KB, application/octet-stream)
2009-09-13 19:21 UTC, Michel Alexandre Salim
no flags Details

Description Upstream Release Monitoring 2009-09-13 10:50:46 UTC
Latest upstream release: 2.2.0
Current version in Fedora Rawhide: 2.0.8
URL: ftp://ftp.gnustep.org/pub/gnustep/core/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring

Comment 1 Michel Alexandre Salim 2009-09-13 17:15:32 UTC
*** Bug 488534 has been marked as a duplicate of this bug. ***

Comment 2 Michel Alexandre Salim 2009-09-13 17:24:04 UTC
Created attachment 360847 [details]
Updated spec file

This is an updated spec that, among others, bring it up to 2.2.0

- As mentioned in the obsoleted bug report for 2.0.8, overriding the documentation directory does not make much sense, as all other GNUstep packages will try to install their documentation there. In this case we ought to just deviate from the normal FHS guidelines and install, as previously, under %{_datadir}/GNUstep/Documentation.

- I'm creating a new gnustep-filesystem subpackage. Packages ought not to require on gnustep-make; it should only be a build requirement. -filesystem currently owns %{_sysconfdir}/GNUstep, %{_libdir}/GNUstep, %{_datadir}/GNUstep and %{_datadir}/GNUstep/Documentation

- Complete documentation now built by default. It does not take that long anyway. Previous script to disable it is broken in anycase.

One thing we might want to consider is: to follow Mandriva and override the user-specific directory to ~/.gnustep rather than ~/GNUstep, or not. Personally I'd prefer to keep it as before.

Axel, thoughts? We're still waiting for a respond to our comaintainership requests too:

https://admin.fedoraproject.org/pkgdb/packages/name/gnustep-make

Comment 3 Michel Alexandre Salim 2009-09-13 17:30:21 UTC
*** Bug 517550 has been marked as a duplicate of this bug. ***

Comment 4 Michel Alexandre Salim 2009-09-13 19:21:09 UTC
Created attachment 360850 [details]
Latest updated spec file

This addresses Charles' concern: local installations now go to /usr/local/GNUstep, and gnustep-filesystem now owns the default local directories as well.

Turns out my sed scripts that replaced Axel's perl scripts did not catch some of the references to 'lib' as well; these are now properly replaced to %{_lib}.

Comment 5 Axel Thimm 2009-09-13 21:46:50 UTC
(In reply to comment #2)
> One thing we might want to consider is: to follow Mandriva and override the
> user-specific directory to ~/.gnustep rather than ~/GNUstep, or not. Personally
> I'd prefer to keep it as before.
> 
> Axel, thoughts? We're still waiting for a respond to our comaintainership
> requests too:

(The request are done)
Is there a reason the mandriva packager decided to rename the directory? While it certainly fits in better with common modern practice it isn't really mandated or suggested by anything.

(In reply to comment #4)
> This addresses Charles' concern: local installations now go to
> /usr/local/GNUstep, and gnustep-filesystem now owns the default local
> directories as well.

In contrast to above /usr/local is being modeled after /usr with some exceptions, and the goal was to be FHS compliant. I think this needs some more thought, like /usr/local/{share,lib*} paths and similar.

> Turns out my sed scripts that replaced Axel's perl scripts did not catch some
> of the references to 'lib' as well; these are now properly replaced to %{_lib}.  

Why did you replace the perl scripts? sed-in-place does not work on all sed incarnations like some older RHEL sibling.

Comment 6 Fedora Update System 2009-09-13 23:31:22 UTC
gnustep-make-2.2.0-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnustep-make-2.2.0-3.fc11

Comment 7 Fedora Update System 2009-09-13 23:31:31 UTC
gnustep-make-2.2.0-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnustep-make-2.2.0-3.fc10

Comment 8 Jochen Schmitt 2009-09-14 14:23:18 UTC
From my side the usage a BuildConflict is not very nice. I hope this is a intermisc solution until we have found a better one.

Comment 9 Fedora Update System 2009-09-15 07:44:18 UTC
gnustep-make-2.2.0-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnustep-make'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9577

Comment 10 Fedora Update System 2009-09-15 07:47:40 UTC
gnustep-make-2.2.0-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnustep-make'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9597

Comment 11 Fedora Update System 2009-09-24 05:21:48 UTC
gnustep-make-2.2.0-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2009-09-24 05:23:10 UTC
gnustep-make-2.2.0-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.