Bug 488558 - gnome-default-applications.desktop needs OnlyShowIn=GNOME
gnome-default-applications.desktop needs OnlyShowIn=GNOME
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 15:27 EST by Christoph Wickert
Modified: 2009-08-10 16:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 16:18:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2009-03-04 15:27:34 EST
Description of problem:
gnome-default-applications only works for GNOME, so gnome-default-applications.desktop should have "OnlyShowIn=GNOME;". With Xfce 4.6 I now have two "Preferred Applications" in my Settings menu, but only one works.

Version-Release number of selected component (if applicable):
control-center-2.24.0.1-12.fc10.i386
Comment 1 Christoph Wickert 2009-04-04 16:22:48 EDT
Any chance we fix that before F11?
Comment 2 Christoph Wickert 2009-05-29 17:35:12 EDT
(In reply to comment #1)
> Any chance we fix that before F11?  

Obviously not. What is the status here?
Comment 3 Martin Donald 2009-06-18 17:53:53 EDT
I have just upgraded my wife's machine to Fedora-11 and have this same problem.

My preferred desktop is XFCE4 but it was not included in the install choices. I added XFCE4 after installation.

The default desktop is stuck at Gnome and I have to change to Xfce at each login.

I try to find where the default is stored. Is it in ~/.dmrc ????


[Desktop]
Language=en_US.utf8
Session=xfce4
Comment 4 Christoph Wickert 2009-06-18 18:06:12 EDT
Martin, you have a different problem. This bug is about default applications: Browser, mail client, terminal emulator and so on. It has nothing to do with your bug.

If you are logging in with gdm, then the default configuration indeed is in .dmrc. Did you select Xfce as session in GDM?
Comment 5 Martin Donald 2009-06-18 18:32:14 EDT
I was logging in via gdm (the graphical interface). I had added switchdesk and switchdesk-gui.

At login I select my name (the only one there) and get options for Language, Keyboard and Sessions. The sessions has the default "GNOME" with "XFce4" as option. Previously my previous choice was remembered but now I have to change to XFCE every login.
Comment 6 Bastien Nocera 2009-06-18 18:36:40 EDT
(In reply to comment #0)
> Description of problem:
> gnome-default-applications only works for GNOME, so
> gnome-default-applications.desktop should have "OnlyShowIn=GNOME;". With Xfce
> 4.6 I now have two "Preferred Applications" in my Settings menu, but only one
> works.

But then how would one change the settings for GNOME applications that you might be using in your setup? (and where's the patch)
Comment 7 Martin Donald 2009-06-18 19:06:02 EDT
I have found a closer match to my problem with bug #494899

Thanks.
Comment 8 Christoph Wickert 2009-06-18 19:29:10 EDT
@Bastien: What Gnome apps? Why do you assume an Xfce user is running Gnome apps that follow gnome-default-applications?

And what patch? This should be fixed inside the spec in desktop-file-install. You really want a patch for that?

@Martin: Yeah, bug 494899 looks like your problem. I'm removing you from this one now.
Comment 9 Christoph Wickert 2009-07-03 14:12:48 EDT
Ping Bastien...
Comment 10 Bastien Nocera 2009-08-04 10:47:09 EDT
(In reply to comment #8)
> @Bastien: What Gnome apps? Why do you assume an Xfce user is running Gnome apps
> that follow gnome-default-applications?

If you run epiphany, totem, or a number of other GNOME apps, then that won't work.

> And what patch? This should be fixed inside the spec in desktop-file-install.
> You really want a patch for that?

Yes, and I don't want a patch against the spec, but a patch against the .desktop file in the sources.

FWIW, needinfo of maintainer just won't catch on. If it wasn't needinfo, it would at least have showed up in my reports.
Comment 11 Christoph Wickert 2009-08-05 19:41:50 EDT
(In reply to comment #10)
> If you run epiphany, totem, or a number of other GNOME apps, then that won't
> work.

You are right with epiphany but Xfce has it's own browser with midori. Why do you assume people are always running GNOME apps in Xfce?

Totem (capitalized ;)) is a bad example because it cannot open any of the preferred apps.

> Yes, and I don't want a patch against the spec, but a patch against the
> .desktop file in the sources.

It already *is* in the sources, but it get's removed in the spec. According to bug 161489 you were the one who did that.

> FWIW, needinfo of maintainer just won't catch on. If it wasn't needinfo, it
> would at least have showed up in my reports.

Please look at the history, it was in needinfo?(control-center-maint@redhat.com) for a month and before that I addressed you in comment #8. If you haven't seen this, it might be caused by the recent bugzilla changes that messed up frontpage.cgi.
Comment 12 Bastien Nocera 2009-08-05 20:05:51 EDT
(In reply to comment #11)
> (In reply to comment #10)
> > If you run epiphany, totem, or a number of other GNOME apps, then that won't
> > work.
> 
> You are right with epiphany but Xfce has it's own browser with midori. Why do
> you assume people are always running GNOME apps in Xfce?
> 
> Totem (capitalized ;)) is a bad example because it cannot open any of the
> preferred apps.

YouTube plugin -> search -> Right-click on search result -> Open in Web Browser

Same for the links in the about box, and the plugins preferences.

> > FWIW, needinfo of maintainer just won't catch on. If it wasn't needinfo, it
> > would at least have showed up in my reports.
> 
> Please look at the history, it was in
> needinfo?(control-center-maint@redhat.com) for a month and before that I
> addressed you in comment #8. If you haven't seen this, it might be caused by
> the recent bugzilla changes that messed up frontpage.cgi.  

Nope, that's because nobody gives a monkey about needinfo on the maintainers. Leave the bugs opened instead. needinfo is for end-users.
Comment 13 Christoph Wickert 2009-08-05 20:43:23 EDT
(In reply to comment #12)
> YouTube plugin -> search -> Right-click on search result -> Open in Web Browser
> 
> Same for the links in the about box, and the plugins preferences.

Shouldn't things like these just use xdg-open?

> Nope, that's because nobody gives a monkey about needinfo on the maintainers.
> Leave the bugs opened instead.

The bug was open all the time. However if you feel like closing it, feel free to do so. I have excluded gnome-default-applications from the Xfce menu in the meantime.
Comment 14 Bastien Nocera 2009-08-10 11:17:28 EDT
Did you also check:
https://bugzilla.redhat.com/show_bug.cgi?id=161489
?

Seems to me that we'd end up with the same problem here...
Comment 15 Christoph Wickert 2009-08-10 11:32:24 EDT
The bug was mentioned in the changelog and I did check it. I think that the decision there was wrong. Firefox and Thunderbird are no Gnome apps and they should not be patched to use gnome-default-applications. However I agree that the current behavior is the best for most of our users, so feel free to close.
Comment 16 Bastien Nocera 2009-08-10 16:18:00 EDT
Let me know when those problems with Firefox and Thunderbird are fixed.

Note You need to log in before you can comment on or make changes to this bug.