Bug 488666 - ibus-anthy candidate selection should be vertical
ibus-anthy candidate selection should be vertical
Status: CLOSED DUPLICATE of bug 493687
Product: Fedora
Classification: Fedora
Component: ibus-anthy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F11Target 481098 491040
  Show dependency treegraph
 
Reported: 2009-03-05 00:03 EST by Akira TAGOH
Modified: 2009-04-09 01:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 01:44:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2009-03-05 00:03:24 EST
Description of problem:
Right now the candidate window displays in the landscape though, keybindings to move a cursor among candidate words is Up and Down key. but not Left and Right key.

Version-Release number of selected component (if applicable):
ibus-1.1.0.20090225-2.fc11.x86_64
ibus-anthy-1.1.0.20090211-2.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1.type something and press space to see the candidate window
2.press Left and Right key
3.press Up and Down key
  
Actual results:
2. nothing happens
3. move a cursor to the _left_ and the _right_

Expected results:
2. should move a cursor to the left with Left key and to the right with Right key.

Additional info:
Comment 1 Peng Huang 2009-03-06 03:34:05 EST
The left and right keys is for moving cursor in pre-edit. So we can not use them for moving cursor in lookup table. So I will not fix it.
Comment 2 Akira TAGOH 2009-03-06 05:59:52 EST
There should be some options to make it useful:

1. Use the portrait candidate window by defualt
2. Assign Left and Right key to move a cursor on the candidate window during it appears and need to cancel it to work them again for moving a cursor on preedit.
3. Reconsider the default keybindings to take it easy
4. Provide a customization for keybindings for workaround and leave it to users.

Just closing WONTFIX sounds like making a denial of those ideas too.
Reopening.
Comment 3 Jens Petersen 2009-03-12 01:37:10 EDT
Can we at least default candidate list to vertical for ibus-anthy or Japanese users?
That would help with this problem.
Comment 4 Warren Togami 2009-03-17 12:03:28 EDT
Windows IME, ATOK and SCIM are vertical.  This really shouldn't be different in ibus because it confuses users.  It seems the key bindings themselves are correct, but how it is displayed during candidate selection needs to be fixed.
Comment 5 Peng Huang 2009-04-07 01:11:08 EDT
ibus will set lookup table vertical in ja locale. Fixed in ibus-1.1.0.20090331-1.fc11
Comment 6 Warren Togami 2009-04-07 04:21:11 EDT
There was a misunderstanding.  We want it to be vertical for both Japanese and Korean candidate selection so this language input interface behaves identically no matter what your desktop locale is.
Comment 7 Jens Petersen 2009-04-09 01:44:12 EDT
should be fixed in latest ibus-1.1.0.20090407-3.fc11 build which now defaults all locale to vertical.

*** This bug has been marked as a duplicate of bug 493687 ***

Note You need to log in before you can comment on or make changes to this bug.