Bug 488787 - SELinux, avc denial when running monitoring probes
SELinux, avc denial when running monitoring probes
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Red Hat Satellite QA List
na
:
Depends On: 487221
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-03-05 13:37 EST by wes hayutin
Modified: 2015-05-29 16:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-29 16:02:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-05 13:37:38 EST
Description of problem:

/var/log/audit/audit.log:type=AVC msg=audit(1236274886.277:5672): avc:  denied  { search } for  pid=22126 comm="execute_command" name="yp" dev=dm-0 ino=1504428 scontext=root:system_r:spacewalk_monitoring_t:s0 tcontext=system_u:object_r:var_yp_t:s0 tclass=dir


[root@grandprix audit]# ps -ef | grep 22126
root     13148 14611  0 13:34 pts/0    00:00:00 grep 22126
root     22126 22125  0 12:22 ?        00:00:01 /usr/bin/perl /usr/bin/execute_commands
[root@grandprix audit]# 


recreate..
run monitoring automation, check audit.log

manual..
probes listed here..

Probe(s) assigned to system have an UNKNOWN status  	 Apache: Processes  	 Cannot find Max Child and Slot MB metrics at URL http://10.10.76.146%20%20%20%20:80/server-status 	 Suite
Probe(s) assigned to system have an UNKNOWN status 	Linux: Load 	The RHN Monitoring Daemon (RHNMD) is not responding: Internal problem executing 

Unix::Load: open3: exec of /usr/bin/ssh -l nocpulse -p 4545 -i /var/lib/nocpulse/.ssh/nocpulse-identity -o StrictHostKeyChecking=no -o BatchMode=yes 10.10.76.146 /bin/sh -s failed. Please make sure the daemon is running and the host is accessible from the monitoring scout. Command was: /usr/bin/ssh -l nocpulse -p 4545 -i /var/lib/nocpulse/.ssh/nocpulse-identity -o StrictHostKeyChecking=no -o BatchMode=yes 10.10.76.146 /bin/sh -s Suite
Probe(s) assigned to system have an UNKNOWN status 

	Linux: Memory Usage 	The RHN Monitoring Daemon (RHNMD) is not responding: Internal problem executing Unix::MemoryFree: open3: exec of /usr/bin/ssh -l nocpulse -p 4545 -i /var/lib/nocpulse/.ssh/nocpulse-identity -o StrictHostKeyChecking=no -o BatchMode=yes 10.10.76.146 /bin/sh -s failed. Please make sure the daemon is running and the host is accessible from the monitoring scout. Command was: /usr/bin/ssh -l nocpulse -p 4545 -i /var/lib/nocpulse/.ssh/nocpulse-identity -o StrictHostKeyChecking=no -o BatchMode=yes 10.10.76.146 /bin/sh -s 	Suite
Probe(s) assigned to system have an UNKNOWN status 

	Linux: Virtual Memory 	The RHN Monitoring Daemon (RHNMD) is not responding: Internal problem executing Unix::VirtualMemory: open3: exec of /usr/bin/ssh -l nocpulse -p 4545 -i /var/lib/nocpulse/.ssh/nocpulse-identity -o StrictHostKeyChecking=no -o BatchMode=yes 10.10.76.146 /bin/sh -s failed. Please make sure the daemon is running and the host is accessible from the monitoring scout. Command was: /usr/bin/ssh -l nocpulse -p 4545 -i /var/lib/nocpulse/.ssh/nocpulse-identity -o StrictHostKeyChecking=no -o BatchMode=yes 10.10.76.146 /bin/sh -s 	Suite
Probe(s) assigned to system have an UNKNOWN status 

	Network Services: Ping
Comment 1 wes hayutin 2009-03-05 13:38:44 EST
/var/log/audit/audit.log:type=AVC msg=audit(1236274886.277:5673): avc:  denied  { node_bind } for  pid=22126 comm="execute_command" scontext=root:system_r:spacewalk_monitoring_t:s0 tcontext=system_u:object_r:inaddr_any_node_t:s0 tclass=tcp_socket
/var/log/audit/audit.log:type=AVC msg=audit(1236274886.277:5674): avc:  denied  { name_bind } for  pid=22126 comm="execute_command" src=718 scontext=root:system_r:spacewalk_monitoring_t:s0 tcontext=system_u:object_r:hi_reserved_port_t:s0 tclass=tcp_socket
/var/log/audit/audit.log:type=AVC msg=audit(1236274886.277:5675): avc:  denied  { name_connect } for  pid=22126 comm="execute_command" dest=111 scontext=root:system_r:spacewalk_monitoring_t:s0 tcontext=system_u:object_r:portmap_port_t:s0 tclass=tcp_socket
/var/log/audit/audit.log:type=AVC msg=audit(1236274886.277:5676): avc:  denied  { node_bind } for  pid=22126 comm="execute_command" scontext=root:system_r:spacewalk_monitoring_t:s0 tcontext=system_u:object_r:inaddr_any_node_t:s0 tclass=tcp_socket
/var/log/audit/audit.log:type=AVC msg=audit(1236274886.277:5677): avc:  denied  { name_bind } for  pid=22126 comm="execute_command" src=719 scontext=root:system_r:spacewalk_monitoring_t:s0 tcontext=system_u:object_r:hi_reserved_port_t:s0 tclass=tcp_socket
/var/log/audit/audit.log:type=AVC msg=audit(1236274886.277:5678): avc:  denied  { name_connect } for  pid=22126 comm="execute_command" dest=111 scontext=root:system_r:spacewalk_monitoring_t:s0 tcontext=system_u:object_r:portmap_port_t:s0 tclass=tcp_socket
Comment 2 Jan Pazdziora 2009-03-07 13:49:48 EST
What compose (version) is this on?

Please, *always* use the bugzilla template when filing new bugzilla. Thank you.
Comment 3 wes hayutin 2009-03-09 10:29:14 EDT
oops. my fault.

Satellite-5.3.0-RHEL5-re20090227.1-i386-embedded-oracle.iso
Comment 4 wes hayutin 2009-03-10 17:55:22 EDT
*** Bug 489576 has been marked as a duplicate of this bug. ***
Comment 5 Jan Pazdziora 2009-04-09 10:39:59 EDT
The AVC denial messages seem NIS-related, so very similar to bug 487221. Moving to ON_QA as spacewalk-monitoring-selinux-0.5.6-1 which added the nis_use_ypbind_uncond is available in Satellite-5.3.0-RHEL5-re20090327.0 compose.
Comment 6 wes hayutin 2009-04-15 16:49:14 EDT
verified
Comment 7 Milan Zazrivec 2009-09-09 09:18:24 EDT
This one needs to be retested after bug #487221 is fixed.
Comment 8 Brandon Perkins 2009-09-09 10:10:18 EDT
Reopening and punting to sat600-triage for re-evaluation.

Note You need to log in before you can comment on or make changes to this bug.