Bug 488959 - Manual pages are not in sync with fence agents
Manual pages are not in sync with fence agents
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
: 666438 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 09:55 EST by Marek Grac
Modified: 2016-04-26 12:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.0.115-72
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 03:15:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (7.49 KB, patch)
2009-08-28 09:57 EDT, Marek Grac
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1001 normal SHIPPED_LIVE cman bug-fix and enhancement update 2011-07-20 11:44:50 EDT

  None (edit)
Description Marek Grac 2009-03-06 09:55:42 EST
Description of problem:

A lot of new features where added and they are accessible through '-o metadata' in XML format and '-h' for humans. But man pages where not updated yet.
Comment 2 Marek Grac 2009-08-28 09:57:20 EDT
Created attachment 359067 [details]
Proposed patch
Comment 3 Marek Grac 2009-10-12 08:08:33 EDT
Final patch (some features where imported with earlier patches)

http://git.fedorahosted.org/git/cluster.git?p=cluster.git;a=commit;h=39fd1b540bb06be1607d4fcd044b5e37abb2daba
Comment 6 RHEL Product and Program Management 2011-01-11 15:24:40 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 RHEL Product and Program Management 2011-01-11 17:20:00 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 9 Lon Hohberger 2011-03-21 19:28:13 EDT
*** Bug 666438 has been marked as a duplicate of this bug. ***
Comment 10 Dean Jansa 2011-05-11 19:00:55 EDT
Fence agents now call show_docs, as in propsed patch:
 
# grep show_docs fence_*
fence_apc:	show_docs(options, docs)
fence_apc_snmp:	show_docs(options, docs)
fence_bladecenter:	show_docs(options, docs)
fence_cisco_mds:	show_docs(options, docs)
fence_cisco_ucs:	show_docs(options, docs)
fence_drac5:	show_docs(options, docs)
fence_ifmib:	show_docs(options, docs)
fence_ilo:	show_docs(options, docs)
fence_ilo_mp:	show_docs(options, docs)
fence_lpar:	show_docs(options, docs)
fence_rhevm:	show_docs(options, docs)
fence_rsa:	show_docs(options, docs)
fence_sanbox2:	show_docs(options, docs)
fence_virsh:	show_docs(options, docs)
fence_vmware:	show_docs(options, docs)
fence_wti:	show_docs(options, docs)


verified in cman-2.0.115-82.el5
Comment 11 errata-xmlrpc 2011-07-21 03:15:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1001.html

Note You need to log in before you can comment on or make changes to this bug.