Bug 488987 - [StorageRewrite] pv is already part of this vg
[StorageRewrite] pv is already part of this vg
Status: CLOSED DUPLICATE of bug 489022
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
StorageRewrite
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 11:38 EST by Tomasz Torcz
Modified: 2009-03-09 11:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 11:33:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt containing backtrace (61.51 KB, text/plain)
2009-03-06 11:38 EST, Tomasz Torcz
no flags Details

  None (edit)
Description Tomasz Torcz 2009-03-06 11:38:26 EST
Created attachment 334317 [details]
anacdump.txt containing backtrace

Description of problem:
I am unable to use partitioning part of installator, anaconda throws a stacktrace as soon as I try to edit things.

Version-Release number of selected component (if applicable):
rawhide i386 boot.iso from 6th march 2009. Tested in KVM (virtio /dev/vda) and VirtualBox 2.1.4 (emulated /dev/sda, PIIX3), same result.


How reproducible:
Always.

Steps to Reproduce:
1. Boot adding "icant...btr" to commandline
2. Select english, keyboard us international, check "Review partition layout"
3. In partition edit screen, select pregenerated root vg or swap vg.
4. Click "Edit".
  
Actual results:
Informationa about error in installer with backtrace (attached).

Expected results:
Window for editing LVM should appear.
Comment 1 James Laska 2009-03-06 11:41:39 EST
Posting summary of traceback for any bugzilla searchers ... 

anaconda 11.5.0.24 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 1500, in _addPV
    raise ValueError("pv is already part of this vg")
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 343, in createAllowedLvmPartitionsList
    self.vg._addPV(device)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 997, in __init__
    (self.lvmlist, sw) = self.createAllowedLvmPartitionsList(self.availlvmparts, self.storage.vgs)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1129, in editLVMVolumeGroup
    isNew)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1054, in editCB
    self.editLVMVolumeGroup(device)
ValueError: pv is already part of this vg
Comment 2 Matthieu Araman 2009-03-07 13:19:58 EST
I've got the same problem with the same boot.iso 20090306
I can't edit the partition lv_root

initial partitionning was created with Fedora 11 alpha.

my setup is :

two disks mirrored /dev/sda and /dev/sdb


/dev/md0 contains ext3 partition /boot

/dev/md1 contain a lvm setup with 4 partitions (and some free space to allow extending lvm)
/ ext4
/var ext4
/home ext4
+ swap

the installer only shows 
/dev/md0 correctly
/dev/md1 is changed to have LVM with lv_root occupying all the disk except 5G for swap.

I wan't to change the setup to have the same partitionning as before (and format everything)

So I select lv_root and click on modify which immediately leads to this error.
Comment 3 Luke Macken 2009-03-07 15:13:13 EST
I'm encountering the same issue with today's rawhide.  I boot with 'icantbelieveitsnotbtr', and as soon as I click "Edit" on lv_root, I get the same traceback.
Comment 4 Chris Lumens 2009-03-09 11:33:30 EDT

*** This bug has been marked as a duplicate of bug 489022 ***

Note You need to log in before you can comment on or make changes to this bug.