Bug 489022 - anaconda exception trying to re-use existing LVM partitions
anaconda exception trying to re-use existing LVM partitions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:d63f89b7a0958c77f...
:
: 488987 489511 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 14:37 EST by G.Wolfe Woodbury
Modified: 2009-03-26 17:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 17:35:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (100.32 KB, text/plain)
2009-03-06 14:37 EST, G.Wolfe Woodbury
no flags Details
Attached traceback automatically from anaconda. (117.06 KB, text/plain)
2009-03-08 08:50 EDT, M8R-nxns8i
no flags Details

  None (edit)
Description G.Wolfe Woodbury 2009-03-06 14:37:16 EST
The following was filed automatically by anaconda:
anaconda 11.5.0.25 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 1507, in _addPV
    raise ValueError("pv is already part of this vg")
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 343, in createAllowedLvmPartitionsList
    self.vg._addPV(device)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 997, in __init__
    (self.lvmlist, sw) = self.createAllowedLvmPartitionsList(self.availlvmparts, self.storage.vgs)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1129, in editLVMVolumeGroup
    isNew)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1054, in editCB
    self.editLVMVolumeGroup(device)
ValueError: pv is already part of this vg
Comment 1 G.Wolfe Woodbury 2009-03-06 14:37:23 EST
Created attachment 334343 [details]
Attached traceback automatically from anaconda.
Comment 2 G.Wolfe Woodbury 2009-03-06 14:45:02 EST
At least it started up without having to wipe the previous installation.

Selected custom layout and went to edit a previous partition/lv to assign mount point and options.

probably a duplicate of a previous traceback.

will try allowing it to start a fresh layout, there's no real stuff on the 1st drive and home is a second drive.
Comment 3 M8R-nxns8i 2009-03-08 08:50:17 EDT
Created attachment 334435 [details]
Attached traceback automatically from anaconda.
Comment 4 Chris Lumens 2009-03-09 11:33:31 EDT
*** Bug 488987 has been marked as a duplicate of this bug. ***
Comment 5 David Lehman 2009-03-10 11:19:53 EDT
*** Bug 489511 has been marked as a duplicate of this bug. ***
Comment 6 G.Wolfe Woodbury 2009-03-19 05:47:26 EDT
There's no traceback for me now, but editing a pre-existing LV has problems assigning the mount point (BZ 490301)
Comment 7 G.Wolfe Woodbury 2009-03-25 02:16:11 EDT
Now its failing again - 11.5.0.35
Almost any LVM layout besides the default fails either silently or with a "Filesystem not formatted"
Comment 8 Chris Lumens 2009-03-26 15:24:31 EDT
So, the original traceback is no longer being seen?  I wonder if that's because you are getting a new traceback before you'd get the old one, or if the old one has been fixed and is no longer getting hit.

If you could attach the new traceback, that'd be helpful in determining which is the case.  If the original bug report is no longer relevant, we should close out this report and open a new one for the new problem.  Thanks.
Comment 9 G.Wolfe Woodbury 2009-03-26 17:35:40 EDT
the original traceback /seems/ to have been fixed in terms of the reported errors

however, the symptoms are now being attributed to other exceptions.
re-using an existing LV and trying too edit its properties still fails.

Technically, I guess that *this* bug is fixed,  when i next test tomorrow morning I'll be sure to file any tracebacks.

Note You need to log in before you can comment on or make changes to this bug.