Bug 489014 - Review Request: gnome-do-plugins - Plugins for Gnome Do
Review Request: gnome-do-plugins - Plugins for Gnome Do
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-06 13:23 EST by Paul Lange
Modified: 2009-08-18 20:51 EDT (History)
23 users (show)

See Also:
Fixed In Version: 0.8.1-6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-08-11 18:37:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
a.badger: fedora‑review+
kevin: fedora‑cvs+

Attachments (Terms of Use)
Adds DESTDIR to BundledLibraries Makefiles, fixes build issue with (1.21 KB, patch)
2009-04-01 10:45 EDT, Sindre Pedersen Bjørdal
no flags Details | Diff
Patches flickrnet's pkgconfig file to use lib64 (1.47 KB, patch)
2009-06-25 11:39 EDT, Juan Manuel Rodriguez
no flags Details | Diff
SourceFucker (1.26 KB, application/x-perl)
2009-06-26 15:25 EDT, David Nielsen
no flags Details
Patch to use libdir instead of datadir for the plugin files (1.63 KB, patch)
2009-07-15 23:40 EDT, Toshio Ernie Kuratomi
no flags Details | Diff
Spec file to install to %{_libdir} and to not use the bundled libraries (7.67 KB, text/plain)
2009-07-15 23:41 EDT, Toshio Ernie Kuratomi
no flags Details
specfile that merges latest from nushio (7.97 KB, application/octet-stream)
2009-07-16 21:31 EDT, Toshio Ernie Kuratomi
no flags Details

  None (edit)
Description Paul Lange 2009-03-06 13:23:27 EST
Spec URL: http://palango.fedorapeople.org/do-plugins/gnome-do-plugins.spec
SRPM URL: http://palango.fedorapeople.org/do-plugins/gnome-do-plugins-0.8.0-1.fc10.src.rpm
GNOME Do allows you to quickly search for many objects present in your
GNOME desktop environment (applications, Evolution contacts, Firefox
bookmarks, files, artists and albums in Rhythmbox, Pidgin buddies) and
perform commonly used commands on those objects (Run, Open, Email,
Chat, Play, etc.).

This package contains various plugins for GNOME Do.
Comment 1 David Nielsen 2009-03-18 04:13:02 EDT
All mono packages are arch currently, it is against the packaging guidelines to make them noarch. Such a move should be conditional on a change in the guidelines and then be done for all packages at once.

Aside that I would love to see the plugins be moved into separate subpackages. e.g. gnome-do-plugins-evolution and so on in a natural fashion. It would be a great boon to our users.

Also you don't need to pass libdir to configure, rpm should take care of that.
Comment 2 David Nielsen 2009-03-30 07:19:15 EDT
Paul, are you still interested in this?
Comment 3 Paul Lange 2009-03-30 10:58:45 EDT
Yes I am. But currently I don't have time to work further on this - so if anybody is interested to work on this feel free to take it.
Comment 4 Huzaifa S. Sidhpurwala 2009-03-31 06:31:20 EDT
Paul i would like to take over this package, if its ok with you.
Comment 5 Paul Lange 2009-03-31 09:46:48 EDT
Yeah, would be cool if you take it since I can't finish it for F11.
Thanks for helping!
Comment 6 Sindre Pedersen Bjørdal 2009-04-01 00:57:52 EDT
Any progress on this?
Comment 7 Sindre Pedersen Bjørdal 2009-04-01 10:45:07 EDT
Created attachment 337547 [details]
Adds DESTDIR to BundledLibraries Makefiles, fixes build issue with

This simple patch is required to make build successfully.
Comment 8 David Nielsen 2009-04-04 14:04:36 EDT
ping, Huzaifa I hope you are still working on this, the list will be helpful if you run into problems - there is no such thing as a dumb question.
Comment 9 Huzaifa S. Sidhpurwala 2009-04-05 21:41:58 EDT
Yes i am working on it. My rawhide machine konked off and i had to re-install which took some time :(
Comment 10 Huzaifa S. Sidhpurwala 2009-04-06 05:42:37 EDT
Following changes made to the spec:
1. Dropped noarch
2. Dropped libdir 

regarding your suggestion for separating the plugins into different packages.
I feel that there are really a lot of plugins for that isnt it?

/usr/share/gnome-do/plugins has 210 files, Assuming two files for each plugin, we have around 105 plugin rpms? 

SPEC: http://huzaifas.fedorapeople.org/spec/gnome-do-plugins.spec
SRPM: http://huzaifas.fedorapeople.org/srpms/gnome-do-plugins-0.8.0-2.fc11.src.rpm

Please let me know what you think.
Comment 11 Mads Villadsen 2009-04-06 07:23:22 EDT
I think it would make sense to split up the plugins in different subpackages only where there is an extra external dependency.

So for instance something like this:

gnome-do-plugins (contains all the "basic" plugins)
gnome-do-plugins-evolution (plugins for evolution)
gnome-do-plugins-banshee (plugins for banshee)
gnome-do-plugins-flickr (plugins for flickr)

So if I do an install of gnome-do and gnome-do-plugins I don't end up pulling in a lot of stuff I don't need as dependencies.
Comment 12 Huzaifa S. Sidhpurwala 2009-04-06 07:31:37 EDT
hmm sounds good, will do :)
Comment 13 David Nielsen 2009-04-06 07:39:42 EDT
That was the general idea. We should aim to be flexible and allowing people to enable only what they need. Remembering that you pull in the world as dependencies for the mega package. I think we need to aim for something sane here, the above looks good at least for a start. We can always break things up some more later if we need it.

Maybe it would be good to ask upstream to please take more care to make packaging easy and let us keep dependencies and enablement sane. I have checked a bunch of distros that ship gnome-do-plugins and they all have this mega package that forces me to have evolution, rhythmbox and other apps that are useless to me installed. I filed bugs against all these packages, perhaps it is time to poke upstream.
Comment 14 Huzaifa S. Sidhpurwala 2009-04-06 07:40:24 EDT
So here are the subpackages:



Does that sound good?
Comment 15 Sindre Pedersen Bjørdal 2009-04-06 08:43:41 EDT
Nice to see progress on this, a couple of notes: is available, but requires patch attached in my post above.

%{_datadir}/gnome-do is owned by package gnome-do. -plugins should not own this dir. 

Split looks sane. Good job.
Comment 16 Huzaifa S. Sidhpurwala 2009-04-07 03:13:47 EDT
So here is what i have done:

1. Bumped to newer upstream after applying the patch Sindre sent.
2. Split the huge rpm into smaller sub-rpms making sure that only those sections which have a dependency [ e.g firefox etc ] would be in a separate rpm.
Someone please check if this condition is fully satisfied.

SPEC: http://huzaifas.fedorapeople.org/spec/gnome-do-plugins.spec
SRPM: http://huzaifas.fedorapeople.org/srpms/gnome-do-plugins-

I tried doing a scratch build in koji however it seems that monodevelop does not exists for f11.
However it has been built for F11 at:

So most probably it did not end up in the build root.
Comment 17 David Nielsen 2009-04-07 03:33:33 EDT
Why are you doing all those excludes? They are listed in the subpackages, it should be enough to have them be owned that way. 

you may also want to move specific buildrequires into the subpackages, that way we can do some neat stuff with flags 

Shouldn't it depend on monodevelop-devel, not that it would make a difference in finding it. This one smells like a koji error to me, we may need to contact the koji guys if it presists or ask the mailing list. Does it happen in a local mock build as well?
Comment 18 Huzaifa S. Sidhpurwala 2009-04-07 03:54:55 EDT
(In reply to comment #17)
> Why are you doing all those excludes? They are listed in the subpackages, it
> should be enough to have them be owned that way. 
Well if you see the file list in the gnome-do-plugin rpm it includes all the files,  So if i dont put excludes the files would go into both the sub packge as well as the gnome-do-plugin package.


> you may also want to move specific buildrequires into the subpackages, that way
> we can do some neat stuff with flags 
Make sense, will do that.
SPEC: http://huzaifas.fedorapeople.org/spec/gnome-do-plugins.spec

However my question is, when the rpm is build from source, you have to build all the sub rpms right? So what is the point in splitting the BRs?

> Shouldn't it depend on monodevelop-devel, not that it would make a difference
> in finding it. This one smells like a koji error to me, we may need to contact
> the koji guys if it presists or ask the mailing list. Does it happen in a >local
> mock build as well?  
Yeah mock is fine.
Opened a ticket with buildsys at:
Comment 19 David Nielsen 2009-04-07 05:37:45 EDT
Maybe that is the case, it is my impression that using flags one could specifically tell rpmbuild to build things like --with-evolution and so on so you could build the separated plugins. However that would require being able to run the configure script in such a way as to disable the undesired plugins and knowing the gnome-do guys this will not be possible. I doubt we can do this on second thought. 

Also regarding the excludes, I rewrote the spec you referenced for greater flexibility and I don't remember doing that.. maybe I did and forgot about it. I'll chuck this up to rpm being suboptimal for maintainers here and not doing the right thing by default.

Doesn't this contain language files?

Regardless I can do a proper review on Thursday, I had my account reenabled so I should also be able to approve it. A quick overview looks very good though.

Why is the banshee exclude commented out? Aside that there's a cosmetic enhancement ensuring an equal amount of newlines between the the main package and the plugins packages file listings.
Comment 20 Sindre Pedersen Bjørdal 2009-04-07 05:43:35 EDT
You don't need the excludes, but you do need to use %dir in the -plugins package. You see, if you do %{_datadir}/gnome-do/plugins/ in %files that package will own all subdirectories and files of that dir, but if you use %dir %{_datadir}/gnome-do/plugins/ it will only own the dir in question, without the subdirs.

As for the monodevelop issue, monodevelop is not available for ppc* for some reason, the following works around that:

# ppc* not supported: needs monodevelop which is not built for ppc*
ExclusiveArch:  %ix86 x86_64 ia64 armv4l sparc alpha

in the long run monodevelop should be fixed to run on ppc though, file a bug against monodevelop.
Comment 21 Christopher Grebs 2009-04-15 16:47:44 EDT
Hey there, is there any progress on this? I'm running a local compiled version of the plugins right now, so it would be very cool to get the plugins from the repository.

Thanks in advance,
Comment 22 David Nielsen 2009-04-22 11:19:21 EDT
There appears to be a problem with splitting up the gnome-do-plugins package in the proposed manner.

I have a bug to ask the Ubuntu folks to do the same here:

Which leads us to this upstream problem.

to do this right we need to wait for 0.8.2 to be released it seems.
Comment 23 Harry Dance 2009-06-17 17:48:34 EDT
Hi, in the meantime, please could someone explain the best way to install these plugins?
Comment 24 Juan Manuel Rodriguez 2009-06-18 11:21:58 EDT
2 questions, the second one depends on the first's answer. 
First one: Is the package orphaned?
Second: Can I adopt it?

Disclaimer: I'm not a packager yet, and I have much to learn. 

Here's the SPEC I made: http://proyectofedora.org/mexico/gnome-do-plugins.spec
(Based on previous specs)

It compiled gnome-do-plugins, and 14 other RPMs. I installed gnome-do-plugins, and it contained most plugins. 

The Plugin list:
Eye of Gnome
Files and Folders
Gnome Dictionary
Gnome Screenshot
Gnome SessionManagement
Gnome Terminal
Google Calculator
Google Calendar
Google Contacts
Google Docs
Locate Files
Microblogging (Twitter)
OpenSearch Web Search

However, it did not install:

I'll run some more tests.
Comment 25 Juan Manuel Rodriguez 2009-06-18 12:04:29 EDT
I apologize for my ignorance (I hadn't used Gnome-do 0.8 before)

It lists all available plugins, but when you try to enable them, they don't work because the package isn't there, which means everything's working fine with my spec so far. 

I tried doing a mock, and it failed. 

For those interested, here's the mock: 

From what I can tell, its Flickr's fault, but I'll keep looking into it.
Comment 26 Juan Manuel Rodriguez 2009-06-18 14:27:50 EDT
There seems to be a bug compiling for x86_64, as I managed to compile it fine excluding that arch and using x86. 

Comment 27 Paul Lange 2009-06-24 14:10:08 EDT
flickrnet is available on x86_64. 
error CS0006: cannot find metadata file `/usr/lib/mono/flickrnet/FlickrNet.dll'

The file is located at '/usr/lib64/mono/flickrnet/FlickrNet.dll' on x86_64. I think the flickrnet pkg-config file is right so I'm not sure what is the problem.
Comment 28 Juan Manuel Rodriguez 2009-06-25 11:39:02 EDT
Hey Paul, Toshio helped me find the error in the package. 

The package flickrnet has a flickrnet.pc file and on the first line, it uses
instead of

This is the reason why it won't find lib64. To fix it, on the flickrnet.spec, we do 
sed -i 's|@LIBDIR@|%_libdir|g' %{SOURCE1}

in the %prep section, after %patch0 -p1. 

I'll attach the patch.
Comment 29 Juan Manuel Rodriguez 2009-06-25 11:39:56 EDT
Created attachment 349415 [details]
Patches flickrnet's pkgconfig file to use lib64

Patches flickrnet's pkgconfig file to use lib64
Comment 30 Paul Lange 2009-06-25 13:56:21 EDT
Hey Juan,

sorry for the bug in flickrnet. I applied your patch and changed some things. Can you please check the this build works correctly http://koji.fedoraproject.org/koji/taskinfo?taskID=1435936

Thank you for your work!

Comment 31 Juan Manuel Rodriguez 2009-06-26 09:33:36 EDT
No problem with that RPM, but like I said, Toshio's the one that provided the fix, I simply pointed out the error. 

This fix should let me compile gnome-do-plugins for x86_64, unless there's another similar bug on another of the packages.
Comment 32 Juan Manuel Rodriguez 2009-06-26 09:42:07 EDT
Paul, could you do a build-override with that package, so I can try to build gnome-do-plugins on x86_64 on koji?

Comment 33 Paul Lange 2009-06-26 11:49:13 EDT

package is built and update submitted: https://admin.fedoraproject.org/updates/flickrnet-2.1.5-3.fc11
Comment 34 David Nielsen 2009-06-26 15:25:08 EDT
Created attachment 349593 [details]

Please note that that type of issue is exactly why SourceFucker was developed. It can create patches for these type of issues for your Mono packages. I would recommend running it against any current packages.
Comment 35 Juan Manuel Rodriguez 2009-06-29 23:18:08 EDT

I tried building gnome-do-plugins against that build, but had an error. Upon inspection, I see that we used ${libdir} instead of ${_libdir}, so it wasn't building on 586. I don't remember getting this error when I tried it last time, but it could've skipped my mind. 

The fix is simple, just replace both on flickrnet.pc. 

Here's the koji build of my failed gnome-do-plugins: 

And the build for the succesfull flickrnet.pc 


I downloaded the pl file and executed it against gnome-do-plugins tar.bz2 and against the flickrnet code, but the patch was empty in both cases, with just a comment that says: 
# SourceFucker.pl: Fix hardcoded references to libdir

Maybe I'm using it wrong?
Comment 36 Paul Lange 2009-07-01 13:47:06 EDT

I'm sorry. i made some mistakes but it should work right now. New build has been done and the update is issued. See https://admin.fedoraproject.org/updates/flickrnet-2.1.5-4.fc11)
Comment 37 Fabian A. Scherschel 2009-07-02 05:42:11 EDT
How is this coming along? Do you need help in testing this?

Comment 38 Juan Manuel Rodriguez 2009-07-02 11:21:41 EDT
Paul, thanks. 

I tried doing a koji build, and it failed again: 

I'm doing a koji build --scratch dist-f11 src.rpm

Fabian, do you know if I should add another parameter so that it uses the new flickrnet? Or is that done automatically?

Comment 39 Paul Lange 2009-07-02 12:05:37 EDT

update has been pushed to stable around 2 hours ago. I expect it needs more time to be used in the build processes.
Comment 40 Fabian A. Scherschel 2009-07-02 15:36:04 EDT

@Juan: Sorry, I am really new to Fedora and RPM in general so I am afraid I can't say. I will be happy to test install anything, though. :)
Comment 41 Juan Manuel Rodriguez 2009-07-02 16:38:27 EDT
Thanks Paul, 

I waited as suggested and it built succesfully: 

@Fabian, I'm new as well, perhaps we should compare notes? :P

I installed the rpms on my computer, and so far, gnome-do's been working with the plugins fine.
Comment 42 Benjamin Podszun 2009-07-13 10:52:57 EDT
Juan: Did you get any feedback regaring the adoption of this package? Will it end up in the repositories soon? Wouldn't this need to go through a review process (setting the flags accordingly) etc.?
Comment 43 Juan Manuel Rodriguez 2009-07-13 11:08:28 EDT
Benjamin, Since I want to adopt this package (And I didn't create the original bug), I hadn't checked the flags or anything. 

Thanks for the reminder.
Comment 44 Toshio Ernie Kuratomi 2009-07-15 02:59:15 EDT
* Package follows the naming guidelines
* spec file is appropriately named
* spec file is in Englishand legible
* No SRPM provided -- Source URL is canonical
* Package builds on x86 and x86_64
* Package does not build on ppc and ppc64 with an appropraite comment as to why
  - Once the package isapproved and has a bugzilla component, please open a bug
    and have it block the ppc trackers:
    : https://bugzilla.redhat.com/show_bug.cgi?id=179260
    : https://bugzilla.redhat.com/show_bug.cgi?id=238953
  - remember to add the bug # to the comments in the spec file
* gnome-do-plugins-0.8.1 does not have language files so no %find_lang is needed.
  From what I'm reading, gnome-do-plugins-0.8.2 has some language catalogs so be
  sure to use %find_lang to mark the language files when updating to that
* Not a dynamic library
* Not relocatable
* All directories are owned
* rpmlint:All the subpackages have this:
  - gnome-do-plugins-banshee.i586: W: summary-not-capitalized gnome-do plugin for banshee
    : This is fine since we're referencing the gnome-do package

  - gnome-do-plugins-banshee.i586: W: no-documentation
    : Documentation is in the main gnome-do-plugins package

So both of these are fine.

  - gnome-do-plugins.src: W: mixed-use-of-spaces-and-tabs (spaces: line 1, tab: line 11)
    : The SRPM has this note that spaces and tabs are mixed. This is cosmetic    
      but is easily solved by changing tabs into spaces everywhere in the spec   
* No files or directories owned twice.                                           
* Permissions set properly                                                       
* Proper %clean section                                                          
* macros used consistently                                                       
* Package builds in koji.                                                        

* License should be GPLv3+
* The files need to install in %{_libdir}/gnome-do/plugins
  - gnome-do may or may not require patching to find plugins in that directory.
    I found this entry in the curent gnome-do's Do/src/Do.Core/Paths.cs but
    I don't know precisely what it does::
       yield return AppDomain.CurrentDomain.BaseDirectory.Combine (PluginsDirectory);

* Main package needs to Require: gnome-do
* Something needs to provide the %{_libdir}/gnome-do/plugins directory and all
  the plugin subpackages that install in there need to Require that package.
  Currently, the gnome-do-plugins package provides that directory but none of
  the other subpackages Require: gnome-do-plugins.  There's two possible
  1) Have all the other packages Require: gnome-do-plugins.
  2) Since all the plugins Require: gnome-do already, have the main gnome-do
     package own that directory instead of gnome-do-plugins.

* The noted mixing of spaces and tabs
* Since the patch is no longer requiredfor building, you can take it out
  instead of simply commenting it
Comment 45 Juan Manuel Rodriguez 2009-07-15 14:22:00 EDT

I uploaded the new files to my fedorapeople account. 

SPEC: http://nushio.fedorapeople.org/gnome-do-plugins/gnome-do-plugins.spec
SRPM: http://nushio.fedorapeople.org/gnome-do-plugins/gnome-do-plugins-0.8.1-2.fc11.src.rpm

I couldn't get it to build on my laptop though, I think its related to the file owner permissions. 

Here's the Koji link, where it *did* build correctly. 

Comment 46 Juan Manuel Rodriguez 2009-07-15 14:22:37 EDT

I uploaded the new files to my fedorapeople account. 

SPEC: http://nushio.fedorapeople.org/gnome-do-plugins/gnome-do-plugins.spec
SRPM: http://nushio.fedorapeople.org/gnome-do-plugins/gnome-do-plugins-0.8.1-2.fc11.src.rpm

I couldn't get it to build on my laptop though, I think its related to the file owner permissions. The errors I got are here: http://fpaste.org/paste/18837

Here's the Koji link, where it *did* build correctly. 

Comment 47 Toshio Ernie Kuratomi 2009-07-15 23:39:14 EDT
I've got an update that puts things into the proper directories.  While doing this I found out that some of the plugins are using bundled, precompiled files :-(.  Everything in BundledLibraries has to go and the plugins that depend on those bundled libraries also have to be disabled.  (This build does this).   At some point in the future, someone can package the gdata APIs for C# (I believe this is it: http://code.google.com/p/google-gdata/downloads/list ) and then the plugins can build against those.  Here's the build::

I'll attach the patch and spec file that make this work.

Using that as a base, here's the things that would still need work::

* License should be GPLv3+ (not GPLv3)
* Files are now installed in %{_libdir}/gnome-do/plugins.  Need to make sure that gnome-do works with that path or submit a patch to gnome-do to make it look there.
* Main package needs to Require: gnome-do
* Still have to decide whether to have all gnome-do-plugin subpackages require the main gnome-do-plugin package or move the %{_libdir}/gnome-do/plugins directory to the gnome-do package.
Comment 48 Toshio Ernie Kuratomi 2009-07-15 23:40:46 EDT
Created attachment 353941 [details]
Patch to use libdir instead of datadir for the plugin files
Comment 49 Toshio Ernie Kuratomi 2009-07-15 23:41:42 EDT
Created attachment 353942 [details]
Spec file to install to %{_libdir} and to not use the bundled libraries
Comment 50 Toshio Ernie Kuratomi 2009-07-16 21:31:07 EDT
Created attachment 354073 [details]
specfile that merges latest from nushio

Hmm... So I got an older version of the spec file from the srpm it looks like.  Here's the new spec file with the changes merged.

And a build with this:

Could you test that this works?  I don't know if gnome-do will need a patch to look in the new directory or not.  I also am not 100% sure I got all of the plugins that depend on the precompiled libraries... if some plugins are broken but others work we should look at that.
Comment 51 Toshio Ernie Kuratomi 2009-07-17 04:31:54 EDT
After some testing with Juan on IRC, it looks like this package will work if the subpackages have an added Requires: gnome-do-plugins

The main gnome-do-plugin package contains some metadata about which plugins are are installed that gnome-do needs in order to load the plugin file.  There's also some additional files that needed to be removed because they depend on the precompiled binary google.gdata libraries.

Nushio, want to upload the spec and one last koji scratch build?  It sounds like this is ready for approval but I want to check that the finished product runs fine since the movement of directories and removal of some plugins has been more complx than I'd like.
Comment 52 Juan Manuel Rodriguez 2009-07-17 13:10:43 EDT
Alright, finally built the new rpms, tested and everything seems to work fine. Even the Google plugins, which I suspect need the BundledLibraries to compile them, not to actually run them. 

The Koji Build: 

The SPEC: 

Comment 53 Toshio Ernie Kuratomi 2009-07-17 17:30:24 EDT
About the google plugins -- Google search and a few others should work as they don't need the bundled libraries.  But Youtube, google docs and a few others should fail.  If those don't fail (the ones that are being deleted in the spec file) then the bundled libraries are being statically linked so we'd need to delte them anyway.

Looking at the spec file, everything seems good to go!  remember to either get %{_libdir}/gnome-do/plugins owned by the gnome-do package or re-own it in the gnome-do-plugins package.  (Now that we know the plugin subpackages have to own the gnome-do-plugins package anyway, this makes more sense).  Your choice as long as one of the options gets done.

Comment 54 Juan Manuel Rodriguez 2009-07-17 17:43:40 EDT
I talked to Sindre (gnome-do packager) 3 days ago, he said he'd fix gnome-do to handle the plugins subfolder. 

I haven't checked if the package's been fixed, but by the time I commit the package, it should be fixed. 

I tried every single Google plugin, including Youtube. They all worked fine.
Comment 55 Juan Manuel Rodriguez 2009-07-17 20:55:08 EDT
New Package CVS Request
Package Name: gnome-do-plugins
Short Description: Plugins for gnome-do
Owners: nushio
Branches: devel, F-11
Comment 56 Kevin Fenzi 2009-07-19 16:47:07 EDT
cvs done.
Comment 57 Fedora Update System 2009-07-20 11:26:32 EDT
gnome-do-plugins-0.8.1-4.fc11 has been submitted as an update for Fedora 11.
Comment 58 Juan Manuel Rodriguez 2009-07-20 13:02:36 EDT
Thanks Toshio and Kevin!

Package has been built and commited for F11 and Rawhide.
Comment 59 cschol2112 2009-07-20 22:24:49 EDT
I don't see the package when searching for 'yum search gnome-do-plugins'. Does it take some time to show up in the repos?
Comment 60 Jason Tibbitts 2009-07-20 22:37:25 EDT
It can take quite some time.  Go to
From there you can see the status of any builds and updates, and download the packages directly if you don't want to wait for them to be released as stable updates.
Comment 61 Fedora Update System 2009-07-30 10:50:42 EDT
gnome-do-plugins-0.8.1-6.fc11 has been submitted as an update for Fedora 11.
Comment 62 Fedora Update System 2009-07-31 14:02:47 EDT
gnome-do-plugins-0.8.1-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-do-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8139
Comment 63 Fedora Update System 2009-08-11 18:37:23 EDT
gnome-do-plugins-0.8.1-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 64 Jud Craft 2009-08-18 20:51:04 EDT
Just wanted to say that I'm using the plugins for the first time and they're awesome.  Thanks everybody!

Note You need to log in before you can comment on or make changes to this bug.