Bug 48909 - Custom Kernel: bzImage won't write
Custom Kernel: bzImage won't write
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: GXedit (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-12 10:41 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:22:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-12 10:41:54 EDT
Description of Problem:
Custom kernel compilation would not write bzImage file

How Reproducible:
Attempted building a new kernel w/Micro-Solutions' module, and the first 
compilation wrote the 'bzImage' file.  That kernel didn't work because I 
accidentally chose the wrong processor, so I removed all the vestages of 
the new kernel & and attempted the custom kernel, again.  The 'bzImage' 
file was not written after two seperate attempts.

Steps to Reproduce:
1. built one kernel, installed it.
2. removed it after boot failure, tried compiling new one.
3. when that bzImage did not write, tried again.
4. All files were cleared after each attempt --new kernel, drivers, 
source, everything.

Actual Results:
After 'make module' failure, I checked to see if bzImage was actually 
written --it was not.  This happened on two seperate occasions, after 
being written on one occasion.

Expected Results:


Additional Information:
I used RedHat's HOW-TO when attempting this custom kernel.  I have 
successfully custom-built at least one kernel, though I am not what one 
would call experienced.  Quite frankly, I am very puzzled at the 
compiler's failure to 'made bzImage'.
Comment 1 Need Real Name 2001-07-13 10:51:17 EDT
Since I reported this problem, something weird happened which I think may be 
relevant:  The dialup networking speed went right down the toilet.  I was 
getting really good speeds --from 'root', not 'user'-- and I saw the  max 
speed listed on the Details graph, get cut by about 1/2 to 2/3.  Instead of 
reporting 7k/sec as the max  --I'm on a 28.8 line, right now, in Michigan-- it 
was reporting 2 or 3k/sec as the max & I got many 'stall' problems to the 
point that, after 20 minutes, your web-site still hadn't loaded.  (Normal time 
for loading your site is anywhere from 5-10 seconds under usual circumstances.)

Since I could not even e-mail, for the same reason as above, I decided to just 
dump the installation & reinstall the whole thing from scratch.  The result 
was that I was able to get the usual speed that the current phone line 
permits, and load your page in roughly 5-10 seconds, as before.

Can all this be *just_because* I attempted to recompile/install the kernel 
after downloading/installing all the listed updates, or is there something 
more subtle going on, here...?

Any questions, I'll do my best to answer; any suggestions as to things I might 
try, I'll do my best.  (Not too happy after spending a day d/l & installing 
all the updates, but guess that comes w/the territory, huh. :-\)
Comment 2 Need Real Name 2001-07-14 15:52:07 EDT
After bzImage wouldn't write, I reinstalled to start afresh; bzImage wrote, 
okay, even before installing the kernel things started to go haywire so I 
reinstalled again (see Bug#47871 for details).  The problem was that RH7.1 
would no longer read vfat floppies.  The error indicated I should specify the 
system type, though it was set to 'auto'.  I did that --specifying vfat-- and 
it still wouldn't read floppy disk.  I never had experienced a misbehaving 
system *just_because* I compiled a custom kernel ...never mind not installing, 
yet.
Comment 3 Need Real Name 2001-07-20 18:52:00 EDT
I reinstalled RedHat from scratch, applied all the upgrades, and once again 
recompiling the kernel refused to write the 'bzImage' file.  Recompiling the 
kernel isn't rocket science.  I followed the accepted How-to documents either 
on --or pointed to by-- your site.  Specifically, I used the How-to for 
upgrading the kernel & the new kernel booted w/o a hitch. Nothing stopped 
working (except as noted above).  I used the Brian Ward How-to for recompiling 
the kernel, following the instructions to the letter on the off-chance I had 
missed something when attempting to do it, before ...and for the 3rd time in a 
row, the bzImage won't write.  If you're not going to offer any sage advice on 
this subject (for *whatever* reason), then please so-state, and I'll keep 
looking around for the 'keeper' distro.  I am more than merely attempting to 
help you find bugs.  I am an independent reviewer ...but more importantly, I'm 
looking for a good distro for my Toshiba notebook! <G>   Thanks! :-)
Comment 4 Bill Nottingham 2006-08-07 16:02:05 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 5 Bill Nottingham 2006-10-18 13:22:52 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.