This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 489093 - selinux-policy not allowing kde4-config to write to ~root/.kde
selinux-policy not allowing kde4-config to write to ~root/.kde
Status: CLOSED DUPLICATE of bug 498809
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 500944 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-07 08:02 EST by vikram goyal
Modified: 2009-05-26 12:43 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 12:43:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
selinux alert (2.25 KB, text/plain)
2009-03-07 08:02 EST, vikram goyal
no flags Details

  None (edit)
Description vikram goyal 2009-03-07 08:02:28 EST
Created attachment 334395 [details]
selinux alert

Description of problem:
SELinux prevented kde4-config from writing ./.kde.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.5.13-46.fc10.noarch
selinux-policy-3.5.13-46.fc10.noarch
kdelibs-4.2.0-15.fc10.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 vikram goyal 2009-03-07 08:03:18 EST
setsebool -P allow_daemons_dump_core=1 was executed
Comment 2 Rex Dieter 2009-03-11 12:08:28 EDT
Hrm, I can't seem to reproduce this.
Comment 3 Rex Dieter 2009-03-11 12:30:22 EDT
Reconfirmed ok here (using kde-4.2.1, currently in updates-testing).

How are you logging into kde?  Using gdm, kdm?
Comment 4 Rex Dieter 2009-03-11 13:39:07 EDT
Ah, ha, nuked my ~root/.kde folder, and now can see it.
Comment 5 vikram goyal 2009-03-14 13:06:39 EDT
Its GDM.
Comment 6 Andre Robatino 2009-03-22 12:29:34 EDT
I see it with selinux-policy-targeted-3.5.13-48.fc10.noarch, even though I have a ~root/.kde directory.  It appears to happen at every boot.  Please change the Summary to remove the version number.  Also, I'm on x86_64, so the Platform should be "All Linux".
Comment 7 Rex Dieter 2009-03-22 12:47:48 EDT
adjusted summary/platform.
Comment 8 Steven M. Parrish 2009-04-27 14:52:53 EDT
Ping?
Comment 9 Daniel Stripes 2009-05-15 08:27:36 EDT
I am still seeing this with selinux-policy-3.5.13-58.fc10, kdelibs-4.2.2-12.fc10, and kernel 2.6.27.21-170.2.56.fc10.i686.  Logging in using gdm here also.
Comment 10 Rex Dieter 2009-05-15 08:52:33 EDT
*** Bug 500944 has been marked as a duplicate of this bug. ***
Comment 11 Steven M. Parrish 2009-05-26 12:43:37 EDT
During today's KDE-SIG meeting we decided this is the same issue as described in https://bugzilla.redhat.com/show_bug.cgi?id=498809.  So closing as a dupe of that one.

*** This bug has been marked as a duplicate of bug 498809 ***

Note You need to log in before you can comment on or make changes to this bug.