Bug 498809 - /etc/profile.d/kde4.sh: call to kde4-config expensive (2-4 seconds), causes inappropriate /.kde accesses
/etc/profile.d/kde4.sh: call to kde4-config expensive (2-4 seconds), causes i...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 489093 504209 518861 566066 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-03 10:39 EDT by Michael Monreal
Modified: 2010-02-17 08:56 EST (History)
15 users (show)

See Also:
Fixed In Version: 4.2.3-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:35:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Part of the bootchart (11.07 KB, image/png)
2009-05-03 10:40 EDT, Michael Monreal
no flags Details
search kde4 plugins path (1.20 KB, patch)
2009-05-06 15:02 EDT, Rex Dieter
no flags Details | Diff

  None (edit)
Description Michael Monreal 2009-05-03 10:39:44 EDT
I just played a bit with bootchart and found (if I read the chart correctly) that GDM somehow runs kde4-config. The result is that the boot process takes about 2-4 seconds longer (I tested with kde4-config removed) because kde4-config pulls in a lot of extra libs (Qt4...). This is quite a lot considering the whole boot takes about 28-30 seconds.

Now I'm wondering why kde4-config is called. All it seems to do is echoing the installation prefix (or nothing here, because I don't have a full KDE4 desktop installed).
Comment 1 Michael Monreal 2009-05-03 10:40:40 EDT
Created attachment 342235 [details]
Part of the bootchart
Comment 2 Matthias Clasen 2009-05-03 16:11:53 EDT
Probably some autostart file that gets installed by some kde package.
Can you look around in /etc/xdg/autostart and /usr/share/gnome/autostart ?
Could also be due to some xinitrc script, so look through
/etc/X11/xinit/xinitrc.d/ as well.
Comment 3 Michael Monreal 2009-05-03 17:11:03 EDT
Hmm, nothing relevant in those autostart dirs (I made sure and cat * | grep kde turns up nothing). Same for xinitrc.d, but I found /etc/profile.d/kde4.sh (drom kdelibs rpm) which seems to just set QT_PLUGIN_PATH to whatever "kde4-config --path qtplugins" returns: some directory in /usr which I'm sure KDE/QT apps look in even if QT_PLUGIN_PATH is unset.

If you can confirm that GDM just executes all the scripts in /etc/profile.d/ we can re-assign to kdelibs I think. I'm sure the kde4.sh has it's use but calling kde4-config and adding 2-4 seconds delay does not seem to be justified.

[1] http://koji.fedoraproject.org/koji/rpminfo?rpmID=1191706
Comment 4 Matthias Clasen 2009-05-03 17:34:02 EDT
Stuff in /etc/profile.d gets read by bash when you start it as a login shell.
Comment 5 Michael Monreal 2009-05-03 17:47:54 EDT
That was my impression as well, but somehow things get run automatically before I start a bash.
Comment 6 Matthias Clasen 2009-05-06 12:40:50 EDT
Ok, moving this to the kde-side. It has nothing to do with gdm.
Comment 7 Rex Dieter 2009-05-06 13:02:31 EDT
I'll see if we can put in additions to QT_PLUGIN_PATH by default, without having to resort to using hackish and expensive env variables.

Any comments or objections to this plan?
Comment 8 Rex Dieter 2009-05-06 15:02:54 EDT
Created attachment 342703 [details]
search kde4 plugins path

A first attempt at patching qt to always search kde4 plugin path.  Any comments?

(Should work I think, but I only tested if it builds, not tested if it works yet)
Comment 9 Rex Dieter 2009-05-06 15:43:46 EDT
tested qt patch, it works as advertised.

If there aren't any red-flags here, we could consider dropping munging QT_PLUGINS_PATH in /etc/profile.d/kde4.sh now.
Comment 10 Rex Dieter 2009-05-07 09:56:44 EDT
After some (irc-mostly) discussion, we're going to try the KISS approach, and avoid qt patching, and just use
QT_PLUGIN_PATH="/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins"
in kde4.(sh|csh) and see how things go.
Comment 11 Rex Dieter 2009-05-12 11:17:20 EDT
Officially waffled, trying qt approach first, to avoid possible complications of listing non-native-arch bits (and it potentially non-preferred order) in QT_PLUGIN_PATH.

qt-4.5.1-10 includes aforementioned patch
kdelibs-4.2.3-3 will drop QT_PLUGINS_PATH munging (for now).
Comment 12 Fedora Update System 2009-05-13 22:54:39 EDT
kdeaccessibility-4.2.3-1.fc11, kdeadmin-4.2.3-1.fc11, kdeartwork-4.2.3-1.fc11, kdebase-4.2.3-1.fc11, kdebase-workspace-4.2.3-2.fc11, kdebindings-4.2.3-2.fc11, kdeedu-4.2.3-1.fc11, kdegames-4.2.3-1.fc11, kdegraphics-4.2.3-1.fc11, kdemultimedia-4.2.3-1.fc11, kdenetwork-4.2.3-1.fc11, kdepim-4.2.3-1.fc11, kdepimlibs-4.2.3-1.fc11, kdeplasma-addons-4.2.3-1.fc11, kdesdk-4.2.3-1.fc11, kdetoys-4.2.3-1.fc11, kdeutils-4.2.3-1.fc11, kde-l10n-4.2.3-1.fc11, kdebase-runtime-4.2.3-2.fc11, kdelibs-4.2.3-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeaccessibility kdeadmin kdeartwork kdebase kdebase-workspace kdebindings kdeedu kdegames kdegraphics kdemultimedia kdenetwork kdepim kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils kde-l10n kdebase-runtime kdelibs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4808
Comment 13 Fedora Update System 2009-05-18 22:03:01 EDT
kdeaccessibility-4.2.3-1.fc11, kdeadmin-4.2.3-1.fc11, kdeartwork-4.2.3-1.fc11, kdebase-4.2.3-1.fc11, kdebindings-4.2.3-2.fc11, kdeedu-4.2.3-1.fc11, kdegames-4.2.3-1.fc11, kdegraphics-4.2.3-1.fc11, kdemultimedia-4.2.3-1.fc11, kdenetwork-4.2.3-1.fc11, kdepim-4.2.3-1.fc11, kdepimlibs-4.2.3-1.fc11, kdeplasma-addons-4.2.3-1.fc11, kdesdk-4.2.3-1.fc11, kdetoys-4.2.3-1.fc11, kdeutils-4.2.3-1.fc11, kde-l10n-4.2.3-1.fc11, kdebase-runtime-4.2.3-2.fc11, kdelibs-4.2.3-3.fc11, kdebase-workspace-4.2.3-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeaccessibility kdeadmin kdeartwork kdebase kdebindings kdeedu kdegames kdegraphics kdemultimedia kdenetwork kdepim kdepimlibs kdeplasma-addons kdesdk kdetoys kdeutils kde-l10n kdebase-runtime kdelibs kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4808
Comment 14 Kevin Kofler 2009-05-19 10:22:15 EDT
We should push that one to stable together with the Qt 4.5.1 update, not the KDE 4.2.3 one, as it needs changes both in Qt and KDE.
Comment 15 Fedora Update System 2009-05-20 19:53:05 EDT
qt-4.5.1-10.fc11, kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt kdelibs kdeplasma-addons'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4813
Comment 16 Fedora Update System 2009-05-25 17:17:33 EDT
kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11, qt-4.5.1-11.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs kdeplasma-addons qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4813
Comment 17 Steven M. Parrish 2009-05-26 12:43:37 EDT
*** Bug 489093 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2009-06-02 10:37:24 EDT
kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11, qt-4.5.1-13.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs kdeplasma-addons qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4813
Comment 19 Kevin Kofler 2009-06-04 19:21:04 EDT
*** Bug 504209 has been marked as a duplicate of this bug. ***
Comment 20 Kevin Kofler 2009-06-04 19:22:57 EDT
As written in the 2 duplicates, this also causes /.kde in the root directory to be accessed (/root/.kde or /home/*/.kde are valid, /.kde isn't), which gets denied by SELinux.
Comment 21 Bug Zapper 2009-06-09 11:04:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 Fedora Update System 2009-06-15 21:35:27 EDT
kdelibs-4.2.3-3.fc11, kdeplasma-addons-4.2.3-2.fc11, qt-4.5.1-13.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Kevin Kofler 2009-08-23 16:33:06 EDT
*** Bug 518861 has been marked as a duplicate of this bug. ***
Comment 24 Daniel Walsh 2010-02-17 08:56:06 EST
*** Bug 566066 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.