Bug 489246 - Unable to connect to internet using HUAWEI E220 USB Modem
Unable to connect to internet using HUAWEI E220 USB Modem
Status: CLOSED DUPLICATE of bug 487663
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 00:30 EDT by yunus
Modified: 2009-03-16 17:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 17:45:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (1.74 MB, text/plain)
2009-03-09 00:48 EDT, yunus
no flags Details

  None (edit)
Description yunus 2009-03-09 00:30:06 EDT
Description of problem:
I could not connect to the internet using HUAWEI E220 USB Modem. It also often shows double (the same) connection name entry on nm-applet


Version-Release number of selected component (if applicable):
[yunusf10@tselnode-114-121-144-13 ~]$ rpm -aq | grep NetworkManager
NetworkManager-vpnc-0.7.0.99-1.fc11.x86_64
NetworkManager-glib-0.7.0.99-1.fc11.x86_64
NetworkManager-0.7.0.99-1.fc11.x86_64
NetworkManager-openvpn-0.7.0.99-1.fc11.x86_64
NetworkManager-gnome-0.7.0.99-1.fc11.x86_64


How reproducible:
it's always reproducible

Steps to Reproduce:
1.boot my laptop
2.try to connecto to internet via nm-applet
3.
  
Actual results:
It fails to connect to internet without unplug the USB Modem and plug again the USB Modem

Expected results:
It should just connect to internet using nm-applet without causing kerneloops and without showing double connection name

Additional info:

Please let me know that you still need additional information that I have to provide
Comment 1 yunus 2009-03-09 00:48:01 EDT
Created attachment 334464 [details]
/var/log/messages
Comment 2 bobpoljakov 2009-03-11 16:27:36 EDT
Same situation here. I have a huawei e870, after updating to NetworkManager-0.7.0.99-1 the connection stopped working, after boot. If I unplug the card, and insert it again, it started to work. After upgrading to the latest NM this workaround doesn't work anymore.
Comment 3 Tomer Perry 2009-03-11 17:26:26 EDT
Same here with icon225 USB modem - on f10 x86.
After the latest update can't connect using the modem anymore ( worked fine with older versions)
It seems that NM don't identify the right ttyHSx to use.
Its either shows:
NetworkManager: <info>  (ttyHS3): detected GSM modem via udev capabilities

Where ttyHS3 is not the application port
Comment 4 Dan Williams 2009-03-12 11:06:37 EDT
(In reply to comment #3)
> Same here with icon225 USB modem - on f10 x86.
> After the latest update can't connect using the modem anymore ( worked fine
> with older versions)
> It seems that NM don't identify the right ttyHSx to use.
> Its either shows:
> NetworkManager: <info>  (ttyHS3): detected GSM modem via udev capabilities
> 
> Where ttyHS3 is not the application port  

This would be a different problem, since your card is not a Huawei card.

In your case, what is the contents of:

 /sys/class/tty/ttyHS0/hso_type
 /sys/class/tty/ttyHS1/hso_type
 /sys/class/tty/ttyHS2/hso_type
 /sys/class/tty/ttyHS3/hso_type
 /sys/class/tty/ttyHS4/hso_type
Comment 5 Massimiliano 2009-03-13 18:09:47 EDT
Same situation with my HUAWEI E169 usb modem after updating to
NetworkManager-0.7.0.99-3.fc10. The modem works only if it is plugged before the computer starts.
The output from 'uname -mprv':

2.6.27.19-170.2.35.fc10.i686 #1 SMP Mon Feb 23 13:21:22 EST 2009 i686 i686

The output from /var/log/messages:

Mar 13 22:06:36 localhost NetworkManager: <info>  Activation (ttyUSB2) starting connection 'Auto Mobile Broadband (GSM) connection'
Mar 13 22:06:36 localhost NetworkManager: <info>  (ttyUSB2): device state change: 3 -> 4
Mar 13 22:06:36 localhost NetworkManager: <info>  Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) scheduled...
Mar 13 22:06:36 localhost NetworkManager: <info>  Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) started...
Mar 13 22:06:36 localhost NetworkManager: <info>  Activation (ttyUSB2) Stage 1 of 5 (Device Prepare) complete.
Mar 13 22:06:46 localhost NetworkManager: <WARN>  init_done(): Modem initialization timed out
Mar 13 22:06:46 localhost NetworkManager: <info>  (ttyUSB2): device state change: 4 -> 9
Mar 13 22:06:46 localhost NetworkManager: <info>  Marking connection 'Auto Mobile Broadband (GSM) connection' invalid.
Mar 13 22:06:46 localhost NetworkManager: <info>  Activation (ttyUSB2) failed.
Mar 13 22:06:46 localhost NetworkManager: <info>  (ttyUSB2): device state change: 9 -> 3
Mar 13 22:06:46 localhost NetworkManager: <info>  (ttyUSB2): deactivating device (reason: 0).
Mar 13 22:06:46 localhost NetworkManager: nm_system_device_flush_ip4_routes_with_iface: assertion `iface_idx >= 0' failed
Mar 13 22:06:46 localhost NetworkManager: nm_system_device_flush_ip4_addresses_with_iface: assertion `iface_idx >= 0' failed
Comment 6 Jessica Sterling 2009-03-14 20:59:10 EDT
This bug has been triaged.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Christoph Karl 2009-03-15 11:09:08 EDT
Same for my HUAWEI E220 modem:
NetworkManager-0.7.0.99-3.fc10
does not work.
A fallback to 
NetworkManager-0.7.0-0.11.svn4229.fc10
makes it work again.
Plain F10 with all other updates installed.
If more info needed, please tell me.
Comment 8 Tomer Perry 2009-03-15 17:49:03 EDT
Hi,

I guess you mean /sys/class/tty/ttyHSx/hsotype, and I have only 4:

/sys/class/tty/ttyHS0/hsotype ---- Control
/sys/class/tty/ttyHS1/hsotype ---- Application
/sys/class/tty/ttyHS2/hsotype ---- Diagnostic
/sys/class/tty/ttyHS3/hsotype ---- Modem

OTOH, I also got a sierra based modem now.
I suspect I have similar behaviour; udev seems to identify everything OK, but NM choose the wrong port. The right port is usually /dev/ttyUSB3, while NM tries /dev/ttyUSB0. A simple symlink between USB3 to USB0 do the trick and NM works OK.
Comment 9 Dan Williams 2009-03-16 15:43:43 EDT
(In reply to comment #8)
> Hi,
> 
> I guess you mean /sys/class/tty/ttyHSx/hsotype, and I have only 4:
> 
> /sys/class/tty/ttyHS0/hsotype ---- Control
> /sys/class/tty/ttyHS1/hsotype ---- Application
> /sys/class/tty/ttyHS2/hsotype ---- Diagnostic
> /sys/class/tty/ttyHS3/hsotype ---- Modem
> 
> OTOH, I also got a sierra based modem now.
> I suspect I have similar behaviour; udev seems to identify everything OK, but
> NM choose the wrong port. The right port is usually /dev/ttyUSB3, while NM
> tries /dev/ttyUSB0. A simple symlink between USB3 to USB0 do the trick and NM
> works OK.  

Tom; current NM upstream will fix your issue (I've tested with two different devices including the iCON 225).  This bug is about the Huawei cards though, which are somewhat different.  The sierra issue you're having is the same issue as this bug though, where NM chooses the wrong port.  I've fixed the issue for Sierra modems upstream as well (tested with AT&T Mercury (rebranded Sierra), Sierra 881, and Sierra AC860).
Comment 10 Dan Williams 2009-03-16 17:45:52 EDT

*** This bug has been marked as a duplicate of bug 487663 ***

Note You need to log in before you can comment on or make changes to this bug.