Bug 487663 - Huawei mobile broadband fails with NetworkManager >= 0.7.0.97
Huawei mobile broadband fails with NetworkManager >= 0.7.0.97
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 489246 490482 490864 491728 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 06:12 EST by Mary Ellen Foster
Modified: 2009-05-12 00:06 EDT (History)
13 users (show)

See Also:
Fixed In Version: 0.7.0.99-4.git20090324.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 12:12:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages excerpt from a successful connection (6.28 KB, text/plain)
2009-02-27 06:12 EST, Mary Ellen Foster
no flags Details
Log file (from different computer) showing failed connection (2.52 KB, text/plain)
2009-02-27 06:18 EST, Mary Ellen Foster
no flags Details
Script of two unsuccessful connection attempts (5.43 KB, text/plain)
2009-03-04 04:37 EST, Mary Ellen Foster
no flags Details

  None (edit)
Description Mary Ellen Foster 2009-02-27 06:12:45 EST
Created attachment 333459 [details]
/var/log/messages excerpt from a successful connection

Description of problem:
The above-mentioned version of NetworkManager breaks mobile broadband. I can no longer connect to my GSM network, which works fine with NetworkManager-0.7.0-2.git20090207.fc10.i386.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0.97-5.git20090220.fc10

How reproducible:
Every time

Steps to Reproduce:
1. Use nm-applet to connect to a GSM network
  
Actual results:
Connection fails -- log excerpt will be attached.

Expected results:
Working connection -- log excerpt attached.
Comment 1 Mary Ellen Foster 2009-02-27 06:18:32 EST
Created attachment 333461 [details]
Log file (from different computer) showing failed connection

Here's the log of an unsuccessful connection on a different computer. The "PIN checking timed out" part looks suspicious (we never even got a PIN-entry window popping up!)
Comment 2 Mary Ellen Foster 2009-02-27 06:51:06 EST
Downgrading to version 0.7.0-1.git20090102.fc10.i386 on the affected machines made the mobile broadband work again, so it's definitely a NetworkManager issue.
Comment 3 Dan Williams 2009-02-27 18:13:57 EST
What mobile broadband card do you have, and what provider?

Also, are you comfortable using the terminal?  There are a few things we can do to figure out what's going on, including getting a root shell and turning on serial debugging.  That would involve:

(both as root)
1) service NetworkManager stop
2) NM_SERIAL_DEBUG=1 /usr/sbin/NetworkManager --no-daemon

Then start the connection from the applet.  When it fails, grab the output and attach it to this bug.  Thanks!
Comment 4 Mary Ellen Foster 2009-03-04 04:37:35 EST
Created attachment 333981 [details]
Script of two unsuccessful connection attempts

The card is a Huawei stick of some sort -- sorry, I forgot to note the exact details this morning. I'm using a Vodafone Germany UMTS (3G) connection. My kernel is kernel-2.6.27.19-170.2.35.fc10.i686

I've attached the output of two unsuccessful connection attempts while running NetworkManager with NM_SERIAL_DEBUG=1. This is the normal case -- failing early. I've also managed to get a kernel oops sometimes instead, but it didn't happen while I was testing this morning. I'll try again when I next get home.
Comment 5 Jessica Sterling 2009-03-08 20:28:41 EDT
This bug has been triaged.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 bobpoljakov 2009-03-11 16:45:02 EDT
Same here. Huawei E870, Vodafone, 2.6.27.19-170.2.35.fc10.i686.PAE kernel, and the last two NM updates
Comment 7 TC 2009-03-15 23:17:11 EDT
I am seeing the same problem with 0.7.0.99 with my Huawei E220 that was resolved by downgrading to NetworkManager-0.7.0-1.git20090102.fc10. Incidentally I had to delete the "Automatic GSM Connection" profile after downgrading in order for the 3G connection to function properly again.

One more thing to note was that the dialing number was auto-set to *99# in this version, whereas previously it was auto-set to *99*1# (my network provider expects *99*111#, but *99*1# works as well)
Comment 8 Dan Williams 2009-03-16 15:41:41 EDT
I need the serial debugging info I requested in Comment #3 from somebody...

NM will always set the dialing number to *99#; but it will override that number if you have entered an APN, and use the correct dialing string for the APN.

The problem with Huawei modems is that they provide multiple serial ports, and NM wasn't doing a good job of figuring out which one to use.  I believe I've corrected that issue upstream, so we'll have to wait for the next update to figure out whether it's fixed or not.  I also have ordered a Huawei E160G to help debug further Huawei issues in the future.
Comment 9 Mary Ellen Foster 2009-03-16 15:55:24 EDT
Are the logs that I attached in Comment #4 not enough? I can try again, but tell me what to do differently if those are inadequate.
Comment 10 Dan Williams 2009-03-16 16:11:15 EDT
(In reply to comment #9)
> Are the logs that I attached in Comment #4 not enough? I can try again, but
> tell me what to do differently if those are inadequate.  

Ah, sorry, those are just fine.  I had expected more serial communication with the device, but it seems that it just fails too soon.  I'm preparing some updates that will either fix the issue or further help debug it, either one.

Mary, what specific mobile broadband device do you have, is it a Huawei device?
Comment 11 Mary Ellen Foster 2009-03-16 16:27:51 EDT
lsusb calls it a "Huawei Technologies Co., Ltd. E620 USB Modem"
Comment 12 Dan Williams 2009-03-16 17:45:52 EDT
*** Bug 489246 has been marked as a duplicate of this bug. ***
Comment 13 Dan Williams 2009-03-18 09:23:07 EDT
*** Bug 490864 has been marked as a duplicate of this bug. ***
Comment 14 Pawel Salek 2009-03-18 13:04:52 EDT
*** Bug 490482 has been marked as a duplicate of this bug. ***
Comment 15 Dan Williams 2009-03-20 18:39:20 EDT
I believe I've fixed this upstream, Fedora builds coming presently...
Comment 16 yunus 2009-03-21 06:08:13 EDT
(In reply to comment #15)
> I believe I've fixed this upstream, Fedora builds coming presently...  

I found NetworkManager-0.7.0.99-3.5.git20090318.fc11 at koji ( http://koji.fedoraproject.org/koji/buildinfo?buildID=94658)

Changelog
* Wed Mar 18 2009 Dan Williams <dcbw@redhat.com> - 1:0.7.0.99-3.5 
- nm: work around unhandled device removals due to missing HAL events 
- nm: improve handling of multiple modem ports 
- nm: support for Sony Ericsson F3507g / MD300 and Dell 5530 
- applet: updated translations 

It works for me now. I hope that other that uses F10 will confirm if it also work for them
Comment 17 Graham Cox 2009-03-21 23:12:23 EDT
Dan, should we download and use the build for F11 that you built here? http://koji.fedoraproject.org/koji/buildinfo?buildID=94658

Or is it best to keep using a previous version in F10 and wait for F11 in May?

Thanks for all your hard work in resolving this issue for all of us. :)
Comment 18 Graham Cox 2009-03-22 03:06:50 EDT
I decided to install the RPM for F11. There's no longer a NetworkManager icon in the system tray and I have no network connectivity at home whatsoever. Back to the old version for now...
Comment 19 Dan Williams 2009-03-23 15:12:00 EDT
*** Bug 491728 has been marked as a duplicate of this bug. ***
Comment 20 Alasdair Kergon 2009-03-23 21:49:01 EDT
I've just built this locally for f10 and so far it's connected successfully every time, whereas before the only reliable way I found to reconnect after the network dropped out for any reason was to reboot the machine. (Huawei E220)  Can this go into F10 updates?
Comment 21 Dan Williams 2009-03-24 06:53:31 EDT
(In reply to comment #20)
> I've just built this locally for f10 and so far it's connected successfully
> every time, whereas before the only reliable way I found to reconnect after the
> network dropped out for any reason was to reboot the machine. (Huawei E220) 
> Can this go into F10 updates?  

Yes, it's going to get built as an update today.
Comment 22 yunus 2009-03-24 10:46:02 EDT
The latest build (see above) did not work for me

[yunusf10@localhost config-files]$ rpm -qa | grep NetworkManager
NetworkManager-vpnc-0.7.0.99-1.fc11.x86_64
NetworkManager-0.7.0.99-4.git20090324.fc11.x86_64
NetworkManager-gnome-0.7.0.99-4.git20090324.fc11.x86_64
NetworkManager-glib-0.7.0.99-4.git20090324.fc11.x86_64
NetworkManager-openvpn-0.7.0.99-1.fc11.x86_64
[yunusf10@localhost config-files]$ 

I found not entry for my Huawei E220 USB Modem. 

[yunusf10@localhost etc]$ su -c 'service NetworkManager stop'Password: 
Stopping NetworkManager daemon:                            [  OK  ]
[yunusf10@localhost etc]$ su -c 'NM_SERIAL_DEBUG=1 /usr/sbin/NetworkManager --no-daemon'
Password: 
NetworkManager: <info>  starting...
-- Error received: File exists
-- Original message: type=0x14 length=56 flags=<REQUEST,ACK,ATOMIC> sequence-nr=1237904332 pid=4197927
NetworkManager: <WARN>  nm_generic_enable_loopback(): error -17 returned from rtnl_addr_add():
Sucess

NetworkManager: <info>  Found radio killswitch /org/freedesktop/Hal/devices/platform_acer_wmi_rfkill_acer_wireless_wlan
NetworkManager: <info>  Found radio killswitch /org/freedesktop/Hal/devices/pci_8086_4222_rfkill_3945ABG_wlan
NetworkManager: <info>  Found radio killswitch /org/freedesktop/Hal/devices/iwl_wlan_switch
NetworkManager: <info>  (eth0): new Ethernet device (driver: 'tg3')
NetworkManager: <info>  (eth0): exported as /org/freedesktop/Hal/devices/net_00_1b_24_52_f3_bf
NetworkManager: <info>  (wlan0): driver supports SSID scans (scan_capa 0x01).
NetworkManager: <info>  (wlan0): new 802.11 WiFi device (driver: 'iwl3945')
NetworkManager: <info>  (wlan0): exported as /org/freedesktop/Hal/devices/net_00_1b_77_51_5d_63
NetworkManager: <info>  (ttyUSB1): ignoring due to lack of mobile broadband capabilties
NetworkManager: <info>  (ttyUSB0): ignoring due to lack of mobile broadband capabilties
NetworkManager: <info>  (ttyS0): ignoring due to lack of mobile broadband capabilties
NetworkManager: <info>  (ttyS1): ignoring due to lack of mobile broadband capabilties
NetworkManager: <WARN>  killswitch_getpower_reply(): Error getting killswitch power: Method "GetPower" with signature "" on interface "org.freedesktop.Hal.Device.KillSwitch" doesn't exist
.
NetworkManager: <info>  Wireless now disabled by radio killswitch
NetworkManager: <info>  (eth0): device state change: 1 -> 2
NetworkManager: <info>  (eth0): bringing up device.
NetworkManager: <info>  (eth0): preparing device.
NetworkManager: <info>  (eth0): deactivating device (reason: 2).
NetworkManager: <info>  (wlan0): device state change: 1 -> 2
NetworkManager: <info>  (wlan0): bringing up device.
-- Error received: No such device
-- Original message: type=0x13 length=32 flags=<REQUEST,ACK> sequence-nr=1237904348 pid=4197927
NetworkManager: <info>  (wlan0): deactivating device (reason: 2).
^CNetworkManager: <WARN>  nm_signal_handler(): Caught signal 2, shutting down normally.
NetworkManager: <info>  (eth0): now unmanaged
NetworkManager: <info>  (eth0): device state change: 2 -> 1
NetworkManager: <info>  (eth0): cleaning up...
NetworkManager: <info>  (eth0): taking down device.
NetworkManager: <info>  (wlan0): now unmanaged
NetworkManager: <info>  (wlan0): device state change: 2 -> 1
NetworkManager: <info>  exiting (success)
[yunusf10@localhost etc]$
Comment 23 Fedora Update System 2009-03-24 10:54:21 EDT
NetworkManager-0.7.0.99-4.git20090324.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-4.git20090324.fc10
Comment 24 Fedora Update System 2009-03-24 10:57:32 EDT
NetworkManager-0.7.0.99-4.git20090324.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-4.git20090324.fc9
Comment 25 Dan Williams 2009-03-24 10:59:41 EDT
(In reply to comment #22)
> The latest build (see above) did not work for me
> 
> [yunusf10@localhost config-files]$ rpm -qa | grep NetworkManager
> NetworkManager-vpnc-0.7.0.99-1.fc11.x86_64
> NetworkManager-0.7.0.99-4.git20090324.fc11.x86_64
> NetworkManager-gnome-0.7.0.99-4.git20090324.fc11.x86_64
> NetworkManager-glib-0.7.0.99-4.git20090324.fc11.x86_64
> NetworkManager-openvpn-0.7.0.99-1.fc11.x86_64
> [yunusf10@localhost config-files]$ 
> 
> I found not entry for my Huawei E220 USB Modem. 

You'd need to reboot and/or plug/replug the modem.  Did you do either of those?
Comment 26 yunus 2009-03-24 11:15:14 EDT
(In reply to comment #25)
> (In reply to comment #22)
> > The latest build (see above) did not work for me
> > 
> > [yunusf10@localhost config-files]$ rpm -qa | grep NetworkManager
> > NetworkManager-vpnc-0.7.0.99-1.fc11.x86_64
> > NetworkManager-0.7.0.99-4.git20090324.fc11.x86_64
> > NetworkManager-gnome-0.7.0.99-4.git20090324.fc11.x86_64
> > NetworkManager-glib-0.7.0.99-4.git20090324.fc11.x86_64
> > NetworkManager-openvpn-0.7.0.99-1.fc11.x86_64
> > [yunusf10@localhost config-files]$ 
> > 
> > I found not entry for my Huawei E220 USB Modem. 
> 
> You'd need to reboot and/or plug/replug the modem.  Did you do either of those?  

Yes, I did those tricks but they did not work. I rebooted but found not entry in nm. Then I tried  to plug and replug. I still found no entry for my modem in nm.

I am currently running wvdial.
Comment 27 Dan Williams 2009-03-24 12:59:25 EDT
(In reply to comment #26)
> (In reply to comment #25)
> > (In reply to comment #22)
> > > The latest build (see above) did not work for me
> > > 
> > > [yunusf10@localhost config-files]$ rpm -qa | grep NetworkManager
> > > NetworkManager-vpnc-0.7.0.99-1.fc11.x86_64
> > > NetworkManager-0.7.0.99-4.git20090324.fc11.x86_64
> > > NetworkManager-gnome-0.7.0.99-4.git20090324.fc11.x86_64
> > > NetworkManager-glib-0.7.0.99-4.git20090324.fc11.x86_64
> > > NetworkManager-openvpn-0.7.0.99-1.fc11.x86_64
> > > [yunusf10@localhost config-files]$ 
> > > 
> > > I found not entry for my Huawei E220 USB Modem. 
> > 
> > You'd need to reboot and/or plug/replug the modem.  Did you do either of those?  
> 
> Yes, I did those tricks but they did not work. I rebooted but found not entry
> in nm. Then I tried  to plug and replug. I still found no entry for my modem in
> nm.

In that case, we can debug the udev  modem prober.  Can you edit /lib/udev/rules.d/77-nm-probe-modem-capabilities.rules like so?

change this line:

DRIVERS=="option|sierra|hso|cdc_acm", IMPORT{program}="nm-modem-probe --vid 0x$attr{idVendor} --pid 0x$attr{idProduct} --usb-interface $attr{bInterfaceNumber} --driver $attr{driver} --delay 3000 --export $tempnode", GOTO="nm_modem_probe_end"

to:

DRIVERS=="option|sierra|hso|cdc_acm", IMPORT{program}="nm-modem-probe --log /tmp/probe.log --verbose --quiet --vid 0x$attr{idVendor} --pid 0x$attr{idProduct} --usb-interface $attr{bInterfaceNumber} --driver $attr{driver} --delay 3000 --export $tempnode", GOTO="nm_modem_probe_end"

(ie, by adding "--log /tmp/probe.log --verbose --quiet" right after nm-modem-probe)

then unplug your adapter, replug it, and attach /tmp/probe.log for me.

Thanks!
Comment 28 Fedora Update System 2009-03-25 12:11:39 EDT
NetworkManager-0.7.0.99-4.git20090324.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 bobpoljakov 2009-03-26 09:01:14 EDT
For me, the latest update also not working. I can succesfully connect, but can't ping any ip-s. Reverting to the NetworkManager-0.7.0-1.git20090102.fc10.i386 solves this issue.
Comment 30 yunus 2009-03-26 09:43:03 EDT
(In reply to comment #27)
> (In reply to comment #26)
> > (In reply to comment #25)
> > > (In reply to comment #22)
> > > > The latest build (see above) did not work for me
> > > > 
> > > > [yunusf10@localhost config-files]$ rpm -qa | grep NetworkManager
> > > > NetworkManager-vpnc-0.7.0.99-1.fc11.x86_64
> > > > NetworkManager-0.7.0.99-4.git20090324.fc11.x86_64
> > > > NetworkManager-gnome-0.7.0.99-4.git20090324.fc11.x86_64
> > > > NetworkManager-glib-0.7.0.99-4.git20090324.fc11.x86_64
> > > > NetworkManager-openvpn-0.7.0.99-1.fc11.x86_64
> > > > [yunusf10@localhost config-files]$ 
> > > > 
> > > > I found not entry for my Huawei E220 USB Modem. 
> > > 
> > > You'd need to reboot and/or plug/replug the modem.  Did you do either of those?  
> > 
> > Yes, I did those tricks but they did not work. I rebooted but found not entry
> > in nm. Then I tried  to plug and replug. I still found no entry for my modem in
> > nm.
> 
> In that case, we can debug the udev  modem prober.  Can you edit
> /lib/udev/rules.d/77-nm-probe-modem-capabilities.rules like so?
> 
> change this line:
> 
> DRIVERS=="option|sierra|hso|cdc_acm", IMPORT{program}="nm-modem-probe --vid
> 0x$attr{idVendor} --pid 0x$attr{idProduct} --usb-interface
> $attr{bInterfaceNumber} --driver $attr{driver} --delay 3000 --export
> $tempnode", GOTO="nm_modem_probe_end"
> 
> to:
> 
> DRIVERS=="option|sierra|hso|cdc_acm", IMPORT{program}="nm-modem-probe --log
> /tmp/probe.log --verbose --quiet --vid 0x$attr{idVendor} --pid
> 0x$attr{idProduct} --usb-interface $attr{bInterfaceNumber} --driver
> $attr{driver} --delay 3000 --export $tempnode", GOTO="nm_modem_probe_end"
> 
> (ie, by adding "--log /tmp/probe.log --verbose --quiet" right after
> nm-modem-probe)
> 
> then unplug your adapter, replug it, and attach /tmp/probe.log for me.
> 
> Thanks!  

I found no /tmp/probe.log after doing the instruction you gave above.(even I also have rebooted the machine and repeated the instruction)

I have edited /lib/udev/rules.d/77-nm-probe-modem-capabilities.rules

-------------begin-of-file-----------------------
# do not edit this file, it will be overwritten on update

ACTION!="add|change", GOTO="nm_modem_probe_end"
SUBSYSTEM!="tty", GOTO="nm_modem_probe_end"
KERNEL!="tty*", GOTO="nm_modem_probe_end"

DRIVERS=="serial_cs", IMPORT{program}="nm-modem-probe --delay 3000 --export $tempnode", GOTO="nm_modem_probe_end"
DRIVERS=="option|sierra|hso|cdc_acm", IMPORT{program}="nm-modem-probe --log /tmp/probe.log --verbose --quiet --vid 
0x$attr{idVendor} --pid 0x$attr{idProduct} --usb-interface $attr{bInterfaceNumber} --driver $attr{driver} --delay 3
000 --export $tempnode", GOTO="nm_modem_probe_end"

LABEL="nm_modem_probe_end"
-------------end-of-file-------------------------


You may want to take a look at /var/log/messages below when I unpluged and replug the modem.
------------begin----------
<snip>
Mar 26 20:05:52 localhost kernel: usb 4-1: USB disconnect, address 2
Mar 26 20:05:52 localhost kernel: option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
Mar 26 20:05:52 localhost kernel: option 4-1:1.0: device disconnected
Mar 26 20:05:52 localhost kernel: option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
Mar 26 20:05:52 localhost kernel: option 4-1:1.1: device disconnected
Mar 26 20:06:03 localhost kernel: ALSA sound/pci/hda/hda_intel.c:633: hda_intel: azx_get_response timeout, switching to pollin
g mode: last cmd=0x11af000c
Mar 26 20:06:56 localhost kernel: usb 4-1: new full speed USB device using uhci_hcd and address 4
Mar 26 20:06:56 localhost kernel: usb 4-1: New USB device found, idVendor=12d1, idProduct=1003
Mar 26 20:06:56 localhost kernel: usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Mar 26 20:06:56 localhost kernel: usb 4-1: Product: HUAWEI Mobile
Mar 26 20:06:56 localhost kernel: usb 4-1: Manufacturer: HUAWEI Technologies
Mar 26 20:06:56 localhost kernel: usb 4-1: configuration #1 chosen from 1 choice
Mar 26 20:06:56 localhost kernel: usb-storage: probe of 4-1:1.0 failed with error -1
Mar 26 20:06:56 localhost kernel: usb 4-1: USB disconnect, address 4
Mar 26 20:06:56 localhost pulseaudio[3274]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuc
hProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_ffffffff_ffffffff_noserial
Mar 26 20:06:56 localhost pulseaudio[3274]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuc
hProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_ffffffff_ffffffff_noserial_
0
Mar 26 20:06:56 localhost kernel: usb 4-1: new full speed USB device using uhci_hcd and address 5
Mar 26 20:06:57 localhost kernel: usb 4-1: New USB device found, idVendor=12d1, idProduct=1003
Mar 26 20:06:57 localhost kernel: usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Mar 26 20:06:57 localhost kernel: usb 4-1: Product: HUAWEI Mobile
Mar 26 20:06:57 localhost kernel: usb 4-1: Manufacturer: HUAWEI Technologies
Mar 26 20:06:57 localhost kernel: usb 4-1: configuration #1 chosen from 1 choice
Mar 26 20:06:57 localhost kernel: usb-storage: probe of 4-1:1.0 failed with error -5
Mar 26 20:06:57 localhost kernel: option 4-1:1.0: GSM modem (1-port) converter detected
Mar 26 20:06:57 localhost kernel: usb 4-1: GSM modem (1-port) converter now attached to ttyUSB1
Mar 26 20:06:57 localhost kernel: usb-storage: probe of 4-1:1.2 failed with error -1
Mar 26 20:06:57 localhost pulseaudio[3274]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuc
hProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_12d1_1003_noserial
Mar 26 20:06:57 localhost pulseaudio[3274]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuc
hProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_12d1_1003_noserial_if1
Mar 26 20:06:57 localhost pulseaudio[3274]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuc
hProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_12d1_1003_noserial_if0
Mar 26 20:06:57 localhost pulseaudio[3274]: module-hal-detect.c: D-Bus error while parsing HAL data: org.freedesktop.Hal.NoSuc
hProperty: No property info.capabilities on device with id /org/freedesktop/Hal/devices/usb_device_12d1_1003_noserial_if2
Mar 26 20:06:57 localhost NetworkManager: <info>  (ttyUSB1): ignoring due to lack of mobile broadband capabilties
Mar 26 20:06:57 localhost NetworkManager: <info>  (ttyUSB0): found serial port (udev:  hal:GSM)
Mar 26 20:06:57 localhost NetworkManager: <info>  (ttyUSB0): ignoring due to lack of probed mobile broadband capabilties
<snip>
----end------------

Please do not hesitate to ask for information for me in order to solve the problem.

Thank you
yunus
Comment 31 Dan Williams 2009-03-26 17:31:45 EDT
yunus tji nyan: I fixed a bug yesterday in the handling of modem probing that is only present on rawhide due to changes in udev.  I'm building new packages that should fix your problem.  Please try the packages here and let me know if they work for you:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1260227
Comment 32 Fedora Update System 2009-03-26 18:04:49 EDT
NetworkManager-0.7.0.99-5.git20090326.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-5.git20090326.fc9
Comment 33 yunus 2009-03-27 10:34:09 EDT
(In reply to comment #31)
> yunus tji nyan: I fixed a bug yesterday in the handling of modem probing that
> is only present on rawhide due to changes in udev.  I'm building new packages
> that should fix your problem.  Please try the packages here and let me know if
> they work for you:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1260227  

Yes, it works for me. Thank you
Comment 34 bobpoljakov 2009-03-28 03:30:24 EDT
For me it's still not working. I have a Huawei e870, and with the latest NM I can connect to mobile net, but no internet at all, can't ping any host. Any idea how I can solve this problem? What does 'CLOSED NEXTRELEASE' mean? Next fedora release, next NM version?
Comment 35 yunus 2009-03-28 21:38:25 EDT
(In reply to comment #34)
> For me it's still not working. I have a Huawei e870, and with the latest NM I
> can connect to mobile net, but no internet at all, can't ping any host. Any
> idea how I can solve this problem?
Could you please attach /var/log/messages here?

What is the content of /etc/resolv.conf after you can connect to mobile net?

Those information might be useful for the developer.

> What does 'CLOSED NEXTRELEASE' mean? Next fedora release, next NM version?  
The problem described has been fixed in the next release of the product, and is not planned to be fixed in the release against which the bug was filed.
(see : https://bugzilla.redhat.com/page.cgi?id=fields.html)
Comment 36 bobpoljakov 2009-03-30 04:58:14 EDT
(In reply to comment #35)
> (In reply to comment #34)
> > For me it's still not working. I have a Huawei e870, and with the latest NM I
> > can connect to mobile net, but no internet at all, can't ping any host. Any
> > idea how I can solve this problem?
> Could you please attach /var/log/messages here?
> 
> What is the content of /etc/resolv.conf after you can connect to mobile net?
> 
> Those information might be useful for the developer.
> 
> > What does 'CLOSED NEXTRELEASE' mean? Next fedora release, next NM version?  
> The problem described has been fixed in the next release of the product, and is
> not planned to be fixed in the release against which the bug was filed.
> (see : https://bugzilla.redhat.com/page.cgi?id=fields.html)  

Thank you for the answer, the problem solved... i did nothing, i don't know what caused the problem, but now it's working as it worked with the previous release.
Comment 37 Igor 2009-04-02 03:12:48 EDT
I do have similar problem with NetworkManager-glib-0.7.0.99-5.git20090326.fc10.i386 and CMOTECH CDMA CNU-550E usb adapter

in /var/log/messages I see 

kernel: usb 4-1: new full speed USB device using uhci_hcd and address 2 kernel: usb 4-1: configuration #1 chosen from 1 choice kernel: usb 4-1: New USB device found, idVendor=16d8, idProduct=5543 kernel: usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3 kernel: usb 4-1: Product: CMOTECH CDMA Technologies kernel: usb 4-1: Manufacturer: CMOTECH CO., LTD. kernel: usb 4-1: SerialNumber: Serial Number kernel: cdc_acm 4-1:1.0: ttyACM0: USB ACM device kernel: usbcore: registered new interface driver cdc_acm kernel: cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters NetworkManager: <info>  (ttyACM0): found serial port (udev:  hal:CDMA) NetworkManager: <info>  (ttyACM0): ignoring due to lack of probed mobile broadband capabilties
Comment 38 Fedora Update System 2009-04-08 23:04:01 EDT
NetworkManager-0.7.0.100-2.git20090408.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.100-2.git20090408.fc9
Comment 39 Fedora Update System 2009-04-14 21:23:27 EDT
NetworkManager-0.7.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.1-1.fc9
Comment 40 Fedora Update System 2009-05-12 00:06:41 EDT
NetworkManager-0.7.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.