Bug 489408 - Xkb configuration
Xkb configuration
Status: CLOSED DUPLICATE of bug 483195
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-09 17:30 EDT by Sandrine Soudant
Modified: 2015-01-14 18:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-15 20:10:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot and log as required by X Server's message (44.70 KB, application/x-gzip)
2009-03-09 17:33 EDT, Sandrine Soudant
no flags Details
screenshot of the error message (45.16 KB, image/png)
2009-03-10 13:19 EDT, Matěj Cepl
no flags Details
/etc/sysconfig/keyboard file (93 bytes, text/plain)
2009-03-13 17:13 EDT, Sandrine Soudant
no flags Details
lshal output (108.64 KB, text/plain)
2009-03-13 17:17 EDT, Sandrine Soudant
no flags Details

  None (edit)
Description Sandrine Soudant 2009-03-09 17:30:50 EDT
Description of problem:
At start, X server shows the window as seen in attachment.

Version-Release number of selected component (if applicable): X.Org 10503000


How reproducible: each new X session


Steps to Reproduce:
1. boot the PC
2. log in with X
3.
  
Actual results:


Expected results:


Additional info:
In attachment, the logs as required by the X server's message.
Comment 1 Sandrine Soudant 2009-03-09 17:33:04 EDT
Created attachment 334578 [details]
Screen shot and log as required by X Server's message
Comment 2 Matěj Cepl 2009-03-10 13:19:03 EDT
Created attachment 334684 [details]
screenshot of the error message

[dahuette@idefix ~]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "latin9", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "fr-latin9", "", ""
[dahuette@idefix ~]$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = []
 model = 
 options = []
[dahuette@idefix ~]$
Comment 3 Peter Hutterer 2009-03-12 19:07:46 EDT
please post your /etc/sysconfig/keyboard and the output of lshal.
Comment 4 Sandrine Soudant 2009-03-13 17:13:39 EDT
Created attachment 335163 [details]
/etc/sysconfig/keyboard file
Comment 5 Sandrine Soudant 2009-03-13 17:17:56 EDT
Created attachment 335165 [details]
lshal output
Comment 6 Peter Hutterer 2009-03-15 18:21:25 EDT
Reassigning to gdm, the server does the right thing here.

I just looked at the gdm-system-keyboard.patch, shouldn't that pull out LAYOUT, MODEL, etc (if available) instead of KEYTABLE?
Comment 7 Peter Hutterer 2009-03-15 20:10:58 EDT

*** This bug has been marked as a duplicate of bug 483195 ***

Note You need to log in before you can comment on or make changes to this bug.