Bug 483195 - Error activating XKB configuration.
Error activating XKB configuration.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
: 489054 489408 491439 491759 492483 496784 (view as bug list)
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-01-30 01:45 EST by mail
Modified: 2009-05-11 03:01 EDT (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-02 01:44:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf as requested (421 bytes, text/plain)
2009-02-07 10:11 EST, mail
no flags Details
Xorg log as requested (11.58 KB, text/plain)
2009-02-07 10:12 EST, mail
no flags Details
Xorg.0.log (62.84 KB, text/plain)
2009-03-13 11:02 EDT, Vinagre
no flags Details

  None (edit)
Description mail 2009-01-30 01:45:50 EST
Description of problem:

After startup I get:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
10503000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

The requestet reports are:

[fidepus@FUCKUP ~]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "pc105", "de", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "pc105", "de", "", ""
[fidepus@FUCKUP ~]$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [de-latin1-nodeadkeys]
 model = 
 options = []


Version-Release number of selected component (if applicable):


How reproducible:

happens allways

Steps to Reproduce:
1. start up the machinge
2. autologin
3. error
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2009-02-07 09:07:01 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 mail 2009-02-07 10:11:52 EST
Created attachment 331198 [details]
xorg.conf as requested
Comment 3 mail 2009-02-07 10:12:43 EST
Created attachment 331199 [details]
Xorg log as requested
Comment 4 Matěj Cepl 2009-02-08 09:29:38 EST
Are you able to reproduce this using only open source software? I see that you are using nVidia's binary-only driver. I understand that this bug is not primarily about graphic drivers, but unfortunately it is quite possible that some other part of whole Xorg suite of software got changed by installation of nvidia. Please refer to https://fedoraproject.org/wiki/Xorg/3rd_Party_Video_Drivers and clean your system to the original Fedora state, which we can support.

Then, please regenerate and re-attach X server log file (/var/log/Xorg.*.log; don't use any /etc/X11/xorg.conf for this testing) to the bug report.

Thanks in advance.
Comment 5 Peter Hutterer 2009-02-08 21:07:09 EST
(In reply to comment #0)
> [fidepus@FUCKUP ~]$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
>  layouts = [de-latin1-nodeadkeys]
>  model = 
>  options = []

What keyboard layout do you want to activate here? I can't find any such layout, neither in the gnome config, nor in xkeyboard-config.
Comment 6 Eric Tanguy 2009-02-26 13:49:46 EST
Same problem here : 

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "latin9", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "fr-latin9", "", ""


$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us	latin9,fr]
 model = pc105
 options = [grp	grp:shift_caps_toggle]

this problem is since recent updates and if i remember well there a xorg one.
Comment 7 galerien 2009-02-28 04:42:58 EST
same problem after update :

$ xprop -root |grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "latin9", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "fr-latin9", "", ""

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = []
 model = 
 options = []
Comment 8 Peter Hutterer 2009-03-01 19:16:57 EST
this seems to be a gnome problem. there's no us-latin9 keyboard, somehow the gconf keys seem to get mixed up.

does this happen with a test user?
Comment 9 Julian Sikorski 2009-03-12 18:33:59 EDT
This also happens with freshly installed rawhide:
[julas@rawhide ~]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "pl", "", ""
[julas@rawhide ~]$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [pl_PL.UTF-8]
 options = []
 model =
Comment 10 Vinagre 2009-03-13 11:00:15 EDT
Same here, on a fresh rawhide installation, I don't have any xorg.conf


Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
10600000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

----------------------------------------------------
$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "pt", "", ""
---------------------------------------------------------
$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [en_US.UTF-8]
 options = []
 model =
Comment 11 Vinagre 2009-03-13 11:02:24 EDT
Created attachment 335099 [details]
Xorg.0.log
Comment 12 Peter Hutterer 2009-03-15 20:10:58 EDT
*** Bug 489408 has been marked as a duplicate of this bug. ***
Comment 13 Eric Paris 2009-03-20 14:57:56 EDT
*** Bug 489054 has been marked as a duplicate of this bug. ***
Comment 14 Ray Strode [halfline] 2009-03-20 16:17:36 EDT
Should be fixed with the latest gdm (2.26.0-6.fc11) for *new* users.  Existing users will still be hosed.

The way to clean it up is sort of gross:

su -c "gconftool-2 --config-source=xml:readwrite:/var/lib/gdm/.gconf --unset /apps/gdm/simple-greeter/recent-layouts --direct"
rm -f ~/.dmrc
gconftool-2 --recursive-unset /desktop/gnome/peripherals/keyboard/kbd

Need to figure out if there's a way I can do that automatically.
Comment 15 Andreas Thienemann 2009-04-01 15:30:35 EDT
*** Bug 491439 has been marked as a duplicate of this bug. ***
Comment 16 Andreas Thienemann 2009-04-01 15:39:08 EDT
*** Bug 491759 has been marked as a duplicate of this bug. ***
Comment 17 Andreas Thienemann 2009-04-01 15:47:18 EDT
(In reply to comment #14)

> Should be fixed with the latest gdm (2.26.0-6.fc11) for *new* users.  Existing
> users will still be hosed.

Nope. I cannot confirm that it's working for *new* users.
gdm-2.26.0-7.fc11.i586 on a fresh rawhide scratch installation.

Same message appears on first login.

[andreas@workstation ~]$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "nodeadkeys", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "de", "", ""
[andreas@workstation ~]$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
layouts = []
options = []
model = 
[andreas@workstation ~]$ 

> The way to clean it up is sort of gross:
> 
> su -c "gconftool-2 --config-source=xml:readwrite:/var/lib/gdm/.gconf --unset
> /apps/gdm/simple-greeter/recent-layouts --direct"
> rm -f ~/.dmrc
> gconftool-2 --recursive-unset /desktop/gnome/peripherals/keyboard/kbd

Doesn't fix the problem. The message appears nevertheless as soon as control
is passed from gdm to the normal user session.
Comment 18 Andreas Thienemann 2009-04-08 12:11:52 EDT
Still not fixed with rawhide as of 20090408, neither with deleting the kbd configuration for existing users nor for new users.
Comment 19 Peter Hutterer 2009-04-09 01:01:50 EDT
*** Bug 492483 has been marked as a duplicate of this bug. ***
Comment 20 Joachim Backes 2009-04-10 04:33:11 EDT
Having additionally the problem that the nodeadkeys switch does not operate correctly: the handling of "|@[]" on a german nodeadkeys keyboard  is correct, but I have to type the tilde character "~" twice and not once.
Comment 21 Andreas Thienemann 2009-04-10 05:13:38 EDT
(In reply to comment #20)
> Having additionally the problem that the nodeadkeys switch does not operate
> correctly: the handling of "|@[]" on a german nodeadkeys keyboard  is correct,
> but I have to type the tilde character "~" twice and not once.  

Confirmed. Same here.
|@[] are not deadkeys, ~´`^ are.
Comment 22 Joachim Backes 2009-04-10 05:49:53 EDT
You are right ;-)

Weird: My keyboard model is "Generic 101-key PC" with USA layout (installed by anaconda as a "german/nodeadkeys" keyboard) , but it functions as it would be a german keyboard (umlauts äöü or s sharp ß are right). But if I switch by System->preferences->keyboard to "Germany Eliminate dead keys" by using the +ADD button in the "Keyboard Preferences" window instead of USA, then AltGr does no more function: getting only + sign instead of ~, or getting no ^ char.
Comment 23 Joachim Backes 2009-04-13 07:00:07 EDT
Got rid from all described problems after updating my system on monday, april 13.

Now my keyboard controls:

Keyboard model: Generic 101-Keys PC
Layout: Only "Germany Eliminate dead keys" added and selected. (No more USA layout needed).

The AltGr, tilde (~) and the ^ key now work correctly.
Comment 24 Andreas Thienemann 2009-04-13 09:02:59 EDT
(In reply to comment #23)

> Got rid from all described problems after updating my system on monday, april
> 13.
> 
> Now my keyboard controls:
> 
> Keyboard model: Generic 101-Keys PC
> Layout: Only "Germany Eliminate dead keys" added and selected. (No more USA
> layout needed).
> 
> The AltGr, tilde (~) and the ^ key now work correctly.  

Did you set this manually in the configuration tool or was it autodetected?

If you set it manually, it works but can be considered a workaroung. It should be set automatically.
Comment 25 Joachim Backes 2009-04-13 10:10:03 EDT
No, I set it manually (I didn't try a Fc11 re-install).
Comment 26 Matthieu Araman 2009-04-13 19:52:00 EDT
with rawhide updated for today, after applying above command to reset config, still have the same error message.
Comment 27 Robert Nichols 2009-04-13 22:08:53 EDT
To fix the problem for an existing user I had to delete directory
  ~/.gconf/desktop/gnome/peripherals/keyboard .
Comment 28 Andreas Thienemann 2009-04-18 09:19:54 EDT
Problem is still happening on a new rawhide installation, setting F11Blocker
Comment 29 Joachim Frieben 2009-04-26 08:04:42 EDT
After a fresh install from current "rawhide", I do obtain multiple instances of the "Error activating XKB configuration." error window. During install, I had chosen a keyboard layout "German w/o dead keys" for a German PS/2 keyboard attached to an IBM ThinkPad T23. Furthermore, I get:

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "nodeadkeys", "terminate:ctrl_alt_bksp"
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "de", "", ""

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = []
 options = []
 model =
Comment 30 Matthias Clasen 2009-04-28 01:03:12 EDT
Did you select a layout on the login screen ? 
What does

echo $GDM_KEYBOARD_LAYOUT 

show in this situation ?

And what about

lshal | grep xkb ?
Comment 31 Need Real Name 2009-04-28 02:20:37 EDT
de_AT.UTF-8

  input.xkb.layout = 'us'  (string)
  input.xkb.model = 'evdev'  (string)
  input.xkb.rules = 'base'  (string)
  input.xkb.variant = ''  (string)
  input.xkb.layout = 'us'  (string)
  input.xkb.model = 'evdev'  (string)
  input.xkb.rules = 'base'  (string)
  input.xkb.variant = ''  (string)
  input.xkb.layout = 'de'  (string)
  input.xkb.model = 'pc105'  (string)
  input.xkb.options = 'terminate:ctrl_alt_bksp'  (string)
  input.xkb.rules = 'base'  (string)
  input.xkb.variant = 'nodeadkeys'  (string)
Comment 32 Joachim Frieben 2009-04-28 06:58:44 EDT
The issue stops by adding a German keyboard layout by means gnome-keyboard-properties, setting it to be the default one and removing the US layout which was the only one displayed in "Selected Layouts" although the system layout was "German w/o dead keys".
Comment 33 Need Real Name 2009-04-28 12:11:36 EDT
But we can't keep asking people to fix their keyboard layouts. This is what? The third time this has happened? It should just work.
Comment 34 Matthias Clasen 2009-04-28 12:37:50 EDT
To make sure that it just works, you need to help identify what is different in your setup that makes this happen to you, since it does not happen here.
Comment 35 Need Real Name 2009-04-28 13:31:38 EDT
Of course. But as soon as I implement the workaround of reconfiguring my keyboard, you lose that information. So what do you need to know?
Comment 36 Andreas Thienemann 2009-04-28 16:12:17 EDT
Setting the severity to high.

There have been several reports of this triggering F11 preview release users on IRC.
Comment 37 Matthias Clasen 2009-04-29 23:27:51 EDT
Can you try if http://koji.fedoraproject.org/koji/buildinfo?buildID=100317 
makes any difference ?
Comment 38 Joachim Frieben 2009-04-30 01:07:22 EDT
After updating to gnome-settings-daemon-2.26.1-4.fc11, the issue does not appear for a new user anymore.
Comment 39 Steven Moix 2009-05-01 14:09:17 EDT
I can confirm that, after updating to gnome-settings-daemon-2.26.1-4.fc11, the issue does not appear for a new user anymore (nor does it for old users). I'm using an fr_CH keyboard layout.
Comment 40 Matthias Clasen 2009-05-02 01:44:14 EDT
Ok, I'll take this as sufficient proof that things are fixed.
Comment 41 Peter Hutterer 2009-05-10 20:19:08 EDT
*** Bug 496784 has been marked as a duplicate of this bug. ***
Comment 42 Matthieu Araman 2009-05-11 03:01:48 EDT
I can also confirm that this fixed it on french install + keyboard both for new users and for existing users.

Note You need to log in before you can comment on or make changes to this bug.