Bug 489451 - cpg fails to sync properly if nodeid > 0xffffff
cpg fails to sync properly if nodeid > 0xffffff
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.3
All Linux
low Severity high
: rc
: ---
Assigned To: Steven Dake
Cluster QE
:
: 492948 (view as bug list)
Depends On:
Blocks: 489454
  Show dependency treegraph
 
Reported: 2009-03-10 03:32 EDT by Steven Dake
Modified: 2016-04-26 12:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: openais-0.80.5-4.el5_4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 489454 (view as bug list)
Environment:
Last Closed: 2009-09-02 07:30:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Dake 2009-03-10 03:32:29 EDT
Description of problem:
if the node id is greater then 0xFFFFFF (6 F's) cpg syncronization doesn't start.  This would effect people using cpg with autogenerated node ids.

Version-Release number of selected component (if applicable):
openais-0.80.3-22.el5_3.3

How reproducible:
100%

Steps to Reproduce:
1. start 3 node cluster
2. start testcpg on all nodes
3. killall -9 lowest node id
  
Actual results:
no configuration change is generated

Expected results:
configuration change is generated

Additional info:
Comment 1 Alan Conway 2009-03-31 17:34:38 EDT
*** Bug 492948 has been marked as a duplicate of this bug. ***
Comment 4 errata-xmlrpc 2009-09-02 07:30:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1366.html

Note You need to log in before you can comment on or make changes to this bug.