Bug 492948 - Ghost cluster member after restarting openais.
Ghost cluster member after restarting openais.
Status: CLOSED DUPLICATE of bug 489451
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: Alan Conway
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 17:01 EDT by Alan Conway
Modified: 2009-10-06 12:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 17:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2009-03-30 17:01:47 EDT
Description of problem:

From Nick.Hall@gs.com

Ran into one issue on my first test - steps to reproduce:
 
1)      start 4 node OpenAIS cluster
2)      start qpidd on all 4 nodes
3)      qpid-cluster shows 4 nodes
4)      pick one node and fail it by running service openais stop
5)      qpid-cluster still shows 4 nodes
6)      restart OpenAIS and qpidd on failed node
7)      qpid-cluster now shows 5 nodes with one repeated:
 
[root@lnaiqlv24 ~]# qpid-cluster
  Cluster Name: TESTCLUSTER
Cluster Status: ACTIVE
  Cluster Size: 5
       Members: ID=10.229.20.196:3936 URL=amqp:tcp:10.229.20.196:5672
              : ID=10.229.20.198:3661 URL=amqp:tcp:10.229.20.198:5672
              : ID=10.229.20.199:4649 URL=amqp:tcp:10.229.20.199:5672
              : ID=10.229.20.203:4104 URL=amqp:tcp:10.229.20.203:5672
              : ID=10.229.20.203:4256 URL=amqp:tcp:10.229.20.203:5672
 
OpenAIS log correctly shows 4 nodes:
 
Mar 30 16:31:21.912122 [CLM  ] CLM CONFIGURATION CHANGE
Mar 30 16:31:21.912135 [CLM  ] New Configuration:
Mar 30 16:31:21.912145 [CLM  ]  r(0) ip(10.229.20.196)
Mar 30 16:31:21.912153 [CLM  ]  r(0) ip(10.229.20.198)
Mar 30 16:31:21.912160 [CLM  ]  r(0) ip(10.229.20.199)
Mar 30 16:31:21.912166 [CLM  ] Members Left:
Mar 30 16:31:21.912172 [CLM  ] Members Joined:
Mar 30 16:31:21.912188 [CLM  ] CLM CONFIGURATION CHANGE
Mar 30 16:31:21.912194 [CLM  ] New Configuration:
Mar 30 16:31:21.912202 [CLM  ]  r(0) ip(10.229.20.196)
Mar 30 16:31:21.912209 [CLM  ]  r(0) ip(10.229.20.198)
Mar 30 16:31:21.912217 [CLM  ]  r(0) ip(10.229.20.199)
Mar 30 16:31:21.912224 [CLM  ]  r(0) ip(10.229.20.203)
Mar 30 16:31:21.912230 [CLM  ] Members Left:
Mar 30 16:31:21.912237 [CLM  ] Members Joined:
Mar 30 16:31:21.912244 [CLM  ]  r(0) ip(10.229.20.203)
Mar 30 16:31:21.912253 [SYNC ] This node is within the primary component and will provide service.
Mar 30 16:31:21.912276 [TOTEM] entering OPERATIONAL state.
Mar 30 16:31:21.913668 [CLM  ] got nodejoin message 10.229.20.196
Mar 30 16:31:21.913775 [CLM  ] got nodejoin message 10.229.20.198
Mar 30 16:31:21.913838 [CLM  ] got nodejoin message 10.229.20.199
Mar 30 16:31:21.914079 [CLM  ] got nodejoin message 10.229.20.203
Mar 30 16:31:21.921216 [CPG  ] got joinlist message from node -954931958
Mar 30 16:31:21.921526 [CPG  ] got joinlist message from node -1005263606
Mar 30 16:31:21.921628 [CPG  ] got joinlist message from node -971709174
Comment 1 Alan Conway 2009-03-31 17:34:37 EDT
Caused by 489451, which is fixed in openais-0.80.3-22.el5_3.4.
I confirmed that qpidd behaves as expected with the updated openais.

*** This bug has been marked as a duplicate of bug 489451 ***

Note You need to log in before you can comment on or make changes to this bug.