Bug 489481 - Useless "domain didn't show up" error when starting a guest with too much RAM
Useless "domain didn't show up" error when starting a guest with too much RAM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-03-10 07:47 EDT by Dominick Grift
Modified: 2009-07-31 06:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-31 06:36:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dominick Grift 2009-03-10 07:47:28 EDT
Description of problem:

Unable to complete install '<class 'libvirt.libvirtError'> internal error Domain mybooksdb2 didn't show up

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 717, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 536, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 628, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 973, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Domain mybooksdb2 didn't show up
'

Version-Release number of selected component (if applicable):
libvirt-0.6.1-2.fc11.x86_64

How reproducible:
Install a guest using virt-manager
Comment 1 Daniel Berrange 2009-03-10 07:51:46 EDT
Can you check if anything is present in /var/log/libvirt/qemu/mybooksdb2.log and attach to this BZ if found. Also, check is 'ps -auxwf' shows any QEMU process running ?
Comment 2 Dominick Grift 2009-03-10 08:17:15 EDT
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/bin/qemu-system-x86_64 -S -M pc -no-kqemu -m 4096 -smp 2 -name mybooksdb2 -uuid ad1a2204-4bf4-146d-c69a-0372db76ccc3 -monitor pty -
pidfile /var/run/libvirt/qemu//mybooksdb2.pid -no-reboot -boot d -drive file=/dev/sdb2,if=ide,index=0 -drive file=/dev/sr0,if=ide,media=cdrom,index=2 -net nic,macaddr=54:52:00:64:d
9:d2,vlan=0 -net tap,fd=18,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0 -k en-us -soundhw es1370 
qemu: at most 2047 MB RAM can be simulated

qemu           	0:off	1:off	2:on	3:on	4:on	5:on	6:off

sh-4.0# ps auxwf | grep -i qemu
root      4160  0.0  0.0  87740   804 pts/0    S+   13:16   0:00              \_ grep -i qemu

I will retry with less memory. since it complained about 2047 being max.
Comment 3 Dominick Grift 2009-03-10 08:18:51 EDT
sh-4.0# service qemu status
qemu binary format handlers are not registered.
Comment 4 Dominick Grift 2009-03-10 08:22:11 EDT
ok works now, sorry for false alarm

started qemu (seems it didnt start on boot unlike chkconfig says)
also used less memory (2047)
put selinux into permissive mode.
Comment 5 Dominick Grift 2009-03-10 08:32:26 EDT
After this it hangs here:

...trying to set up timer (IRQ0) through 8259A ...
..... (found apic 0 pin 2) ...
....... failed.
...trying to set up timer as Virtual Wire IRQ...
Comment 6 Daniel Berrange 2009-03-10 08:38:38 EDT
RE comment #5, you are hitting this QEMU bug:

https://bugzilla.redhat.com/show_bug.cgi?id=488759

See the attachment on that bug, showing exactly same log as you have


I'm going to leave this bug open for a while, until I figure out whether we can get better error reporting for the initial problem you reported (too much RAM)
Comment 7 Mark McLoughlin 2009-03-25 13:39:50 EDT
Okay, so the goal here is to see if we can replace:

  libvirtError: internal error Domain mybooksdb2 didn't show up

with e.g.

  libvirtError: qemu: at most 2047 MB RAM can be simulated
Comment 8 Bug Zapper 2009-06-09 08:04:47 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Ricky Burgin 2009-07-03 21:50:32 EDT
I'd like to confirm that when I received this error, I did not have QEMU installed and running and I had SELinux completely enabled on its default settings post-FC11 install.

By installing and starting QEMU and changing SELinux to permissive, the error went away and the virtual machine kicked in. Though, it may have just been one or the other, not both QEMU and SELinux.

I did not try using over 2047MB of RAM.
Comment 10 Mark McLoughlin 2009-07-31 06:36:48 EDT
Fixed upstream in 0.6.4 by:

  http://libvirt.org/git/?p=libvirt.git;a=commit;h=27d72bd517

which depends on a fairly large previous patch. Since this only makes diagnosing errors easy, I'm not going to backport to F11 and mark it as fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.