Bug 489511 - anaconda crashed when trying to edit VolGroup00
anaconda crashed when trying to edit VolGroup00
Status: CLOSED DUPLICATE of bug 489022
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-10 10:52 EDT by Jeff Bastian
Modified: 2009-03-10 11:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-10 11:19:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
tar of anaconda logs (40.65 KB, application/octet-stream)
2009-03-10 10:56 EDT, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2009-03-10 10:52:58 EDT
Description of problem:
I was trying to install today's (2009-03-10) rawhide and anaconda crashed when I selected VolGroup00 and clicked Edit.

09:39:58 CRITICAL: anaconda exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 1507, in _addPV
    raise ValueError("pv is already part of this vg")
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 343, in createAllowedLvmPa
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 997, in __init__
    (self.lvmlist, sw) = self.createAllowedLvmPartitionsList(self.availlvmparts,
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1129, in editLVMVolumeGroup
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1054, in editCB
ValueError: pv is already part of this vg

Version-Release number of selected component (if applicable):

How reproducible:
every time

Steps to Reproduce:
1. boot from 2009-03-10 rawhide boot.iso
2. enter LUKS passphrase to open /dev/sda2  (Linux LVM)
3. choose custom disk layout
4. select VolGroup00 and click Edit
Actual results:

Expected results:
no crash

Additional info:
I'm trying to install rawhide parallel with Fedora 10 on spare space in VolGroup00.
Comment 1 Jeff Bastian 2009-03-10 10:55:34 EDT
BTW, I tried to use the automatic upload to BZ from anaconda, but after I entered my BZ name and password and a description and hit OK, it didn't do anything.  The network was up since I was installing from http.
Comment 2 Jeff Bastian 2009-03-10 10:56:45 EDT
Created attachment 334666 [details]
tar of anaconda logs
Comment 3 David Lehman 2009-03-10 11:19:53 EDT
FWIW, if you've had a traceback you can just grab /tmp/anacdump.txt and attach it next time. Also, you can generate an anacdump.txt at any time by sending SIGUSR2 to anaconda.

*** This bug has been marked as a duplicate of bug 489022 ***

Note You need to log in before you can comment on or make changes to this bug.