Bug 489613 - Traceback from OSError, unable to unpack value
Traceback from OSError, unable to unpack value
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 489406 (view as bug list)
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-10 18:15 EDT by Jesse Keating
Modified: 2013-01-09 22:27 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 13:58:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2009-03-10 18:15:23 EDT
anaconda 11.5.0.26 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/rhpl/executil.py", line 93, in execWithRedirect
    except OSError, (errno, msg):
  File "/usr/lib/python2.6/site-packages/rhpl/keyboard.py", line 129, in activate
    executil.execWithRedirect(argv[0], argv)
  File "/usr/lib/anaconda/textw/keyboard_text.py", line 59, in __call__
    anaconda.id.keyboard.activate()
  File "/usr/lib/anaconda/text.py", line 674, in run
    rc = win(self.screen, instance)
  File "/usr/bin/anaconda", line 1012, in <module>
    anaconda.intf.run(anaconda)
ValueError: need more than 0 values to unpack

Local variables in innermost frame:
status: -1
searchPath: 0
stdout: 1
stdin: 0
argv: ['/usr/bin/loadkeys', 'us']
ignoreTermSigs: 0
command: /usr/bin/loadkeys
stderr: 2
newPgrp: 0
root: /
childpid: 1840
Comment 1 Chris Lumens 2009-03-12 11:56:00 EDT
*** Bug 489406 has been marked as a duplicate of this bug. ***
Comment 2 Jesse Keating 2009-03-12 13:55:56 EDT
Updated the topic.  OSError does indeed raise a tuple that is errorno and the message, so I'm not entirely sure what's going on here.
Comment 3 Chris Lumens 2009-03-16 11:46:10 EDT
There has to be some external factor here, as I am unable to reproduce this locally.  If you can reliably hit it, can you attach the various log files?  Also, is there anything special you are doing or is this just a straight text mode install?
Comment 4 Jesse Keating 2009-03-16 13:58:30 EDT
This may have been due to the squashfs issues we were having.  I'm going to close this unless we can reproduce again somewhere else.

Note You need to log in before you can comment on or make changes to this bug.