Bug 489617 - csh/tcsh : Unknown colorls variable `rs'.
csh/tcsh : Unknown colorls variable `rs'.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tcsh (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 18:53 EDT by Thomas Evangelidis
Modified: 2009-04-06 16:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: 6.15-7.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 16:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gentoo 234700 None None None Never

  None (edit)
Description Thomas Evangelidis 2009-03-10 18:53:05 EDT
Description of problem:
when switching to csh/tcsh the error message is displayed.

Version-Release number of selected component (if applicable):


How reproducible:
Always (as far as I am concerned).repositories

Steps to Reproduce:
1. download and install tcsh from FC 10 
2. type csh or tcsh
3.
  
Actual results:
Unknown colorls variable `rs'.

Expected results:
to switch to csh or tcsh

Additional info:
Comment 1 Rahul Sundaram 2009-03-10 19:01:59 EDT
Reassigning incorrectly assigned bug
Comment 2 Vitezslav Crhonek 2009-03-11 06:50:16 EDT
Hi,

This issue is already fixed in Rawhide (https://bugzilla.redhat.com/show_bug.cgi?id=487783).

It should not occur in F-10 and I'm also not able to reproduce it. New colorls variables (rs and hl) are not included in F-10 coreutils (latest version is coreutils-6.12-20.fc10).

Which coreutils do you use?
Comment 3 Thomas Evangelidis 2009-03-11 12:14:12 EDT
I am using coreutils-6.12-19.fc10. tcsh was working just fine a few days ago so I suspect there must be something wrong with the packages I installed in the interval.I noticed that I had also SELinux coreutils installed and tried to erase them from the package manager. The process took quite long and when it was about to finish the screen started blinking and the keyboard became irresponsive. I rebooted but couldn't restart, the process stucks when the progressbar becomes white!
Comment 4 Fedora Update System 2009-03-13 05:50:14 EDT
tcsh-6.15-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/tcsh-6.15-7.fc10
Comment 5 Vitezslav Crhonek 2009-03-13 05:51:17 EDT
Well, OK, I'll add these two colorls variables in F-10 too. It should help you
and nothing will break even if coreutils doesn't include them.
Comment 6 Fedora Update System 2009-03-13 14:42:55 EDT
tcsh-6.15-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tcsh'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2685
Comment 7 Thomas Evangelidis 2009-03-17 08:24:05 EDT
Problem has been resolved, thank you!
Comment 8 Fedora Update System 2009-04-06 16:33:51 EDT
tcsh-6.15-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.