Bug 489649 - I can not turn on my machine with keyboard after hibernate
I can not turn on my machine with keyboard after hibernate
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On: 234762
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-11 02:11 EDT by A S Alam
Modified: 2013-07-02 20:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 234762
Environment:
Last Closed: 2009-03-11 06:08:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2009-03-11 02:11:34 EDT
+++ This bug was initially created as a clone of Bug #234762 +++

Description of problem:
After hibernating the machine can not be turned on with keyboard, only with the
power button. (when i do a poweroff it works fine)

Version-Release number of selected component (if applicable):

kernel-2.6.20-1.3036.fc7.src.rpm

How reproducible:
always

Steps to Reproduce:
1.hibernate
2.try to power on with keyboard
3.
  
Actual results:
nothing

Expected results:
power on

Additional info:

proc: AMD Athlon(tm) 64 Processor 3000+
motherboard: Asus A8N-E

/sbin/lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio
Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV380 [Radeon X600 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV380 [Radeon X600]
05:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)

--- Additional comment from davej@redhat.com on 2007-04-23 13:04:08 EDT ---

hibernate will power the machine off completely, unlike 'suspend'.
Even then, it will only wake up if you configure it to do so in your bios.
/proc/acpi/wakeup will show all the possible events it will respond to whilst in
suspend to ram.

Suspend to disk however is not possible to wakeup from without the power button,
or wake on lan.


--- Additional comment from bognarg@gmail.com on 2007-04-24 03:26:10 EDT ---

(In reply to comment #1)
> hibernate will power the machine off completely, unlike 'suspend'.
yes i know, but i did not mentioned suspend. I said after poweroff (which powers
off the machine completly) i can turn on the machine with keyboard.

> Suspend to disk however is not possible to wakeup from without the power button,
> or wake on lan.
Bios settings: power on on keyboard, after poweroff it works fine after
hibernate it is not.




--- Additional comment from davej@redhat.com on 2007-04-24 11:31:42 EDT ---

huh, I've never seen any machine do that.  I have no idea.
At a guess it's some ACPI defect, but I can't imagine what it could be.
Mailing the acpi developers upstream (acpi-devel@vger.kernel.org) is probably
your best bet.

--- Additional comment from richard@hughsie.com on 2007-05-24 07:46:44 EDT ---

(In reply to comment #3)
> huh, I've never seen any machine do that.  I have no idea.

Me neither. Oddball hardware IMO.

Richard.


--- Additional comment from opensource@till.name on 2008-01-13 11:19:01 EDT ---

I just wanted to file a similiar bug, I have a Pentium III that suspends and
hibernates hapily, but does not wake up from hibernate (and suspend). When I
hibernate with "shutdown" instead of "platform", it will wake up from hibernate
when it get's its wol packet.

cat /proc/acpi/wakeup shows disabled for everything. Is there a way to enable it? 

--- Additional comment from fedora-triage-list@redhat.com on 2008-05-13 22:43:11 EDT ---

Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 1 A S Alam 2009-03-11 02:16:09 EDT
I have same problem.
CPU: model name	: AMD Phenom(tm) 9650 Quad-Core Processor
Main Board: M3A78-EM
---------
 /sbin/lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Link Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV630 [Radeon HD 2600 Series]
01:00.1 Audio device: ATI Technologies Inc RV630/M76 audio device [Radeon HD 2600 Series]
02:00.0 FireWire (IEEE 1394): JMicron Technologies, Inc. IEEE 1394 Host Controller
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
---------
Comment 2 Richard Hughes 2009-03-11 06:08:39 EDT
If it's hibernated, the machine is off. Unless you've got a machine that can startup just by pressing the keyboard key when off (unlikely), this isn't going to work.
Comment 3 Till Maas 2009-03-11 07:02:09 EDT
(In reply to comment #2)
> If it's hibernated, the machine is off. Unless you've got a machine that can
> startup just by pressing the keyboard key when off (unlikely), this isn't going
> to work.  

Afaik all my mainboards since around 1999 support to power on using the keyboard. It is not that uncommon to support this for ATX mainboards.

Btw. you can try to set HIBERNATE_MODE to shutdown in /usr/lib64/pm-utils/defaults, maybe it works then.
Comment 4 A S Alam 2009-03-11 20:41:02 EDT
(In reply to comment #2)
> If it's hibernated, the machine is off. Unless you've got a machine that can
> startup just by pressing the keyboard key when off (unlikely), this isn't going
> to work.  

oh, sorry, my mistake to misunderstand issue as my keyboard was not working, when machine resumed (after hibernate) (not able to enter password in screen-lock). Need to un-plug and then plug again keyboard.

Can u please help me to decide Should I need to file new bug for it or bug #479504 are same?

Note You need to log in before you can comment on or make changes to this bug.