Bug 489915 - AttributeError: 'NoDevice' object has no attribute 'teardownFormat'
AttributeError: 'NoDevice' object has no attribute 'teardownFormat'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 490044 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 10:58 EDT by Sebastian Vahl
Modified: 2009-03-12 22:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-12 11:50:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full traceback (71.43 KB, text/plain)
2009-03-12 10:58 EDT, Sebastian Vahl
no flags Details

  None (edit)
Description Sebastian Vahl 2009-03-12 10:58:28 EDT
Created attachment 334941 [details]
full traceback

Description of problem:
An installation from a live image stops right after formating the partition with this traceback:

anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 1466, in 
umountFilesystems
    device.teardownFormat()
  File "/usr/lib/anaconda/livecd.py", line 162, in doPreInstall
    swapoff = False)
  File "/usr/lib/anaconda/backend.py", line 279, in doPreInstall
    anaconda.backend.doPreInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in 
renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1338, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoDevice' object has no attribute 'teardownFormat'

My setup was a single root partition with ext3.


Version-Release number of selected component (if applicable):
anaconda-11.5.0.28-1.i586

How reproducible:


Steps to Reproduce:
1. boot recent live image
2. try to install

  
Actual results:
traceback

Expected results:
installation starts

Additional info:
If that matters: I'm copying the content of the live images to a vfat partition and start this live image through a grub entry of my normal installation. The installation target is a partition on my second hdd. This procedure was working fine all the time.
Comment 1 Chris Lumens 2009-03-12 11:50:12 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 2 David Lehman 2009-03-12 22:35:46 EDT
*** Bug 490044 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.