Bug 490083 - Grub does not respond to timeout and hiddenmenu commands
Grub does not respond to timeout and hiddenmenu commands
Status: CLOSED DUPLICATE of bug 481379
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 01:27 EDT by Peter Gückel
Modified: 2009-03-13 05:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 05:42:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gückel 2009-03-13 01:27:03 EDT
Description of problem:
On a freshly installed x86_64 system (from DVD), anaconda or whatever sets up grub.conf with timeout=5 and hiddenmenu (I have not edited these lines and have only added other OS to the list, and yum has added a couple of kernels), the computer always displays the menu and it never times out. I have to type carriage return to initiate booting of the system.

Version-Release number of selected component (if applicable):
grub-0.97-42.fc11.x86_64

How reproducible:
Install a x86_64 system from DVD and reboot and notice symptoms.

Steps to Reproduce:
1. install
2. reboot
3. take action (type <cr>)
  
Actual results:
The hidden menu is never hidden and the system hangs, waiting for a user response that is not requested.

Expected results:
The menu shoud be hidden, unless a key is pressed before the time-out, and, should automatically boot the default option, namely 0.

Additional info:
Comment 1 Jurgen Kramer 2009-03-13 03:43:16 EDT
This problem also exists on i386. GRUB just sits there waiting for user action instead of counting down and automatically booting the system.
Comment 2 Mike Chambers 2009-03-13 05:42:02 EDT

*** This bug has been marked as a duplicate of bug 481379 ***

Note You need to log in before you can comment on or make changes to this bug.