Bug 481379 - Not respecting timeout and hiddenmenu setting
Not respecting timeout and hiddenmenu setting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 485572 490083 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-23 15:26 EST by Michael Monreal
Modified: 2009-05-18 08:50 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 11:00:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2009-01-23 15:26:42 EST
My /boot/grub/menu.lst has "timeout 5" and "hiddenmenu" set (it's the default). However, grub shows and does not timeout at all, meaning it does not start anything as long as I don't hit return.
Comment 1 Jeff Layton 2009-02-16 19:59:57 EST
I just updated my laptop to F11A and am seeing the same behavior. I've tried various things -- commenting out the splashimage, etc.
Comment 2 Jeff Layton 2009-02-16 20:08:35 EST
Ahh...

This is actually the same problem as bug 468526. The problem patch was backed out of the f10 branch, but not in f11 for some reason. Looks like there is a failed koji build that pulls out that patch, but no good ones yet.
Comment 3 lexual 2009-03-01 04:40:49 EST
*** Bug 485572 has been marked as a duplicate of this bug. ***
Comment 4 Mike Chambers 2009-03-01 07:25:25 EST
Any new status on this issue with the timer?
Comment 5 Mike Chambers 2009-03-13 05:42:02 EDT
*** Bug 490083 has been marked as a duplicate of this bug. ***
Comment 6 Mike Chambers 2009-03-13 22:20:04 EDT
I *think* this actually works now.  At least doing an upgrade from an updated F10 install to rawhide as of today and grub acted like in F10.  I will watch it more closely again after my next reboot.
Comment 7 Peter Gückel 2009-03-14 19:12:57 EDT
If this:

grub-0.97-43.fc11.x86_64

was the update that 'fixed' it...

it didn't.
Comment 8 Michael Monreal 2009-03-15 05:04:23 EDT
It certainly works for me now, on a brand new installation based on F11Alpha. Before (even on an up-to-date grub from RawHide, it didn't). My guess would be that pre-F11Alpha RawHide installations are not updated correctly somehow?
Comment 9 Peter Gückel 2009-03-15 12:24:33 EDT
Mine's not a pre-F11Alpha Rawhide installation. I freshly installed to a virgin partition on 6 days ago using the DVD.
Comment 10 Kyle 2009-03-17 13:48:21 EDT
I am also experiencing this.  I did a fresh F11Alpha install and have kept up to date with rawhide updates.
Comment 11 Mike Chambers 2009-03-17 18:37:30 EDT
Correction, it does NOT work for me now.  I think the only time this worked was when I did an F10 (updated) upgrade to Rawhide via yum.  I am now on F11 Alpha and updated to rawhide and it doesn't work.
Comment 12 Mike Chambers 2009-03-22 22:58:58 EDT
I found out that after doing the upgrade, if you reinstall grub to the mbr or wherever, that the countdown was fixed.  So it seems in the upgrade process it's not working, but if reinstall or if doing a clean install it probably will work again.
Comment 13 Kyle 2009-03-22 23:41:09 EDT
I can confirm that doing a 'grub-install' brought back the countdown.  However, the screen is only blue behind the letters.  All the rest of the background is black.  I thought the entire screen background was supposed to be blue.
Comment 14 Peter Gückel 2009-03-23 12:37:52 EDT
I was hopeful, so I reinstalled grub to the hard drive's MBR from the command line and rebooted.

Unfortunately, there is still no time-out and the menu is not hidden.
Comment 15 Steve 2009-04-01 03:48:43 EDT
It is fixed in Fedora 11 Beta. Please close Bug.
Comment 16 Peter Gückel 2009-04-01 13:04:20 EDT
In Fedora release 10.92 (Rawhide), which I presume is Beta (I have the latest upgrades installed, which arrived yesterday, including grub-0.97-44.fc11.x86_64), it still is NOT fixed.
Comment 17 Steve 2009-04-01 13:18:44 EDT
It is fixed when making a fresh install of the Fedora-11-Beta-DVD.
Comment 18 Peter Gückel 2009-04-02 13:32:07 EDT
So, which file do I need to edit, or which rpm do I need to install/reinstall to get it to work?
Comment 19 Jeremy Katz 2009-05-04 11:00:07 EDT
We don't re-run grub-install on a grub (package) upgrade to avoid some of the problems that can occur when running grub-install

So if you had the problem package installed, you'll need to rerun grub-install by hand (or do an anaconda upgrade, where we have a little more control and do such things)

Closing as rawhide

Note You need to log in before you can comment on or make changes to this bug.