Bug 490212 - can't handle quirky partitioning table
can't handle quirky partitioning table
Status: CLOSED DUPLICATE of bug 489122
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:05e7984cac22a661a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 16:33 EDT by Jarod Wilson
Modified: 2009-03-13 17:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 17:01:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (66.27 KB, text/plain)
2009-03-13 16:33 EDT, Jarod Wilson
no flags Details

  None (edit)
Description Jarod Wilson 2009-03-13 16:33:17 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.28 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 852, in __init__
    raise DeviceError("cannot find parted partition instance")
  File "/usr/lib/anaconda/storage/devices.py", line 197, in PartitionDeviceFactory
    return PartitionDevice(*args, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1010, in addUdevDevice
    parents=[disk])
  File "/usr/lib/anaconda/storage/devicetree.py", line 1272, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 221, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 64, in storageInitialize
    anaconda.id.storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
DeviceError: cannot find parted partition instance
Comment 1 Jarod Wilson 2009-03-13 16:33:22 EDT
Created attachment 335156 [details]
Attached traceback automatically from anaconda.
Comment 2 Jarod Wilson 2009-03-13 16:42:11 EDT
Anaconda said it didn't like my partition table, and asked if it could reinitialize it. I told it to go ahead with it, and it appears it did indeed clear the partition table (post-mortem inspection of the drive shows no partition table now), but then the backtrace.
Comment 3 Jarod Wilson 2009-03-13 16:45:07 EDT
fwiw, the partition table *was* a bit wonky, but not invalid... The drive originally had a 150G sda1, then an sda2 that started after it. The huge sda1 was deleted w/fdisk, and sda1 was recreated as a 200M partition (because grub was falling down trying to boot the 150G partition directly). So there was a big gap between sda1 and sda2 that anaconda apparently choked on.
Comment 4 Chris Lumens 2009-03-13 17:01:50 EDT
I've fixed this traceback, though the troubles handling a strange partitioning table is certainly still a problem.  I'm going to dupe this one to the bug that I fixed about the partitioning table.  Can you try again with the next build of anaconda and open a new bug if we still say your partition table is unreadable?  Thanks.

*** This bug has been marked as a duplicate of bug 489122 ***

Note You need to log in before you can comment on or make changes to this bug.