Bug 490265 - The version of SWIG shipped with RHEL 5 (5.3?) is one revision too old
The version of SWIG shipped with RHEL 5 (5.3?) is one revision too old
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: swig (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Adam Tkac
BaseOS QE
: FutureFeature, Rebase
: 558795 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-14 09:48 EDT by David Sugar
Modified: 2013-04-30 19:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 06:46:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Sugar 2009-03-14 09:48:54 EDT
Description of problem:

SWIG versions prior to 1.3.30 does not support correct expansion of $self.  Many modern (recently written) swig wrappers now use $self expansion to define object destructors, and these all of course fail to build with the version of swig distributed.  The version shipped is 1.3.29 which is several years old.  If it can be "bumped" even minimally to 1.3.30 (or better a more recent 1.3.x release) this would resolve this issue.
 
Version-Release number of selected component (if applicable):

1.3.29

How reproducible:

Build a swig with a $self reference.  You will get error: '$self' was not declared in this scope.  A typical note about this can be found here: http://www.mail-archive.com/m5-dev@m5sim.org/msg02184.html as there is much discussion also findable on google for this issue...
Comment 1 Adam Tkac 2010-01-27 04:28:55 EST
*** Bug 558795 has been marked as a duplicate of this bug. ***
Comment 4 Radek Vokal 2010-04-13 06:45:33 EDT
We don't plan to rebase swig in next releases of RHEL5. If you feel that this issue is critical for you, please contact redhat.com/support .
Comment 5 RHEL Product and Program Management 2010-04-13 06:46:36 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.