Bug 490293 - system-config-samba: AttributeError: 'SambaUserData' object has no attribute 'samba_passwd_file'
system-config-samba: AttributeError: 'SambaUserData' object has no attribute ...
Status: CLOSED DUPLICATE of bug 490050
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-14 17:41 EDT by Scott Tsai
Modified: 2009-03-16 09:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 09:47:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2009-03-14 17:41:07 EDT
Description of problem:
system-config-samba fails with a Python traceback:
AttributeError: 'SambaUserData' object has no attribute 'samba_passwd_file'

Version-Release number of selected component (if applicable):
system-config-samba-1.2.71-1.fc11.noarch

How reproducible:
Always

Steps to Reproduce:
1. yum -y install system-config-samba
2. system-config-samba

  
Actual results:
$ system-config-samba 
Traceback (most recent call last):
  File "/usr/bin/system-config-samba", line 49, in <module>
    mainWindow.MainWindow (debug_flag = debug_flag, use_dbus = use_dbus)
  File "/usr/share/system-config-samba/mainWindow.py", line 141, in __init__
    self.samba_user_win = sambaUserWin.SambaUserWin(self, self.xml, self.samba_user_data, self.main_window)
  File "/usr/share/system-config-samba/sambaUserWin.py", line 83, in __init__
    self.fillUserList()
  File "/usr/share/system-config-samba/sambaUserWin.py", line 90, in fillUserList
    list = self.samba_user_data.getPasswdFile()
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/proxy/sambaBackend.py", line 61, in getPasswdFile
    return self.dbus_object.getPasswdFile (dbus_interface = "org.fedoraproject.Config.Samba.UserData")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/site-packages/slip/dbus/service.py", line 81, in wrapped_method
    retval = method (self, *p, **k)
  File "/usr/lib/python2.6/site-packages/scsamba/dbus/service/sambaBackend.py", line 68, in getPasswdFile
    return self.userdata.getPasswdFile ()
  File "/usr/lib/python2.6/site-packages/scsamba/core/sambaBackend.py", line 158, in getPasswdFile
    return self.samba_passwd_file
AttributeError: 'SambaUserData' object has no attribute 'samba_passwd_file'


Expected results:
A pretty GUI.

Additional info:
Comment 1 Nils Philippsen 2009-03-16 09:47:44 EDT

*** This bug has been marked as a duplicate of bug 490050 ***

Note You need to log in before you can comment on or make changes to this bug.