Bug 490309 - X11 server corrupts TTY
X11 server corrupts TTY
Status: CLOSED DUPLICATE of bug 501525
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-15 00:49 EDT by Russell Miller
Modified: 2009-09-06 04:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-09-06 04:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
system info (104.13 KB, text/plain)
2009-03-15 00:50 EDT, Russell Miller
no flags Details
xorg.conf (2.36 KB, text/plain)
2009-05-31 19:31 EDT, Russell Miller
no flags Details
xorg.0.log (47.67 KB, text/plain)
2009-06-01 09:23 EDT, Russell Miller
no flags Details

  None (edit)
Description Russell Miller 2009-03-15 00:49:36 EDT
Description of problem:

When I start the X server, the TTY is corrupted.  The backlight flashes irregularly, the images seems compressed to the first few lines and moves around very quickly.  The console still can startx again, so it's just the video that's corrupted.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. start x
2. exit x
Actual results:


Expected results:

No corruption

Additional info:

See attachment.
Comment 1 Russell Miller 2009-03-15 00:50:34 EDT
Created attachment 335242 [details]
system info
Comment 2 Matěj Cepl 2009-03-31 10:27:18 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Russell Miller 2009-05-31 19:31:07 EDT
Created attachment 346035 [details]
Comment 4 Matěj Cepl 2009-06-01 09:17:02 EDT
... and other logs?
Comment 5 Russell Miller 2009-06-01 09:23:44 EDT
Created attachment 346079 [details]
Comment 6 Russell Miller 2009-06-01 09:29:22 EDT
I'll try running it without a conf file later today.  Won't likely make an difference.
Comment 7 Russell Miller 2009-06-01 12:04:18 EDT
I notice that my report is unclear on something.  The video is just fine when it's running the X server, I can use KDE just fine.  It's the tty console thats corrupted - for example when I ctrl-alt-F1.  If I kill the X server ungracefully, sometimes it will come back correctly and sometimes not, but never does if I exit gracefully.
Comment 8 Vedran Miletić 2009-09-06 04:53:10 EDT
This is likely a duplicate of bug 501525 (also series 4 chipset), and it's likely fixed in Fedora 11.

*** This bug has been marked as a duplicate of bug 501525 ***

Note You need to log in before you can comment on or make changes to this bug.