Bug 490482 - USB-connected UMTS modem regression USB-connected UMTS modem regression
Status: CLOSED DUPLICATE of bug 487663
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-03-16 12:52 EDT by Pawel Salek
Modified: 2009-03-18 13:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-18 13:04:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2009-03-16 12:52:17 EDT
Description of problem:
Recent kernel update broke my USB-connected UMTS modem Huawei E169. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Connect the modem. It will be automatically detected as "Auto Mobile Broadband (GSM) connection"
2. Attempt the connection activation using Network Manager
Actual results:
NetworkManager fails to establish the connection. Messages say:
<WARN>  check_pin_done(): PIN checking timed out
<info>  (ttyUSB0): device state change: 4 -> 9
<info>  Marking connection 'Auto Mobile Broadband (GSM) connection' invalid.
<info>  Activation (ttyUSB0) failed.

Expected results:
The connection is established. The messages should read:
<info>  (ttyUSB0): powering up...
<info>  Registered on Home network
<info>  Associated with network: (sanitized?)
<info>  Connected, Woo!
<info>  (ttyUSB0): device state change: 4 -> 5
<info>  Starting pppd connection

Additional info:
Should you need any extra information, just ask. I mark this regression as urgent as it effectively takes me off the net, I cannot even download new fixed packages.
Comment 1 yunus 2009-03-18 12:04:49 EDT
Thank you for filing the bug.

Did you also update NetworkManager when you updated the kernel?
It will be helpful if you can provide the version of your NetworkManager. I suspect that this bug related to https://bugzilla.redhat.com/show_bug.cgi?id=487663.

Fedora Bugzappers volunteer triage team
Comment 2 Pawel Salek 2009-03-18 12:28:24 EDT
Yes, the kernel and NetworkManager upgrades came in one batch. Downgrading NetworkManager to NetworkManager- was the first thing I did when I got the chance (that is, alternative network connection, which was not easy). It did not help. Right now, I am running NetworkManager- with the older kernel and it works fine.
Comment 3 Pawel Salek 2009-03-18 13:04:52 EDT
I withdraw my last comment. A second test showed that NM- worked because the device was already initialized by NM- If I initialize the device with NM-, *disconnect it*, install NM-, connect the device again, NM will not be able to establish the connection.

*** This bug has been marked as a duplicate of bug 487663 ***
Comment 4 yunus 2009-03-18 13:24:08 EDT
I reset the component to NetworkManager

Thank you again for reporting the bug and marking this as a duplicate of 487663.

If NM will not be able to establish the connection, you may want to try to unplug the usb modem and replug it until NM establish the connection. This trick works for me.
Fedora Bugzappers volunteer triage team

Note You need to log in before you can comment on or make changes to this bug.