Bug 490485 - anaconda install fails with AttributeError: 'str' object has no attribute 'conf'
anaconda install fails with AttributeError: 'str' object has no attribute 'conf'
Status: CLOSED DUPLICATE of bug 490296
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-16 13:05 EDT by Scott Douglass
Modified: 2009-03-16 13:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 13:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Douglass 2009-03-16 13:05:09 EDT
Description of problem:
While attempting to use virt-install to create a Rawhide QEMU VM,  the anaconda installation crashes.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.30-1.i586.rpm

How reproducible:
100%

Steps to Reproduce:
virt-install \
  --name fedora-xo \
  --ram 512 \
  --vcpus 1 \
  --disk path=/archive/vm/libvirt/fedora-xo.img,size=2.0 \
  --network bridge:br0 \
  --vnc \
  --connect qemu:///system \
  --os-type linux \
  --os-variant fedora10 \
  --hvm \
  --arch i686 \
  --location http://10.0.1.2/rawhide/i386/os \
  --extra-args "ks=http://10.0.1.2/olpc/fedora-xo/fedora-xo.ks ip=dhcp" \
  $*

Kickstart file has:

rootpw olpcroot
firewall --enabled --ssh  
network  --bootproto=dhcp --device=eth0 --onboot=on
auth  --useshadow  --passalgo=md5
install
graphical
keyboard us
lang en_US
selinux --disabled
url --url=http://10.0.1.2/rawhide/i386/os
timezone  America/New_York
bootloader --location=partition
clearpart --all --drives=sda
part /  --asprimary --fstype="ext3" --grow --size=1 --bytes-per-inode=4096 --ondisk=sda
logging --level=debug --host=10.0.1.2 --port=514
firstboot --enabled
xconfig --startxonboot
services --disabled=rpcidmapd,rpcgssd,rpcbind,portreserve,nfslock,netfs,mdmonitor,cups,auditd,exim 
reboot

  
Actual results:

ar 16 11:35:22 10.0.1.112 INFO    Running kickstart %%traceback script(s)
Mar 16 11:35:22 10.0.1.112 INFO    All kickstart %%traceback script(s) have been run
Mar 16 11:35:22 CRITICAL anaconda 11.5.0.29 exception report#012Traceback (most recent call first):#012  File "/usr/lib/anaconda/yuminstall.py", line 1496, in doPreInstall#012    if os.access("/etc/modprobe.d/anaconda".conf, os.R_OK):#012  File "/usr/lib/anaconda/backend.py", line 279, in doPreInstall#012    anaconda.backend.doPreInstall(anaconda)#012  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep#012    rc = stepFunc(self.anaconda)#012  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext#012    self.moveStep()#012  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked#012    self.anaconda.dispatch.gotoNext()#012  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback#012    self.intf.icw.nextClicked()#012  File "/usr/lib/anaconda/gui.py", line 1338, in handleRenderCallback#012    self.currentWindow.renderCallback()#012AttributeError: 'str' object has no attribute 'conf'


Expected results:
No crash.

Additional info:
Looks like some kind of type-o in yuminstall.py
Comment 1 Chris Lumens 2009-03-16 13:14:31 EDT

*** This bug has been marked as a duplicate of bug 490296 ***

Note You need to log in before you can comment on or make changes to this bug.