Bug 490296 - Anaconda crash on rawhide 2009-03-14
Anaconda crash on rawhide 2009-03-14
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:badee9fd28dc85ae7...
:
: 490272 490485 490534 (view as bug list)
Depends On:
Blocks: F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-03-14 18:23 EDT by Chris Adams
Modified: 2013-01-10 00:05 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 10:30:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (125.05 KB, text/plain)
2009-03-14 18:23 EDT, Chris Adams
no flags Details
Attached traceback automatically from anaconda. (139.87 KB, text/plain)
2009-03-15 09:14 EDT, Andrew Parker
no flags Details
Attached traceback automatically from anaconda. (97.61 KB, text/plain)
2009-03-15 13:12 EDT, eric magaoay
no flags Details
Attached traceback automatically from anaconda. (176.96 KB, text/plain)
2009-03-15 14:30 EDT, G.Wolfe Woodbury
no flags Details
Attached traceback automatically from anaconda. (267.35 KB, text/plain)
2009-03-16 06:53 EDT, M8R-nxns8i
no flags Details
Attached traceback automatically from anaconda. (139.03 KB, text/plain)
2009-03-16 09:34 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (97.07 KB, text/plain)
2009-03-17 11:01 EDT, Sascha Zorn
no flags Details
Attached traceback automatically from anaconda. (200.42 KB, text/plain)
2009-03-17 15:01 EDT, A.J. Werkman
no flags Details

  None (edit)
Description Chris Adams 2009-03-14 18:23:14 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.29 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 1496, in doPreInstall
    if os.access("/etc/modprobe.d/anaconda".conf, os.R_OK):
  File "/usr/lib/anaconda/backend.py", line 279, in doPreInstall
    anaconda.backend.doPreInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1338, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'str' object has no attribute 'conf'
Comment 1 Chris Adams 2009-03-14 18:23:22 EDT
Created attachment 335232 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Adams 2009-03-14 18:27:01 EDT
This was a pretty generic install attempt.  I booted from PXE, selected an NFS install to an existing partition (with format as ext3), and the default package selection.  I got this error while anaconda was checking dependencies.
Comment 3 Tomas Mraz 2009-03-15 08:57:34 EDT
*** Bug 490272 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Parker 2009-03-15 09:14:41 EDT
Created attachment 335259 [details]
Attached traceback automatically from anaconda.
Comment 5 eric magaoay 2009-03-15 13:12:35 EDT
Created attachment 335264 [details]
Attached traceback automatically from anaconda.
Comment 6 G.Wolfe Woodbury 2009-03-15 14:30:47 EDT
Created attachment 335268 [details]
Attached traceback automatically from anaconda.
Comment 7 M8R-nxns8i 2009-03-16 06:53:37 EDT
Created attachment 335334 [details]
Attached traceback automatically from anaconda.
Comment 8 James Laska 2009-03-16 09:34:24 EDT
Created attachment 335348 [details]
Attached traceback automatically from anaconda.
Comment 9 Chris Lumens 2009-03-16 10:30:40 EDT
Thanks for the bug report.  This will be fixed in the next build of anaconda.
Comment 10 Chris Lumens 2009-03-16 13:14:31 EDT
*** Bug 490485 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2009-03-17 10:01:32 EDT
*** Bug 490534 has been marked as a duplicate of this bug. ***
Comment 12 Sascha Zorn 2009-03-17 11:01:00 EDT
Created attachment 335533 [details]
Attached traceback automatically from anaconda.
Comment 13 A.J. Werkman 2009-03-17 15:01:58 EDT
Created attachment 335584 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.