Bug 490507 - hp6930p / keymapping for display switch, brightness down, brightness up needs to fixed [NEEDINFO]
hp6930p / keymapping for display switch, brightness down, brightness up needs...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Richard Hughes
desktop-bugs@redhat.com
:
Depends On:
Blocks: 450326
  Show dependency treegraph
 
Reported: 2009-03-16 14:35 EDT by ritz
Modified: 2014-06-02 09:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 490504
Environment:
Last Closed: 2014-06-02 09:19:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (rkhadgar)


Attachments (Terms of Use)

  None (edit)
Description ritz 2009-03-16 14:35:38 EDT
+++ This bug was initially created as a clone of Bug #490504 +++

Description of problem:
these are the error messages generated (for display switch, brightness down, brightness up, respectively): when using the multimedia keys

atkbd.c: Unknown key pressed (translated set 2, code 0xee on isa0060/serio0).
atkbd.c: Use 'setkeycodes e06e <keycode>' to make it known.

atkbd.c: Unknown key pressed (translated set 2, code 0x92 on isa0060/serio0).
atkbd.c: Use 'setkeycodes e012 <keycode>' to make it known.

atkbd.c: Unknown key pressed (translated set 2, code 0x97 on isa0060/serio0).
atkbd.c: Use 'setkeycodes e017 <keycode>' to make it known.


Version-Release number of selected component (if applicable):
http://cgit.freedesktop.org/hal-info/tree/fdi/information/10freedesktop/30-keymap-hp.fdi, as of 17th March, 2009.

How reproducible:
always

Steps to Reproduce:
1. Use the multimedia keys in question
  
Actual results:
bad mojo

Expected results:
good mojo

Additional info:

edit the line below in 30-keymap-hp.fdi

          <match key="/org/freedesktop/Hal/devices/computer:system.hardware.product" contains_outof="4410s;4411s;4415s;4416s;6730s;6730b;Compaq 5X5">

to

          <match key="/org/freedesktop/Hal/devices/computer:system.hardware.product" contains_outof="4410s;4411s;4415s;4416s;6730s;6730b;6930p;Compaq 5X5">

this would need to be reported to upstream.
Comment 4 Vladimir Benes 2009-12-09 07:20:20 EST
I changed headline as it points to hp6930 not hp6390 (see first comment.. new hal fdi file)..
Comment 7 RHEL Product and Program Management 2014-03-07 08:45:12 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 8 RHEL Product and Program Management 2014-06-02 09:19:33 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.