Bug 490585 - sparc fails make check
sparc fails make check
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
rawhide
sparc Linux
low Severity medium
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On: 491163
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 01:38 EDT by Dennis Gilmore
Modified: 2009-05-20 19:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.141-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 491163 (view as bug list)
Environment:
Last Closed: 2009-05-08 23:56:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2009-03-17 01:38:08 EDT
when building elfutils-0.140-1  on F-9 F-10 and rawhide  make check fails with the following

section [36] '.symtab': symbol 74: st_value out of bounds
section [36] '.symtab': symbol 94: st_value out of bounds
*** failure in ../src/addr2line
section [ 8] '.rela.dyn': relocation 170: relocation type invalid for the file type
*** failure in ../libelf/libelf.so
section [ 8] '.rela.dyn': relocation 883: relocation type invalid for the file type
*** failure in ../libdw/libdw.so
section [ 8] '.rela.dyn': relocation 108: relocation type invalid for the file type
*** failure in ../libasm/libasm.so
FAIL: run-elflint-self.sh


builds are at 
http://sparc.koji.fedoraproject.org/koji/taskinfo?taskID=165677
http://sparc.koji.fedoraproject.org/koji/taskinfo?taskID=163247
http://sparc.koji.fedoraproject.org/koji/taskinfo?taskID=166077
Comment 1 Dennis Gilmore 2009-03-17 01:57:32 EDT
https://sparc.koji.fedoraproject.org/koji/taskinfo?taskID=166119  is the rawhide build
Comment 2 Roland McGrath 2009-03-18 04:11:06 EDT
I need to see the offending binaries the elflint test complains about.
Or access to a sparc machine when I can try it (had access to some sparc before but forget where it is now).
Comment 3 Roland McGrath 2009-03-19 04:29:04 EDT
The reloc type errors will be fixed when I get the sparc_reloc.def table filled in from folks who know all the sparc reloc type usage.

The st_value complaints only happen on 32-bit.  These are valid complaints about what looks like an ld (binutils) bug.

[23] .plt                 PROGBITS     000223a8 0023a8 00025c  0 WAX    0   0  4
[24] .bss                 NOBITS       00022608 002604 000038  0 WA     0   0  8
   74: 00022604      0 NOTYPE  WEAK   DEFAULT       24 data_start
   93: 00022604      0 NOTYPE  GLOBAL DEFAULT       24 __data_start

These .bss symbols got assigned the address of the padding word before .bss starts.  You'll have to take that up with binutils maintainers, which I ain't.
Comment 4 Roland McGrath 2009-04-01 22:12:35 EDT
Reloc stuff done upstream, and now just this on dgilmore's rawhideish mock:

32:

section [36] '.symtab': symbol 74: st_value out of bounds
section [36] '.symtab': symbol 93: st_value out of bounds
*** failure in ../src/addr2line

64:

PASS: run-elflint-self.sh
Comment 5 Dennis Gilmore 2009-04-15 03:05:56 EDT
glibc that fixes the remaining issue was built today. https://sparc.koji.fedoraproject.org/koji/taskinfo?taskID=170082 is a scratch build with the new glibc and upstream fixes.  could we please have a new elfutils pushed and built.
Comment 6 Fedora Update System 2009-04-24 18:46:33 EDT
elfutils-0.141-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/elfutils-0.141-1.fc9
Comment 7 Fedora Update System 2009-04-24 18:46:48 EDT
elfutils-0.141-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/elfutils-0.141-1.fc10
Comment 8 Fedora Update System 2009-04-27 17:31:37 EDT
elfutils-0.141-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update elfutils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3994
Comment 9 Fedora Update System 2009-04-27 17:35:40 EDT
elfutils-0.141-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update elfutils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4018
Comment 10 Fedora Update System 2009-05-08 23:55:54 EDT
elfutils-0.141-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-05-09 00:20:06 EDT
elfutils-0.141-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2009-05-19 17:58:25 EDT
elfutils-0.141-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/elfutils-0.141-1.fc11
Comment 13 Fedora Update System 2009-05-20 19:53:22 EDT
elfutils-0.141-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.