Bug 491163 - sparc32: ld places .bss symbol before .bss section address (in section alignment padding)
sparc32: ld places .bss symbol before .bss section address (in section alignm...
Status: CLOSED DUPLICATE of bug 493969
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
sparc Linux
low Severity medium
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
:
Depends On: 493969
Blocks: 490585
  Show dependency treegraph
 
Reported: 2009-03-19 12:54 EDT by Dennis Gilmore
Modified: 2009-04-03 11:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 490585
Environment:
Last Closed: 2009-04-03 10:51:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2009-03-19 12:54:42 EDT
+++ This bug was initially created as a clone of Bug #490585 +++

when building elfutils-0.140-1  on F-9 F-10 and rawhide  make check fails with the following

section [36] '.symtab': symbol 74: st_value out of bounds
section [36] '.symtab': symbol 94: st_value out of bounds
*** failure in ../src/addr2line
section [ 8] '.rela.dyn': relocation 170: relocation type invalid for the file type
*** failure in ../libelf/libelf.so
section [ 8] '.rela.dyn': relocation 883: relocation type invalid for the file type
*** failure in ../libdw/libdw.so
section [ 8] '.rela.dyn': relocation 108: relocation type invalid for the file type
*** failure in ../libasm/libasm.so
FAIL: run-elflint-self.sh


builds are at 
http://sparc.koji.fedoraproject.org/koji/taskinfo?taskID=165677
http://sparc.koji.fedoraproject.org/koji/taskinfo?taskID=163247
http://sparc.koji.fedoraproject.org/koji/taskinfo?taskID=166077

--- Additional comment from dennis@ausil.us on 2009-03-17 01:57:32 EDT ---

https://sparc.koji.fedoraproject.org/koji/taskinfo?taskID=166119  is the rawhide build

--- Additional comment from roland@redhat.com on 2009-03-18 04:11:06 EDT ---

I need to see the offending binaries the elflint test complains about.
Or access to a sparc machine when I can try it (had access to some sparc before but forget where it is now).

--- Additional comment from roland@redhat.com on 2009-03-19 04:29:04 EDT ---

The reloc type errors will be fixed when I get the sparc_reloc.def table filled in from folks who know all the sparc reloc type usage.

The st_value complaints only happen on 32-bit.  These are valid complaints about what looks like an ld (binutils) bug.

[23] .plt                 PROGBITS     000223a8 0023a8 00025c  0 WAX    0   0  4
[24] .bss                 NOBITS       00022608 002604 000038  0 WA     0   0  8
   74: 00022604      0 NOTYPE  WEAK   DEFAULT       24 data_start
   93: 00022604      0 NOTYPE  GLOBAL DEFAULT       24 __data_start

These .bss symbols got assigned the address of the padding word before .bss starts.  You'll have to take that up with binutils maintainers, which I ain't.
Comment 1 Tom "spot" Callaway 2009-04-03 10:51:22 EDT

*** This bug has been marked as a duplicate of bug 493969 ***

Note You need to log in before you can comment on or make changes to this bug.