Bug 49066 - up2date --download <package> bombs out when the package cannot be installed
up2date --download <package> bombs out when the package cannot be installed
Status: CLOSED DUPLICATE of bug 63844
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-13 08:26 EDT by Graham Leggett
Modified: 2015-01-07 18:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-03 21:48:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2001-07-13 08:26:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; I; Linux 2.4.6 ppc)

Description of problem:
When using the --download flag to up2date to ask it to download the package
only, and not install it, up2date bombs out the entire process should the
installation not be possible right away.

The correct behavior would be to follow the instructions on the command
line, and just download the package so that conflicts could be resolved
manually.


How reproducible:
Always

Steps to Reproduce:
- Install exim
- Configure exim (so that it's config files have changed)
- Try and download a new exim package using up2date - use the --download
flag to download the package only.


Actual Results:  [root@samantha /root]# /usr/sbin/up2date --download exim

Retrieving list of all available packages...

Removing installed packages from list of updates...
########################################

Removing packages with files not specified from list...

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Getting headers for skipped packages...
########################################
The following Packages were marked to be skipped by your configuration:

Name                                    Version        Rel  Reason
-------------------------------------------------------------------------------
exim                                    3.22           6x   Config modified

None of the packages you requested were found, or they are already updated.


Additional info:
Comment 1 Adrian Likins 2001-07-13 20:26:20 EDT
This is intended behavior. up2date will only fetch packages that can be
installed correctly, if it is going to install them directly it self or not.
Comment 2 Graham Leggett 2001-07-13 20:43:45 EDT
According to the documentation man up2date:

       -d, --download
              download  packages only, do not install them.  This option is
provided so that you can
              override the configuration option "Do not install packages after
retrieval."  It is mutually
              exclusive with the --install option.

this implies that the files should be downloaded only - it is not intuitive to
also assume that these rpms should be eventually installable - if I wanted
up2date to install them I would have asked it to.

If this is the intended behavior then the documentation needs fixing to indicate
clearly how a download is to be done that doesn't involve dependancies.
Comment 3 Ed Bailey 2001-11-03 21:48:19 EST
I've just run into a similar problem; the system I'm up2date'ing is a very small
single-purpose box.  It is installed on a 128MB CompactFlash card via a script
(the script basically does a rpm -ivh *.rpm on the ~100 RPMs I require).

I want to use up2date to keep it current by configuring up2date to download
only, pointing up2date at an NFS-mounted filesystem to store the RPMs (that
system is also where I install onto my CompactFlash card).

However, up2date complains (and rightly so) that the new kernel requires more
free space on the root filesystem (my CompactFlash card) than currently exists
there.  This is true; however, my installation script deals with this, so
up2date shouldn't worry about it.

The problem is, there's no way to tell up2date to chill out.  The --force option
should either be expanded to handle such issues, or another option should be
added to support this funtionality (I suggest
"--justdownloadthefilesanddon'tworryaboutitdammit!" :-)
Thanks!

Ed
Comment 4 Adrian Likins 2002-05-15 16:52:46 EDT

*** This bug has been marked as a duplicate of 63844 ***

Note You need to log in before you can comment on or make changes to this bug.