Bug 63844 - [RFE] up2date won't download (should allow download only regardless of package set installibility)
[RFE] up2date won't download (should allow download only regardless of packag...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
: 49066 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-19 09:06 EDT by greg hosler
Modified: 2015-01-07 18:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 20:10:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description greg hosler 2002-04-19 09:06:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020401

Description of problem:
2 scenerios.

1) I fill up the rhn-register, with the option "do not install". I run up2date,
with a d/l directory that has in excess of 1.3 gb - I tell up2date to "download
everything available"

up2date then goes into rpm mode and eventually tells me "insufficient room on /usr"

2) instead of running just "up2date" I run "up2date -d" - again I tell it to
download everything available. again it tells me "insufficient room on /usr"

"download only, and do not install" mode has absolutely no business telling me
whether or not I have space on /usr (or any other partition for that matter).
That's an install/update issue, and *only* an install/update issue. If a user is
intellegent enough to d/l and do selective updates, then can deal with space
problems as/when the time comes.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see above
2.
3.
	

Actual Results:  no rpm's downloaded

Expected Results:  rpm's downloaded.

Additional info:

in it's current form, up2date is useless for those that do not trust
an automated d/l and install silently mode.
Comment 1 Adrian Likins 2002-05-08 13:42:42 EDT
I'll take a look and see if it's possible to make rpm ignore the
available size when determining if a transaction set is valid
or not. 

Currently, the client will only let you download sets of
packages which are installable on the machine the client
is running on. This is by design.

I'm currently working on version 3 of the client, so
I'll see if adding a "--download-package-even-though-I-know-I-cant-install-them"
option to the next version. It's probabaly a worthwhile RFE.
Comment 2 Adrian Likins 2002-05-15 16:52:40 EDT
*** Bug 49066 has been marked as a duplicate of this bug. ***
Comment 3 Adrian Likins 2003-08-06 18:20:10 EDT
There is new --get commandline mode to only download packages without
checking deps.

Note You need to log in before you can comment on or make changes to this bug.