Bug 490758 - libudev0 not available during some installs breaks NM
libudev0 not available during some installs breaks NM
Status: CLOSED DUPLICATE of bug 485133
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
: 491461 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 16:37 EDT by Chris Schanzle
Modified: 2009-10-28 11:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 11:12:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Schanzle 2009-03-17 16:37:32 EDT
Description of problem:
After clean install, reboot shows NetworkManager unable to start because libudev0.so.0 could not be found.

libudev0 is not on fedora 10's DVD or "Fedora" repo, only under "Everything".

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0.99-3.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1. install with: method=nfs:<myNFSserver>:/fedora/linux/releases/10/Fedora/x86_64/os

This path results in a working installation:
/fedora/linux/releases/10/Fedora/x86_64/os

Note sure how to resolve this for DVD installations who want to pre-apply updates.

Maybe "update" libudev0 so it's in the update repo too?
Comment 1 Chris Schanzle 2009-03-17 16:39:29 EDT
Sorry, bad editing above.  Working installation path is:
/fedora/linux/releases/10/Everything/x86_64/os/
Comment 2 Chris Schanzle 2009-03-17 17:56:56 EDT
Alternate steps to reproduce:

1. Boot F10 DVD (note libudev0 does not exist here)
2. use defaults possible until repo selection screen
3. deselect "Office and Productivity" to save time
4. enable repo "Fedora 10 - <arch> Updates"
5. proceed with installation

When system starts NetworkManager service, it fails to start with unable to find libudev0.so.0.
Comment 3 Dan Williams 2009-03-18 09:19:41 EDT
As explained on the fedora-devel mailing lists, enabling the "Updates" repo actually requires the Everything repo to be enabled as well, since updates may require new packages not available in the original repo or on the dvd.  Not sure how anaconda wants to handle this.
Comment 4 Chris Lumens 2009-03-18 10:52:14 EDT

*** This bug has been marked as a duplicate of bug 485133 ***
Comment 5 Chris Schanzle 2009-03-18 12:06:11 EDT
Reopened; I don't see how 485133 is a duplicate; that's an upgrade F8->F10 NVR issue.

At the absolute least, release notes should be amended that if you add repo "Updates" you need repo "Everything".

Anaconda could help with this by auto-selecting the Everything repo automatically when user selects Updates repo.

I haven't tried yet, but will adding Everything be a higher "cost" repo than local DVD, so that DVD is read in preference to network?

I feel is a problem that should be addressed as including updates during a DVD install not only sounds like a good idea, it seems to be supported.
Comment 6 Dan Williams 2009-03-23 12:46:08 EDT
*** Bug 491461 has been marked as a duplicate of this bug. ***
Comment 7 Joel Andres Granados 2009-09-09 07:57:36 EDT
The subject of this bug is no longer relevant.  I just did a rawhide install with a minimal set of packages selected. (I deselected everything and only left base) and NM works correctly.  Feel free to reopen this bug if you see the same behavior in f12 alpha or later.

With respect to the Updates - Everything issue.  I would suggest  testing with f12alpha and opening a new bug if that behavior persists.
Comment 8 Chris Schanzle 2009-09-10 09:51:29 EDT
I feel just closing this without resolution is inappropriate.  Joel, I think you missed the root cause of this in your first paragraph, there's probably no way to reproduce this with F12 at the moment.  NetworkManager was just an example of the general install problem, as noted in comment #3.

One resolution would be to add to the release notes that if you install with updates, you may need to have access to the "Everything" repo, not just what is on the DVD or "Fedora" repo.  The reason is that some updates may require additional dependencies on packages that were not on the DVD in the original release.

As it stands, this is an undocumented requirement.
Comment 9 Chris Lumens 2009-10-28 11:12:52 EDT
Please see bug 485133 comment #16 for why this is a duplicate.

*** This bug has been marked as a duplicate of bug 485133 ***

Note You need to log in before you can comment on or make changes to this bug.