Bug 490818 - [PATCH] mkdumprd's interaction with mdadm could be improved
Summary: [PATCH] mkdumprd's interaction with mdadm could be improved
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
(Show other bugs)
Version: 5.3
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Neil Horman
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
: 500098 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-03-18 07:22 UTC by Harshula Jayasuriya
Modified: 2009-09-02 09:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 600591 (view as bug list)
Environment:
Last Closed: 2009-09-02 09:14:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against TOT mkdumprd (1003 bytes, patch)
2009-03-18 07:26 UTC, Harshula Jayasuriya
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1258 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2009-09-01 09:09:40 UTC

Description Harshula Jayasuriya 2009-03-18 07:22:12 UTC
Description of problem:

* As requested by Neil I am opening a bug for:

1) The regular expressions that search for the keyword "ARRAY" at the start of a line should match whitespace immediately after the keyword. e.g. "^ARRAY[[:space:]]"

2) On line 1664, why is /etc/mdadm.conf accessed directly instead of calling "mdadm --examine --scan"?
-------------------------------------------
1664 emit "  for i in \`grep -v \"#\" /etc/mdadm.conf | awk '/.*ARRAY.*/{print \$2}'\`"
-------------------------------------------
In the other instance where ARRAY information is required, mdadm is called.


Version-Release number of selected component (if applicable):

* The source code I'm referring to is from a TOT CVS checkout of kexec-tools

Additional info:

* I've attached a patch which addresses problem (1).

Regards,
Harshula

Comment 1 Harshula Jayasuriya 2009-03-18 07:26:04 UTC
Created attachment 335661 [details]
Patch against TOT mkdumprd

Comment 2 Harshula Jayasuriya 2009-03-20 00:56:31 UTC
Hi Neil,

re: Problem (2) from the original Description.

I forget to mention that the mdadm binary is copied into the kdump initrd image. Hence it is available and can be called from initrd's init script.

Comment 3 Neil Horman 2009-03-23 17:15:31 UTC
in 1.102pre-60.el5.  Thanks!

Comment 5 Neil Horman 2009-05-12 14:27:21 UTC
*** Bug 500098 has been marked as a duplicate of this bug. ***

Comment 7 Neil Horman 2009-07-16 12:54:59 UTC
*** Bug 509947 has been marked as a duplicate of this bug. ***

Comment 9 Neil Horman 2009-07-21 15:22:12 UTC
I'm moving this back to MODIFIED, Since I'm fixing the remaining cosmetic problems for this bug in bz 509947

Comment 14 errata-xmlrpc 2009-09-02 09:14:01 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1258.html


Note You need to log in before you can comment on or make changes to this bug.