Bug 500098 - "# service kdump start" fails on PAE and Xen kernel
"# service kdump start" fails on PAE and Xen kernel
Status: CLOSED DUPLICATE of bug 490818
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-10 22:20 EDT by umed
Modified: 2009-05-12 10:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 10:27:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description umed 2009-05-10 22:20:15 EDT
Description of problem:
# service kdump start
and
# system-config-kdump
fail with below messages on PAE and Xen kernel.

Rebuilding /boot/initrd-2.6.18-128.1.10.el5kdump.img
No module ARRAY found for kernel 2.6.18-128.1.10.el5, aborting.
Failed to run mkdumprd
 

Version-Release number of selected component (if applicable):

kexec-tools-1.102pre-56.el5_3.2
system-config-kdump-1.0.14-4.el5
kernel-2.6.18-128.1.10.el5
kernel-xen-2.6.18-128.1.10.el5


How reproducible:
everytime


Steps to Reproduce:
1. # service kdump start

1. # system-config-kdump
2. Click OK
  
Actual results:
# service kdump start
No kdump initial ramdisk found.                            [WARNING]
Rebuilding /boot/initrd-2.6.18-128.1.10.el5kdump.img
No module ARRAY found for kernel 2.6.18-128.1.10.el5, aborting.
Failed to run mkdumprd
#

Expected results:
# service kdump start
No kdump initial ramdisk found.                            [WARNING]
Rebuilding /boot/initrd-2.6.18-128.1.10.el5kdump.img
Starting kdump:                                            [OK]
#



Additional info:
Comment 1 Neil Horman 2009-05-11 06:22:43 EDT
please post your /etc/mdadm.conf file.
Comment 2 umed 2009-05-11 20:38:02 EDT
$ cat /etc/mdadm.conf
DEVICE partitions
MAILADDR root
ARRAY /dev/md0 super-minor=0
ARRAY /dev/md1 super-minor=1
$

I've already deleted comment line, but "service kdump start" aborted.
Comment 3 Neil Horman 2009-05-12 06:44:09 EDT
suspect this is a duplicate of bz 490818.  Please test with the rpm found here:
http://people.redhat.com/nhorman/rpms/kexec-tools-1.102pre-69.el5.x86_64.rpm
and see if the problem is resolved.  Thanks
Comment 4 umed 2009-05-12 09:50:53 EDT
Thank you!
"kexec-tools-1.102pre-69.el5.x86_64.rpm" works!
Comment 5 Neil Horman 2009-05-12 10:27:21 EDT
Fantastic, thanks!

*** This bug has been marked as a duplicate of bug 490818 ***

Note You need to log in before you can comment on or make changes to this bug.