Bug 490879 - VTKConfig.cmake path errors
VTKConfig.cmake path errors
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vtk (Show other bugs)
11
i386 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
: 505964 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 08:25 EDT by Arthur Magill
Modified: 2009-07-31 13:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.2.1-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 02:52:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to correct paths in VTKConfig.cmake (7.27 KB, patch)
2009-03-18 08:25 EDT, Arthur Magill
no flags Details | Diff
correct missing "/" in VTKConfig.cmake (715 bytes, patch)
2009-04-06 05:28 EDT, Fabrice Bellet
no flags Details | Diff

  None (edit)
Description Arthur Magill 2009-03-18 08:25:08 EDT
Created attachment 335692 [details]
Patch to correct paths in VTKConfig.cmake

Description of problem:

N.B. This is  abug report against the current build of VTK for FC11 taken from Koji and rebuild against FC10, but I expect to see the same error in FC11.

There is a missing / in all paths in /usr/lib/vtk-5.2/VTKConfig.cmake. All paths of the form 

  ${VTK_INSTALL_PREFIX}lib 

should read 

  ${VTK_INSTALL_PREFIX}/lib

Version-Release number of selected component (if applicable):

vtk-5.2.1-1.fc11, rebuild for fc10

How reproducible:
Always

Steps to Reproduce:
0. install vtk, vtk-devel (and for this example vtk-qt)
1. cd /usr/share/doc/vtk-examples-5.2.1/Examples/GUI/Qt/
2. cmake .
  
Actual results:
...lots of path errors...

Expected results:
Clean build of examples

Additional info:
Diff attached which cures all errors, but there is probably a cleaner way of fixing this somewhere in cmake.
Comment 1 Fabrice Bellet 2009-04-06 05:28:23 EDT
Created attachment 338305 [details]
correct missing "/" in VTKConfig.cmake

Same behaviour here. I think the patch should be made to the spec file instead. Ditto for VTK_DATA_ROOT, that probably should be hardcoded to %{_datadir}/vtkdata-xxx, because it is never referenced in a way relative to an install prefix in CMakeLists.txt files.
Comment 2 Milos Jakubicek 2009-04-24 18:39:17 EDT
This problem breaks building octaviz (failed in the F11 Mass Rebuild) and maybe even more packages, going to fix this.
Comment 3 Fabrice Bellet 2009-06-03 09:39:23 EDT
Could vtk be rebuilt for Fedora 11 too ?
Comment 4 Fedora Update System 2009-06-03 15:40:09 EDT
vtk-5.2.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/vtk-5.2.1-2.fc11
Comment 5 Bug Zapper 2009-06-09 08:20:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Torsten Rohlfing 2009-06-14 21:12:24 EDT
*** Bug 505964 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2009-06-15 21:50:54 EDT
vtk-5.2.1-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vtk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6194
Comment 8 Fedora Update System 2009-07-16 02:52:24 EDT
vtk-5.2.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.