Bug 505964 - VTK config/use file are broken on x86_64
VTK config/use file are broken on x86_64
Status: CLOSED DUPLICATE of bug 490879
Product: Fedora
Classification: Fedora
Component: vtk (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 20:37 EDT by Torsten Rohlfing
Modified: 2009-07-31 13:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-14 21:12:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Torsten Rohlfing 2009-06-14 20:37:31 EDT
Description of problem:

When including VTK in another CMake-configured project, CMake encounters an error due to an invalid VTK path.

Version-Release number of selected component (if applicable):

vtk-5.2.1-1.fc11

How reproducible:

Create a CMakeLists.txt file that contains the following:

  SET(VTK_DIR /usr/lib64)
  FIND_PACKAGE(VTK)
  IF (VTK_FOUND)
    INCLUDE (${VTK_USE_FILE})
  ENDIF (VTK_FOUND)
  
then run CMake on this project.
  
Actual results:

CMake Error at CMakeLists.txt:263 (INCLUDE):                                                                       
  include could not find load file:                                                                                

    /usrlib64/vtk-5.2/UseVTK.cmake

Expected results:

CMake finds and configures VTK for use in new project.

Additional info:

It seems that the missing "/" in the generated path is due to the following changes in /usr/lib64/vtk-5.2/VTKConfig.cmake:

# The location of the UseVTK.cmake file.
SET(VTK_USE_FILE "${VTK_INSTALL_PREFIX}lib64/vtk-5.2/UseVTK.cmake")

in vtk5.2 used to be

# The directory containing class list files for each kit.
SET(VTK_KITS_DIR "${VTK_INSTALL_PREFIX}/usr/lib64/vtk-5.0")

in the previous version.

I am having a bit of a hard time tracking down in the VTK cvs what exactly went along with this change, but it seems this could be either a misconfiguration of the Fedora build, or an upstream bug in VTK 5.2.
Comment 1 Torsten Rohlfing 2009-06-14 20:38:25 EDT
Sorry, wrong cut'n'paste -- the VTKConfig.cmake section in 5.0 that corresponds to the one quoted for 5.2 is of course

# The location of the UseVTK.cmake file.
SET(VTK_USE_FILE "${VTK_INSTALL_PREFIX}/usr/lib64/vtk-5.0/UseVTK.cmake")
Comment 2 Torsten Rohlfing 2009-06-14 21:12:24 EDT

*** This bug has been marked as a duplicate of bug 490879 ***

Note You need to log in before you can comment on or make changes to this bug.