Bug 490881 - [Test Day] palimpsest: limited function for root user
[Test Day] palimpsest: limited function for root user
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-disk-utility (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
: 490873 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 08:37 EDT by Ondrej Hudlicky
Modified: 2009-04-07 13:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 13:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Hudlicky 2009-03-18 08:37:09 EDT
Description of problem:

Running palimpsest as root provides very limited functions - not possible to: delete, edit, mount, unmount volumes. 

Version-Release number of selected component (if applicable):
DeviceKit-disks-003-6.fc11
gnome-disk-utility-02-2.fc11
PolicyKit-0.9-6.fc11 - no changes in setup

Reproducible: 
always 

Steps to Reproduce:

1. su -
2. palimpsest & 
3. click on different disks/volumes in left menu
4. run as common X user: palimpsest  &
5. compare the active options provided by palimpsest

Actual results:
root usage has much less option then running as user

Expected results:
root has same (or) more functions available
Comment 1 Matthias Clasen 2009-03-18 22:38:26 EDT
Same comment as for nautilus: This is caused by su not propagating the session bus. But palimpsest is not meant to be used in this way anyway; it uses PolicyKit to ask for privileges if needed.
Comment 2 David Zeuthen 2009-04-07 13:04:39 EDT
Matthias is right, simply don't runt palimpsest (or for that matter any desktop programs) as uid 0. See e.g. http://www.gtk.org/setuid.html and many other places why running desktop apps as uid 0 is a horrible idea. 

Also note that with the move to the new PolicyKit version in F12 by default root will be all powerful PolicyKit-wise. In the mean time, you can manually grant the root user the needed authorizations.
Comment 3 David Zeuthen 2009-04-07 13:06:00 EDT
*** Bug 490873 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.