Bug 491013 - Need "true" upgrade process for RHN Proxy - i.e., without having to re-provision OS and re-install pkgs
Need "true" upgrade process for RHN Proxy - i.e., without having to re-provis...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
520
All Linux
high Severity medium
: ---
: ---
Assigned To: John Ha
Jeff Browning
: Documentation
Depends On:
Blocks: 456984 456999
  Show dependency treegraph
 
Reported: 2009-03-18 17:42 EDT by Xixi
Modified: 2014-08-04 18:18 EDT (History)
6 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 516624 (view as bug list)
Environment:
Last Closed: 2009-09-10 10:37:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2009-03-18 17:42:06 EDT
Description of problem:
This is somewhat of a companion or add-on bug to bug 491007.  There should be a better way to upgrade a RHN Proxy than re-provision OS and re-install RHN Proxy, which kind of goes against the definition of an "upgrade".

There needs to be a Proxy upgrade script like that for Satellite, or testing/documentation that at least removes the necessity to re-provision the entire OS. 

Version-Release number of selected component (if applicable):
All.

How reproducible:
Always.

Steps to Reproduce:
1. Try to upgrade a RHN Proxy via the current official/supported route.
2.
3.
  
Actual results:
Have to reprovision OS then re-install Proxy.

Expected results:
Should not have to reprovision OS, and either have a Proxy upgrade script or have the Proxy installer do a upgrade as opposed to removing old pkgs and then re-install new ones.

Additional info:
Comment 2 Xixi 2009-03-18 17:55:06 EDT
Actually, this is not pure documentation. Changing component to Server.
Comment 3 Miroslav Suchý 2009-03-19 04:57:30 EDT
Since 5.1, you can deactivate proxy and remove the packages. Then you can activate proxy. If you did not choosed to remove packages during deactivations, they are removed and installed new proxy packages.
The removal is necessary since we can not guarantee correct version if we run classical yum/up2date upgrade.
Anyway WebUI installer will not be developed any more and we move to command line installer (CLI). And with CLI is upgrade possible and in fact very easy. You just run 
  configure-proxy.sh
and choose the version of proxy you want upgrade to. And thats all.

Since all the work is done (and tracked in differents BZs) it is "just" about write documentation for that. Therefore moving back to John Ha.

Kbase article 
  http://kbase.redhat.com/faq/docs/DOC-10806
should be edited
And we should probably explicitly note the availability of upgrade in RHN Proxy Guide.
Comment 4 Miroslav Suchý 2009-03-19 13:18:02 EDT
John, I will provide you here suggestion how to rewrite the article, draft of new one and maybe some draft for documentation. Give me day or two...
I will then work with you on polishing the text to usable state.
Comment 5 Brandon Perkins 2009-03-26 00:08:59 EDT
As a note, a few related bugs have been created:

As we are past the documentation freeze for 5.3 we will not be able to get this
in.  However, there is work being done in this area for 5.3 to make it less
painful:

Bug 491007 -  Need official RHN Proxy upgrade documentation (i.e., not kbase) in either Proxy docs or rhn-upgrade pkg

Bug 492247 -  Update of the "How do I upgrade my Red Hat Network (RHN) Proxy to
the latest version?" KB article.

Bug 492248 -  Need to create test cases around Proxy Upgrades in both Proxy and
Upgrades test plans.
Comment 6 John Ha 2009-05-22 17:00:34 EDT
So, from this, the aim is to pull the collective KB entries Miroslav has been working on in Bug 492248 together for a new "Upgrade" chapter in the Proxy Installation Guide, correct?

Have we determined whether this will go into 5.3.0 Proxy Installation Guide or are we sticking with Brandon's statement that we are not going to get this into 5.3.0 on time and the KB entry will suffice?

Let me know either way :)
Comment 7 Clifford Perry 2009-07-23 14:20:01 EDT
This is a Kbase article content. 

How do I upgrade my Red Hat Network (RHN) Proxy using reprovision?
http://kbase.redhat.com/faq/docs/DOC-10806

<bad link> - sending email to kbase list asking. 
http://kbase.redhat.com/faq/docs/DOC-17354

How do I upgrade my Red Hat Network (RHN) Proxy server using the Command Line Installer?
http://kbase.redhat.com/faq/docs/DOC-17659

Cliff
Comment 8 Jeff Browning 2009-07-24 00:44:35 EDT
Given the previous statements that this will not make it into the Proxy Install Guide in 530 and that the KB article will suffice, I am marking this verified. The KB article is updated and correct.
Comment 10 Brandon Perkins 2009-09-10 10:37:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.