Bug 491018 - gpsd 2.39 is now released
gpsd 2.39 is now released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpsd (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
:
Depends On: 492617
Blocks: 219750 491390
  Show dependency treegraph
 
Reported: 2009-03-18 18:03 EDT by David
Modified: 2009-03-31 11:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 15:54:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David 2009-03-18 18:03:39 EDT
Description of problem:

gpsd 2.39 is now released.  Can we please get into F10, F9 and F11 please?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David 2009-03-18 18:44:29 EDT
Also this should build easy as compared to 2.38

I just quickly used the koji 2.38 spec and patches against 2.39 and it only fails on a libgps.so.17

+ /bin/chmod +x /root/rpmbuild/BUILDROOT/gpsd-2.39-1.fc10.i386/usr/lib/libgps.so.17.0.0
/bin/chmod: cannot access `/root/rpmbuild/BUILDROOT/gpsd-2.39-1.fc10.i386/usr/lib/libgps.so.17.0.0': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.AQvvI5 (%install)
Comment 2 Douglas E. Warner 2009-03-18 18:50:25 EDT
Thanks; I was following the release discussion on the dev list so I knew it was coming soon.

I've been trying to test the udev/hotplug wrapper functionality which was delaying me getting 2.38 out; I'll bump for 2.39 and get both pieces out the door soon.
Comment 3 David 2009-03-18 19:16:18 EDT
No problems :) - I only knew as I got the email from gpsd users it was released.

I will keep a eye out in koji for any builds.

Cheers,

David
Comment 4 Douglas E. Warner 2009-03-19 15:11:31 EDT
I'm having a problem getting gpsd built in koji.  I keep getting "file truncated" errors.  Rel-eng thinks this might be related to objects which aren't ordered properly in the Makefile and therefore aren't built when gpsd is getting linked.  I haven't had a chance to look at this yet.
Comment 5 David 2009-03-22 19:13:30 EDT
Thanks for the update.  Hope you have some success with it.

Did you try to build it without xgpsspeed to see if this is what is causing the issue?  Maybe gpsd-dev might have an idea as they wrote it?

Thanks again.
Comment 6 Douglas E. Warner 2009-03-25 10:57:50 EDT
I'm able to build gpsd 2.39 now, but I'm not sure whether to push it back to F-9 and F-10 due to a soname bump in 2.39.  See bug#491390 for more information.
Comment 7 Douglas E. Warner 2009-03-25 17:00:35 EDT
Okay; they're built for F9 and F10; I'm waiting for kdeedu-marble to be rebuilt against it and we'll start getting it pushed.
Comment 8 David 2009-03-25 18:58:27 EDT
Hi Douglas,

Many thanks I downloaded it from koji and installed.  I found a few typo's in the /etc/init.d/gpsd


exec="/usr/sbin/gpsd"

The binary is in sbin not bin as in the init.d file this stopped it from working.

Next it still won't start:

Starting gpsd: gpsd can't listen on local socket /var/run/gpsd.sock
gpsd: control socket create failed, netlib error -1
Failed

I then decided to check for any AVC errors, I found these, in all there are quite a few several stop and starts and restarts and tweaking local policy until it now startes and stops without any AVC errors:


type=AVC msg=audit(1238017743.709:976): avc:  denied  { write } for  pid=21997 comm="gpsd" name="run" dev=dm-0 ino=2007053 scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=dir
type=AVC msg=audit(1238019040.204:1006): avc:  denied  { unix_read unix_write } for  pid=23395 comm="gpsd" key=1314148403 scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:initrc_t:s0 tclass=shm
type=AVC msg=audit(1238019040.212:1007): avc:  denied  { fsetid } for  pid=23395 comm="gpsd" capability=4 scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tclass=capability
type=AVC msg=audit(1238019758.800:1037): avc:  denied  { add_name } for  pid=23508 comm="gpsd" name="gpsd.sock" scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=dir
type=AVC msg=audit(1238019925.225:1040): avc:  denied  { create } for  pid=23543 comm="gpsd" name="gpsd.sock" scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=sock_file
type=AVC msg=audit(1238020024.803:1043): avc:  denied  { create } for  pid=23562 comm="gpsd" name="gpsd.pid" scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=file
type=AVC msg=audit(1238020024.835:1045): avc:  denied  { associate } for  pid=23562 comm="gpsd" key=1314148403 scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:initrc_t:s0 tclass=shm
type=AVC msg=audit(1238020154.058:1048): avc:  denied  { remove_name } for  pid=23588 comm="gpsd" name="gpsd.sock" dev=dm-0 ino=2008174 scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_run_t:s0 tclass=dir
type=AVC msg=audit(1238020309.146:1057): avc:  denied  { unlink } for  pid=23621 comm="gpsd" name="gpsd.sock" dev=dm-0 ino=2008174 scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=sock_file
type=AVC msg=audit(1238020464.848:1063): avc:  denied  { write } for  pid=23662 comm="gpsd" name="gpsd.pid" dev=dm-0 ino=2008317 scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=file
type=AVC msg=audit(1238020464.893:1065): avc:  denied  { read write } for  pid=23662 comm="gpsd" key=1314148403 scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:initrc_t:s0 tclass=shm
type=AVC msg=audit(1238020698.950:1076): avc:  denied  { getattr } for  pid=23716 comm="gpsd" path="/var/run/gpsd.pid" dev=dm-0 ino=2008317 scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=file
type=AVC msg=audit(1238020698.997:1078): avc:  denied  { read write } for  pid=23716 comm="gpsd" path=2F535953563465353435303333202864656C6574656429 dev=tmpfs ino=98307 scontext=unconfined_u:unconfined_r:gpsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file

After allowing these audits into my policy it happily starts and restarts without any AVC errors.


You may want to ask dwalsh to get this into selinux as if anyone runs selinux enforcing gpsd won't run without the policy changes.


GPSD runs well its locked PPS providing time to NTPD.

However my one and last issue is I can't seem to telnet to the machine on 2947 to get the terminal up, yet GPSD is running providing PPS locked time to ntpd.  If I try to telnet in, it kicks me right off.  If I go to the machine locally and connect telnet localhost 2947 it works.

So for some reason its only on localport not listening on all the IP addresses.

Thanks again
Comment 9 David 2009-03-26 02:31:11 EDT
I found the listening has changed since the last fedora version that was in the repos (2.37) seems it only listens on loopback by default.

I suggest these changes for the init script.

OPTIONS="-n -G"

This means GPSD listens on all interfaces now not just loopback so the functionality is now the same as 2.37

I also changed device to serial, perhaps this needs to be noted so users on serial know to change.

Maybe add in like this:

DEVICE="/dev/ttyS0"
#DEVICE="/dev/ttyUSB0"

And note in the comments you comment out one or the other if you want serial or USB.


Fix up the exec line:

exec="/usr/sbin/gpsd"

And its all good to go.  Its been very stable and PPS locked.

Once the selinux stuff is done I see no reason this can't be submitted for stable.
Comment 10 Douglas E. Warner 2009-03-26 08:53:12 EDT
Thanks for the information on the typo in the program name and the AVC warnings.  For your other configuration options they should all be made in /etc/sysconfig/gpsd; if the script currently doesn't use this file I need to update it so it does.
Comment 11 Rex Dieter 2009-03-27 14:04:00 EDT
comment left in gpsd/kdeedu update:
mschwendt - 2009-03-27 17:52:29

Breaks deps, requires updates for:

geoclue
qtgpsc
viking
Comment 12 Rex Dieter 2009-03-27 14:07:27 EDT
Confirmed with repoquery.

I'll withdraw the update, until those other packages are fixed/rebuilt, and can be added to
https://admin.fedoraproject.org/updates/F10/FEDORA-2009-3059

(I'd venture that F-9 may be affected similarly, can anyone confirm or deny that?)
Comment 13 Douglas E. Warner 2009-03-27 14:22:45 EDT
Crap; sorry about that.  My repoquery was apparently not good enough.  I'll file bugs against those other packages.
Comment 14 Rex Dieter 2009-03-30 15:54:13 EDT
OK, too much pain, I'd recommend sticking with rawhide only here for now... and once everything builds and sufficiently tested in rawhide/f11, a re-evaluation can be made.

Note You need to log in before you can comment on or make changes to this bug.