Bug 491390 - gpsd 2.39 soname bump
gpsd 2.39 soname bump
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeedu (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On: 491018
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 14:06 EDT by Douglas E. Warner
Modified: 2009-03-26 12:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 17:08:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas E. Warner 2009-03-20 14:06:32 EDT
gpsd 2.39 will have a soname bump that affects kdeedu-marble.  I have packages built here:

http://www.silfreed.net/download/repo/packages/gpsd/

If you could test to see if kdeedu-marble is affected and let me know if I need to build a compat package I'd appreciate it.
Comment 1 Kevin Kofler 2009-03-20 14:16:39 EDT
I'd suggest just building the updated gpsd in dist-f11 and giving us a heads-up once it's built, we'll worry about rebuilding kdeedu at that point.

I strongly doubt a compat package will be needed or useful, unless there are really major API changes, dependent packages should either rebuild unchanged or need only minor patching.
Comment 2 Kevin Kofler 2009-03-20 14:17:23 EDT
(Note that due to the ongoing beta freeze, the gpsd build will not hit the daily Rawhide snapshots right now anyway.)
Comment 3 Kevin Kofler 2009-03-20 14:18:38 EDT
As for F9 and F10, if you want to update gpsd there too, we can do a grouped update once we have things built in Rawhide.
Comment 4 Douglas E. Warner 2009-03-20 14:31:37 EDT
I'm having problems getting newer gpsd's built in koji at all right now (fine in local mock), but I'll try to ping you once gpsd 2.39 builds/lands in rawhide.  I haven't figured out what to do about F-9/10 yet due to this soname bump.  AFAICT, kdeedu-marble is the only package that links directly to libgps.
Comment 5 Rex Dieter 2009-03-23 11:23:58 EDT
triaged.
Comment 6 Douglas E. Warner 2009-03-25 10:58:59 EDT
gpsd 2.39 is currently building for rawhide (scratch builds worked fine); I'm still trying to decide what to do for F-9 and F-10.
Comment 7 Kevin Kofler 2009-03-25 11:45:40 EDT
If kdeedu-marble is the only user, we can simply bundle it with our KDE 4.2.2 update. Just build it for F9 and F10 and ask Rex to tag it into the buildroots.
Comment 8 Douglas E. Warner 2009-03-25 16:59:35 EDT
Okay; F9 and F10 is built; feel free to get it tagged for building against.
Comment 9 Rex Dieter 2009-03-25 17:07:07 EDT
ok, tagging gpsd-2.39-3.fc9 gpsd-2.39-3.fc10 for buildroots.  Beware of upgrade paths though, the latest build for rawhide/F11 is older, currently gpsd-2.39-2.fc11
Comment 10 Rex Dieter 2009-03-25 17:08:38 EDT
kdeedu built for rawhide. 

The rest will go out with kde-4.2.2 update.
Comment 11 Rex Dieter 2009-03-26 11:27:25 EDT
Douglas, I'll I spun kdeedu-4.2.1-3 builds here too, what timeline did you have in mind for F-9/F-10 updates?  If you'd rather this go sooner, I can issue testing updates asap. (I think I'd personally prefer that than waiting for kde-4.2.2 at this point, but I'd rather hear what you think).
Comment 12 Douglas E. Warner 2009-03-26 11:34:38 EDT
No hurry here; I haven't pushed it to testing yet since I wanted to wait to see if we could do a combined push.
Comment 13 Rex Dieter 2009-03-26 11:38:33 EDT
ok, I'd propose we batch things in:
https://admin.fedoraproject.org/updates/F9/FEDORA-2009-3052
https://admin.fedoraproject.org/updates/F10/FEDORA-2009-3059

sound like a plan?
Comment 14 Douglas E. Warner 2009-03-26 11:45:24 EDT
Works for me; I can't add gpsd to your update, can you add it?
Comment 15 Douglas E. Warner 2009-03-26 11:45:59 EDT
You could also add this bug as fixed by the update
Comment 16 Rex Dieter 2009-03-26 12:08:54 EDT
ok, done.

Note You need to log in before you can comment on or make changes to this bug.