Bug 491439 - Error activating xkb configuration
Error activating xkb configuration
Status: CLOSED DUPLICATE of bug 483195
Product: Fedora
Classification: Fedora
Component: xkeyboard-config (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 20:28 EDT by Need Real Name
Modified: 2009-04-01 15:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 15:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2009-03-20 20:28:42 EDT
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
10600000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd


$ xprop -root|grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "nodeadkeys", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "de", "", ""

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [de_AT.UTF-8]
 options = []
 model =
Comment 1 Mike Gahagan 2009-03-25 14:27:08 EDT
Here is another one from a KVM guest install, updated to today's rawhide.

[mike@localhost ~]$ cat *.out
 layouts = [en_US.UTF-8]
 options = []
 model = 
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "us", "", ""
[mike@localhost ~]$ cat xprop.out 
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "evdev", "us", "", ""
[mike@localhost ~]$ cat gcpmftool.out 
 layouts = [en_US.UTF-8]
 options = []
 model = 

I think bz 491759 might be a dup of this bug (there are a few others as well)
Comment 2 Andreas Thienemann 2009-04-01 15:30:35 EDT

*** This bug has been marked as a duplicate of bug 483195 ***

Note You need to log in before you can comment on or make changes to this bug.