Bug 491508 - "Utrace:" line in /proc/$pid/status has unusual format, breaks parsing in yum
"Utrace:" line in /proc/$pid/status has unusual format, breaks parsing in yum
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 491482 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 06:46 EDT by Michal Schmidt
Modified: 2009-03-24 05:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: kernel-2.6.29-0.279.rc8.git6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 05:11:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2009-03-22 06:46:50 EDT
Description of problem:
All lines in /proc/$pid/status use a colon and a tab to separate the key from value(s). The only exception in the "Utrace: " line which uses a space instead of the tab.
This breaks yum's show_lock_owner function which parses this file and expects the key/value separator to be ':\t'.
yum could be made more robust here, but it's better if the kernel keeps the format of the lines consistent, because who knows what other software may have the same expectation.

Version-Release number of selected component (if applicable):
kernel-2.6.29-0.267.rc8.git4.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. Look at /proc/self/status with a hex editor
2. See the "Utrace: " line.
  
Actual results:
The character after the colon is a space (0x20).

Expected results:
The character after the colon should be a tab (0x9).

Additional information:
The faulty line is printed in kernel/utrace.c:task_utrace_proc_status(), it comes from linux-2.6-utrace.patch.
Comment 1 Roland McGrath 2009-03-22 22:27:37 EDT
Should be fixed in the next rawhide kernel build.
Comment 2 Michal Schmidt 2009-03-23 13:17:20 EDT
*** Bug 491482 has been marked as a duplicate of this bug. ***
Comment 3 Michal Schmidt 2009-03-24 05:11:09 EDT
It works now. Thanks.

Note You need to log in before you can comment on or make changes to this bug.